Bug 119683 - Draw Export Section
Summary: Draw Export Section
Status: RESOLVED DUPLICATE of bug 125062
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Graphics-Export
  Show dependency treegraph
 
Reported: 2018-09-04 08:01 UTC by andreas_k
Modified: 2019-06-03 12:04 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
broken aspect ration when export (102.24 KB, image/png)
2018-09-04 08:01 UTC, andreas_k
Details
origin odg file (11.99 KB, application/vnd.oasis.opendocument.graphics)
2018-09-04 09:24 UTC, andreas_k
Details
Screenshot of 4 export files from the same source. (33.10 KB, image/jpeg)
2019-03-31 16:23 UTC, Erik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2018-09-04 08:01:00 UTC
Created attachment 144654 [details]
broken aspect ration when export

When you would like to export an drawing in Draw to .png and don't say >selection< than the aspect ratio of the png file is broken.
Comment 1 Roman Kuznetsov 2018-09-04 09:19:23 UTC
Andreas, please attach example ODG file
Comment 2 andreas_k 2018-09-04 09:24:58 UTC
Created attachment 144661 [details]
origin odg file
Comment 3 Regina Henschel 2018-09-04 11:29:40 UTC
I can confirm the behavior for Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: de-DE (en_US); Calc: CL

The bounding box of the drawing is stretched to the page size.

It is OK in Version: Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL
Comment 4 Xisco Faulí 2018-09-04 14:00:39 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=046df0a876b3d948bb1e14443c00c180bc8cccaa

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-16 20:20:47 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-17 21:27:40 +0200
commit 046df0a876b3d948bb1e14443c00c180bc8cccaa (patch)
tree 9619fa49b3f1b66302cbae973603f1c3f41ba3b0
parent bc28d51cb88c796da241d1ab914bbe6bb174cc49 (diff)
tdf#105998: Enhanced fix for MetafileToBitmap at better place

Bisected with: Armin Le Grand

Adding Cc: to bibisect-linux64-6.2
Comment 5 Erik 2019-03-25 22:28:17 UTC
Version 6.2.2.2 (x64)

Draw export to .gif .png
I made a round object on A4 format.(fontwork letter C)
The object is smaller than 50% of the page.
The rest of the page is empty.
Export to gif/png stretches the object to the outlines of the page.
On A4 I see an egg shaped object that is maximized to the outlines.
Export to .gif gives the same image size but the object has the correct size.
Comment 6 Erik 2019-03-31 16:07:01 UTC
(In reply to Erik from comment #5)
> Version 6.2.2.2 (x64)
> 
> Draw export to .gif .png
> I made a round object on A4 format.(fontwork letter C)
> The object is smaller than 50% of the page.
> The rest of the page is empty.
> Export to gif/png stretches the object to the outlines of the page.
> On A4 I see an egg shaped object that is maximized to the outlines.

Correction. 
Export to .jpg .pdf .tif .svg .bmp gives the same image size but the object has the correct size.
Comment 7 Erik 2019-03-31 16:23:05 UTC
Created attachment 150428 [details]
Screenshot of 4 export files from the same source.
Comment 8 Xisco Faulí 2019-06-03 12:04:02 UTC
The problem only happens when 'Save Transparency' is selected
Closing as duplicate of bug 125062. I'll provide a patch for it...

*** This bug has been marked as a duplicate of bug 125062 ***