Bug 125062 - Export as PNG with transparency changes shape of objects radically
Summary: Export as PNG with transparency changes shape of objects radically
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bibisected, bisected, regression
: 119683 (view as bug list)
Depends on:
Blocks: Graphics-Export
  Show dependency treegraph
 
Reported: 2019-05-01 15:06 UTC by Derek Keats
Modified: 2020-10-02 01:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image showing results without transparency behaves as expected (130.90 KB, image/png)
2019-05-01 15:08 UTC, Derek Keats
Details
Image showing results with transparency behaves as described (196.87 KB, image/png)
2019-05-01 15:09 UTC, Derek Keats
Details
showcase of the issue (40.32 KB, image/png)
2019-05-24 23:43 UTC, Usama
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Keats 2019-05-01 15:06:47 UTC
Description:
If you choose export to PNG without background transparency, then the images is exported as expected  with the correct aspect ratio. However,if you choose to export with transparency, then the area covered by objects on the canvas is exported, not the whole canvas, and the objects are then changed in aspect to match the chosen aspect ratio. The result is not usable. 

Steps to Reproduce:
1. Create a canvas of (say) 1920 x 1080
2. Place objects on the canvas
3. Choose FIlE |EXPORT
4. Choose foobar.png as the file name
5. Under Drawing Objects on the dialog, choose Save transparency  
6. Click OK. 



Actual Results:
The image is saved but the objects on the canvas are stretched to match the dimensions of the canvas, and the canvas is not shown at all. 

Expected Results:
The image would be exported with the same size as the canvas, without showing the canvas (background), but retaining the dimensions and aspect ratio chosen. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu2
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-ZA (en_ZA.UTF-8); UI-Language: en-ZA
Comment 1 Derek Keats 2019-05-01 15:08:13 UTC
Created attachment 151112 [details]
Image showing results without transparency behaves as expected
Comment 2 Derek Keats 2019-05-01 15:09:26 UTC
Created attachment 151113 [details]
Image showing results with transparency behaves as described
Comment 3 Derek Keats 2019-05-01 15:51:28 UTC
Interestingly, version 6.0.4.2 on Windows does not behave in this way, but rather behaves as expected.
Comment 4 Usama 2019-05-24 23:43:31 UTC
Created attachment 151669 [details]
showcase of the issue

Hello Derek,
Thank you for reporting this bug. I confirm it on master:
Version: 6.3.0.0.alpha1+
Build ID: 40e2a0d7039eee9c5377996da3949680903e1016
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-22_13:55:35
Locale: hu-HU (en_GB.utf8); UI-Language: en-US
Calc: threaded

But not on:

Version: 6.1.5.1
Build ID: 1:6.1.5~rc1-2~bpo9+1
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.utf8); Calc: group threaded

Setting it to new
Comment 5 James Gimbel 2019-05-31 05:21:20 UTC Comment hidden (spam)
Comment 6 Xisco Faulí 2019-06-03 11:07:25 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=046df0a876b3d948bb1e14443c00c180bc8cccaa

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-16 20:20:47 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-08-17 21:27:40 +0200
commit 046df0a876b3d948bb1e14443c00c180bc8cccaa (patch)
tree 9619fa49b3f1b66302cbae973603f1c3f41ba3b0
parent bc28d51cb88c796da241d1ab914bbe6bb174cc49 (diff)
tdf#105998: Enhanced fix for MetafileToBitmap at better place

Bisected with: bibisect-linux64-6.2

Adding Cc: to Armin Le Grand
Comment 7 Xisco Faulí 2019-06-03 12:04:02 UTC
*** Bug 119683 has been marked as a duplicate of this bug. ***
Comment 8 V Stuart Foote 2019-06-03 13:51:16 UTC
Not just Impress--in the graphics stack, adjusting. Also, Xisco has said he'll patch it...
Comment 9 Xisco Faulí 2019-06-03 14:42:45 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/73391/
Comment 10 Commit Notification 2019-06-05 14:29:35 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6c31c2b01dd32cc7ba1230f2c4a98b8f7def219b%5E%21

tdf#125062: distort hairline borders only if selection is used

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-06-05 18:05:34 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/95ffc97e9dc1c7ba2f13f6b46e495608f70bbe96%5E%21

tdf#125062: distort hairline borders only if selection is used

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-06-08 16:58:27 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/fd4324c64a6919ef46328608b447decc5c5f2d49%5E%21

tdf#125062: distort hairline borders only if selection is used

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 msh 2020-10-02 01:57:39 UTC
Hi, 

>It will be available in 6.2.5.

Has this fix ever been rolled out? Because I ran into the same problem under a later version, 6.4.5.2 (see bug 135348 which I have now realized might be a duplicate of this).