Bug 119771 - Wrong and enlarged PDF export of image (OpenGl)
Summary: Wrong and enlarged PDF export of image (OpenGl)
Status: RESOLVED DUPLICATE of bug 121615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: VCL-OpenGL PDF-Export
  Show dependency treegraph
 
Reported: 2018-09-09 18:59 UTC by Pierre C
Modified: 2019-03-25 15:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (237.49 KB, application/vnd.oasis.opendocument.graphics)
2018-09-09 18:59 UTC, Pierre C
Details
Result pdf file (102.92 KB, application/pdf)
2018-09-09 18:59 UTC, Pierre C
Details
export from 6.2 (177.83 KB, application/pdf)
2018-09-09 19:31 UTC, raal
Details
PDF Options (23.94 KB, image/png)
2019-03-10 14:59 UTC, Pierre C
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre C 2018-09-09 18:59:11 UTC
Created attachment 144759 [details]
Test file

The PDF is absolutely wrong, image is bigger than it should

I've some similar problem with writer

open The test file, export to PDF, and see the result

Image is just a copy-past from Xnview
Comment 1 Pierre C 2018-09-09 18:59:59 UTC
Created attachment 144760 [details]
Result pdf file
Comment 2 raal 2018-09-09 19:31:49 UTC
Created attachment 144761 [details]
export from 6.2

Tested with Version: 6.2.0.0.alpha0+
Build ID: 4b5fcd417587cfb9e6d8b61ecb037ab165eeb5b9
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 

Looks correct, please check my file.
Comment 3 Regis Perdreau 2018-09-09 20:07:42 UTC
Everything correct for me.

Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: x11; 
Locale : nl-NL (fr_FR.UTF-8); Calc: group
Comment 4 Pierre C 2018-09-09 21:51:59 UTC
So Maybe a specific bug to W10.
I've just made a test with LO 6.1 dev => Same problem
Or to my specific hardware. I will try tomorrow on my Laptop (same OS and LO ver) but different GPU
Comment 5 raal 2018-09-10 11:42:19 UTC
Please, could you test with dev version? You can install it alongside standard version. Download here: http://dev-builds.libreoffice.org/daily/master/
I have not problem on win7, LO 6.2
Thank you
Comment 6 Pierre C 2018-09-13 06:34:29 UTC
I've made some tests yesterday

On my desktop : Test with latest LODev => Worng PDF

Test With my LapTop LO 6.0.6.2 and LO master dev => Wrongs PDF

All these two computers rune W10 x64
All LO versions Downloaded are 64 bits

I must Add that not all images cause problem
On the test document I gave, there were three slide. One was good, two were wrong

On a writer document, with about 50 images, only two were wrong
Comment 7 Xisco Faulí 2018-09-17 11:24:59 UTC Comment hidden (no-value)
Comment 8 Pierre C 2018-09-17 21:48:58 UTC Comment hidden (no-value)
Comment 9 Xisco Faulí 2018-09-18 12:03:11 UTC
To be certain the reported issue is not related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 10 Timur 2018-09-18 14:34:10 UTC
Please try both with and without OpenGL and also print (to real or virtual printer like PDFill).
Comment 11 Timur 2018-09-18 14:35:35 UTC
And write your PDF image export options or attach screenshot.
Comment 12 Pierre C 2018-09-19 14:16:10 UTC
It seems to be an OpenGL problem
With OpenGL disabled PDF export is fine.
With Safe mode, PDF export is fine (but OpenGL is disabled)

Graphic card is a NVidia GTX960 with latest drivers
Comment 13 Xisco Faulí 2018-09-20 08:42:18 UTC
So, this is an OpenGL problem...
Comment 14 Pierre C 2018-09-20 11:56:06 UTC
Yes an OpenGL problem, but not specific to my GPU or driver. With my Laptop, the problem is the same GPU Intel HD 520
Comment 15 Jia_you 2018-11-29 08:33:30 UTC
Bug not reproducible in Version: 6.3.0.0.alpha0+ (x64)

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: zh-TW (zh_TW); UI-Language: en-US
Comment 16 Xisco Faulí 2019-01-23 13:11:44 UTC
Hello Pierre C,
Could you please try to reproduce it with LibreOffice 6.2.0.2 from
https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 17 Pierre C 2019-03-10 14:53:27 UTC
Tested With LO 6.2.2.1 and LO 6.3 dev Version: 6.3.0.0.alpha0+ (x64)
Build ID: 4f810905fa74128871f2fe924a3d28a79f4e4261
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-07_00:55:12
Locale: fr-FR (fr_FR); UI-Language: en-US
Calc: CL

Same problem
Comment 18 Pierre C 2019-03-10 14:59:08 UTC
Created attachment 149861 [details]
PDF Options
Comment 19 Luboš Luňák 2019-03-25 15:12:58 UTC

*** This bug has been marked as a duplicate of bug 121615 ***