Bug 119883 - Migration dialog closing LibreOffice if a table has been copied previously
Summary: Migration dialog closing LibreOffice if a table has been copied previously
Status: RESOLVED DUPLICATE of bug 121599
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Database-Firebird-Migration
  Show dependency treegraph
 
Reported: 2018-09-14 15:45 UTC by Xisco Faulí
Modified: 2022-03-04 13:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video demostrating the issue (664.31 KB, video/mp4)
2018-09-17 08:54 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-09-14 15:45:10 UTC
Steps to reproduce:
1. Open a HSQLDB file ( e.g. attachment 141727 [details] )
2. Go to table and say Later to the migration dialog
3. Right click on the table - Copy
4. Close LibreOffice

-> The migration dialog is displayed

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 4e5f89d2d3511b6421b388ecaba2f61ada14d084
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 1 Xisco Faulí 2018-09-14 15:57:30 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1c5c9b84df270e41c68e68bb69fbf183fc20eed2

author	Tamas Bunth <tamas.bunth@collabora.co.uk>	2018-04-23 22:05:55 +0200
committer	Tamás Bunth <btomi96@gmail.com>	2018-05-05 11:10:07 +0200
commit 1c5c9b84df270e41c68e68bb69fbf183fc20eed2 (patch)
tree 10a9dd4f2888224dd776a8ed4703e5fd91f201e4 /dbaccess/source/core/dataaccess/datasource.cxx
parent 60413c9800c27f53c1108015b50754b065bc98c6 (diff)
Refactor: migration warn dlg without modifying API

Bisected with: bibisect-linux64-6.1

Adding Cc: to Tamas Bunth
Comment 2 Drew Jensen 2018-09-14 18:40:53 UTC
So, using Ubuntu 18.04 and LbreOffice 6.1.1.1 and 6.2Alpha 
Just copy of the table to the clipboard does not display the migration dialog.
I'm assuming there is another step here:

4. Close the Base file
5. Paste the data from the table into another document.

This triggers the migration assistant another time; 

While:

4. Leave the Base file open
5. Paste data from table into another document

does not trigger the migration assistant dialog again.
Comment 3 Xisco Faulí 2018-09-17 08:54:14 UTC
Created attachment 144929 [details]
Video demostrating the issue
Comment 4 Drew Jensen 2018-09-17 12:45:04 UTC
(In reply to Xisco Faulí from comment #3)
> Created attachment 144929 [details]
> Video demostrating the issue

Well, I was not able to reproduce that using Linux.
Comment 5 QA Administrators 2019-09-18 02:52:40 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2021-09-18 03:26:37 UTC Comment hidden (obsolete, spam)
Comment 7 Justin L 2022-03-04 11:51:48 UTC
Testing this requires experimental features to be turned on (tools options LibreOffice Advanced).

Fixed in LibreOffice 6.4/6.3.1 by author Xisco Fauli on 2019-07-31 03:49:17 +0200
commit 77ef0a92b3bd19f836d0fcb2a41af5e643129283
    tdf#121599, tdf#123099: ignore migration dialog when
    1. a new HSQLDB database is created
    2. the HSQLDB database is not opened interactively

*** This bug has been marked as a duplicate of bug 121599 ***
Comment 8 Xisco Faulí 2022-03-04 13:14:01 UTC
(In reply to Justin L from comment #7)
> Testing this requires experimental features to be turned on (tools options
> LibreOffice Advanced).
> 
> Fixed in LibreOffice 6.4/6.3.1 by author Xisco Fauli on 2019-07-31 03:49:17
> +0200
> commit 77ef0a92b3bd19f836d0fcb2a41af5e643129283
>     tdf#121599, tdf#123099: ignore migration dialog when
>     1. a new HSQLDB database is created
>     2. the HSQLDB database is not opened interactively
> 
> *** This bug has been marked as a duplicate of bug 121599 ***

oh nice, I fixed my own issue without even knowing