Bug 120050 - File Save crash General Error. General input/output error since release 6.1 - works until 6.0.6
Summary: File Save crash General Error. General input/output error since release 6.1 -...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save Crash
  Show dependency treegraph
 
Reported: 2018-09-22 09:13 UTC by RobG
Modified: 2020-12-21 14:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen shot of crash (10.60 KB, image/jpeg)
2018-09-22 09:16 UTC, RobG
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RobG 2018-09-22 09:13:12 UTC
Description:
Why I try to save back my opened .xlsx file (which I use for ages) or try to save as .xls or .odp, LibreOffice since version 6.1 (incl. 6.1.1.2) crashes.

All works perfectly with release 6.0.6.

Steps to Reproduce:
1. Open my .xlsx (but can't give it away for testing)
2. Save, save As .xlsx or .xls or .odp


Actual Results:
Error Window appears since version 6.1 incl. 6.1.1.2 =>

Error saving the document Test:
General Error.
General input/output error.


Expected Results:
Should save the file without problems


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.1.2 (x64)
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_AT); Calc: CL
Comment 1 RobG 2018-09-22 09:16:49 UTC
Created attachment 145103 [details]
Screen shot of crash
Comment 2 Xisco Faulí 2018-09-22 17:46:29 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 3 RobG 2019-01-27 10:25:14 UTC
I've just downloaded 6.1.4.2 and re-tested it if it still happens and it looks like the bug has been fixed or found anywhere else.

No error anymore.

I set the status to RESOLVED.

Sorry for delay.
Comment 4 Xisco Faulí 2019-01-27 22:36:37 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.
Comment 5 RobG 2019-01-28 15:44:35 UTC
MS Excel 2010 (which we use in the office) isn't able to open the fresh stored .xlsx with 6.1.4.2 anymore. Reports an error. Didn't happen with saved version 6.0.6.

I will create a new ticket for it with screen shots asap.
Comment 6 RobG 2019-02-09 19:58:47 UTC
(In reply to Xisco Faulí from comment #4)
> Thanks for retesting with the latest version.
> Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been
> identified.

It just happened again.

Work with my .xlsx (LO 6.1.4.2) file, added, delete, updated rows ... just try to save the file .. General error again.

Also when I close LO and re-open file - no chance to save/save as. General input/output error.

I will re-open and try to create a test file. Problem is it contains sensitive information - maybe when I remove it it will work.
Comment 7 RobG 2019-02-09 20:01:20 UTC
Also when I try to save as .ods file ... General input/output error.
Comment 8 Xisco Faulí 2019-02-11 11:41:08 UTC
(In reply to RobG from comment #7)
> Also when I try to save as .ods file ... General input/output error.

Please, attach the document. Otherwise, there is nothing we can do from our side
Comment 9 RobG 2019-03-05 11:21:28 UTC
I've found out that the .ods or .xlsx might not be the problem.

When I open the file with LO => 6.1 and have it open for a longer time, use filter, etc. add a line and then I want to save it back, I get the error.

When I use "save as" (regardless ods or xlsx) and save it on another drive it works.

When I use "save as" on the same drive from the original drive it doesn't work.

The drive has no error (chkdsk) and I can copy the file from / to drive (same file name + path) without any problems.

I can use save as from any other application - I've also opened the file with HxD, was able to change a byte and save it back.

When I reboot the PC and open the file with LO and use save or save as on original drive - it works.

Only when I've open LO, work on the file (filter, insert, update rows/cells) - maybe for a longer time - I get the error for this drive only!

This does not happen when I use LO 6.0.x!

The error is "General input/output error" - so aren't there any better details what exactly has happened?

Is there a detailed log file which I can produce with a better error message?

I think this error will be hard to find. Only a source diff between 6.0.x and 6.1 and code-review what has changed and might be the issue might help.
Comment 10 Xisco Faulí 2019-03-21 10:22:30 UTC
Please, attach the document, otherwise we can't investigate this issue...
Comment 11 RobG 2019-08-15 13:10:01 UTC
My .xlsx file is not the problem - it happens with every .xlsx.

I save it and it reports "General I/O error".
File will be saved on external USB drive.
It happens after some time Libre Calc is running. 
Restart Libre Calc doesn't help.
Pre-Loading is disabled.
Restart of PC, open it and save works on hard disc (which is not turned off/on).
"Save as" on another external hard disc works.
Re-connecting USB drive on other USB port (incl. on USB PCIe) doesn't help.
When I get the save error, close Libre Calc, I can copy the file from the other USB over the file with the reported error. So finally there is no error on hard disc.
Also chkdsk reports no error.

I installed 6.0.6 and used it for a longer time - no problems happened.

It still happens with 6.3.0.

I only use xlsx - I would have to test with other open file formats.

Still mysterious.
Comment 12 QA Administrators 2019-08-19 07:10:22 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2019-08-19 08:06:24 UTC
To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 14 QA Administrators 2020-02-16 02:05:31 UTC Comment hidden (obsolete)
Comment 15 RobG 2020-02-16 15:23:18 UTC
(In reply to Xisco Faulí from comment #13)
> To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

UserProfile is not the problem.

Latest status:

- I open LibreOffice > 6.0.6 with a .xlsx or .ods file.
- I edit/save the file multiple times.
- I have it open for a longer time and do nothing.
- After a longer time I continue to edit the file. It may work or not. When it doesn't work => Reported error.
- Also save as ".csv" or any other format on the same(!) drive on any place is not possible.
- Save on any other drive is possible.
- With Explorer I can copy it back to it's original place/drive and open it with LibreOffice, but not save on this drive anymore.

I have no issues with the drive. Any other program works it (open/save).

Close + Start of LibreOffice doesn't help.

I MUST restart the computer - then it works.

It doesn't happen until 6.0.6.

Is any LibreOffice service running in the background although I've started it manually and closed it? Or any external library/service used?

I only know and read that the performance from open/save .xlsx to version 6.1 has been increased. My there was a change "under the hood" which might be the problem?
Comment 16 Buovjaga 2020-05-09 14:18:36 UTC
As we are unable to test (we would need access to your machine), you can try to do a binary bisect of the issue: https://wiki.documentfoundation.org/QA/Bibisect
Use the bibisect-win32-6.1 repository from https://wiki.documentfoundation.org/QA/Bibisect/Windows
Comment 17 Thomas Lendo QA 2020-09-25 20:28:00 UTC
Looks like a duplicate of Bug 113138 - FILESAVE general input/output error on save, files truncated ?
Comment 19 RobG 2020-12-21 14:40:37 UTC
You can close this ticket now.

Reason was a bad hard disc but LibreOffice had a problem with it - maybe something was cached anywhere - however?

With newer hard disc I don't have the problem anymore.

Thanks