Bug Hunting Session
Bug 120136 - Extension Manager: Check for Updates button caused Writer to crash
Summary: Extension Manager: Check for Updates button caused Writer to crash
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: corruptProfile
Depends on:
Blocks: Extension-Manager
  Show dependency treegraph
 
Reported: 2018-09-26 14:27 UTC by gorsewood
Modified: 2019-02-03 23:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["dp_gui::UpdateDialog::Thread::execute()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gorsewood 2018-09-26 14:27:35 UTC
This bug was filed from the crash reporting server and is br-74b70586-6f90-47da-9efe-46e5febdb317.
=========================================
Configuration error - using Extension Manager|Check for Updates button caused Writer to crash
Comment 1 Xisco Faulí 2018-09-26 16:21:10 UTC
Thanks for reporting the issue?
Did it happen just once or is it happening every time you go to the Check for Updates dialog?
Comment 2 gorsewood 2018-09-27 09:04:35 UTC
I have just tested with an empty document and it has happened again.
Comment 3 Telesto 2018-09-27 12:23:02 UTC
Is it possible to give a list of installed extensions (with version number). Excluding the default dictionary's?
Comment 4 gorsewood 2018-09-27 13:04:39 UTC
French spelling dictionary 6.3  dicollecte.org
German spelling dictionary 2017.01.12
Scottish Gaelic spell checker 3.3
Solver for Nonlinear Programming 0.9
Wiki Publisher 1.2.0
writer2latex 1.4
writer2html 1.4
Comment 5 gorsewood 2018-09-27 13:05:56 UTC
My mistake

writer2xhtml 1.4
Comment 6 Buovjaga 2018-10-23 13:22:14 UTC
Somehow similar to bug 118572
Might be interesting to install 6.2 and those extensions to it and try if it still crashes: https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
Comment 7 Dieter Praas 2018-11-04 22:14:43 UTC
(In reply to Buovjaga from comment #6)
> Somehow similar to bug 118572
> Might be interesting to install 6.2 and those extensions to it and try if it
> still crashes

=> I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 8 gorsewood 2018-11-06 12:37:27 UTC
I have just upgraded to 6.1.3.2 and the bug still exists.
Comment 9 Dieter Praas 2018-11-06 13:16:59 UTC
(In reply to gorsewood from comment #8)
> I have just upgraded to 6.1.3.2 and the bug still exists.

Actuially bug 118572 is only fixed in 6.2.0.0. So please try this version. => NEEDINFO
Comment 10 Xisco Faulí 2018-11-06 13:20:32 UTC
(In reply to Dieter Praas from comment #9)
> (In reply to gorsewood from comment #8)
> > I have just upgraded to 6.1.3.2 and the bug still exists.
> 
> Actuially bug 118572 is only fixed in 6.2.0.0. So please try this version.
> => NEEDINFO

Not related...
Comment 11 Xisco Faulí 2018-11-06 13:21:22 UTC
To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 12 gorsewood 2018-11-06 14:02:35 UTC
(In reply to Xisco Faulí from comment #11)
> To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

I have followed the instructions for resetting my user profile and that has cleared the problem.  Thank you.
Comment 13 Xisco Faulí 2018-11-06 14:14:42 UTC
Nice to know.
Closing as RESOLVED WORKSFORME
Comment 14 jay H 2019-02-03 14:35:58 UTC
Extension update probably failed because the resource it wanted (a url for a dictionary in my case) was not available. General solution, catch the URL-not-responding/delivering-data  and translate it into can't-update which hands back to UI as a "please try later", allowing user to continue with other activities?

I'm new to bug reporting. Libre-Office crashed for me on 02/02/2019, so I don't think it's resolved yet. Note the date.
Comment 15 Buovjaga 2019-02-03 15:13:42 UTC
(In reply to jay H from comment #14)
> I'm new to bug reporting. Libre-Office crashed for me on 02/02/2019, so I
> don't think it's resolved yet. Note the date.

Please open a new report and include your crash report.
Comment 16 Buovjaga 2019-02-03 17:22:10 UTC
Jay sent me a direct email:
"My Libre office crashed. I submitted the crash report. It said, on submission, don't report this separately if your bug already appears when you look up this number.

It did appear as bug 120136. (I believe the description is accurate, if possibly a little unspecific.) So I didn't report separately. Now I'm told to submit my crash report separately.  (I don't know where it is at present, perhaps it's somewhere in my profile still). Please advise."

As the signature matches, let's keep this open.

Jay: looking at the crash report history, I guess you are using version 6.1.3.2. It would still be good, if you would copy and paste here the contents of your Help - About.

Please also list the extensions you are using.
Comment 17 jay H 2019-02-03 23:52:19 UTC
I was asked to provide 

ABOUT Libre Office

Version: 6.1.3.2 (x64)  on 03/02/2019, likely true 02/02/2019
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-GB (en_GB); Calc: group threaded

See Log: 86daf60bf00efa86ad547e59e09d6bb77c699acb <link> 
hub.libre-office.org/git-core/86daf60bf00efa86ad547e59e09d6bb77c699acb

and what extensions I'm using: 02/02/2019

Adblock plus: installed, active
Bitdefender Wallet: installed, active

Livemarks: installed, not used but activated
Onetab: installed active
Firefox Multi-account Containers: installed and now disabled

I was trying to download  Grammalecte when Libre office crashed on 02/02/2019. It's file server was down. Grammalecte is now installed 03/02/2019