Bug 132901 - Tools > Options > LibreOffice > Online update crashes if "online update" feature is not installed
Summary: Tools > Options > LibreOffice > Online update crashes if "online update" feat...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: high major
Assignee: Xisco Faulí
URL:
Whiteboard: target:7.2.0 target:7.1.3 target:7.0.6
Keywords: bibisected, bisected, regression
: 135129 135318 135535 135544 135587 135680 135695 137229 139028 140560 141064 141118 141662 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-10 06:13 UTC by Ming Hua
Modified: 2021-05-01 09:48 UTC (History)
20 users (show)

See Also:
Crash report or crash signature: ["VCRUNTIME140_1.dll", "mergedlo.dll"]


Attachments
Online update crash (69.30 KB, image/png)
2021-02-08 06:59 UTC, Panos Stokas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Hua 2020-05-10 06:13:43 UTC
The Windows installer allows the user to select whether or not some optional features are installed.  "Online update" is one of the selectable optional features.

I recently installed 7.0.0 alpha1 on Windows 10, and chose to not install the online update feature.  After a successful installation, if I open Tools > Options... dialog, and click on the LibreOfficeDev > Online Update page, I get an error message in a dialog:
    (Dialog title) LibreOfficeDev 7.0 - Fatal Error
    cannot find /org.openoffice.Office.Jobs/Jobs/UpdateCheck/Arguments
and there is only a single button "OK".  Clicking the button seems to make LO hang.  Closing the dialog (using the "X" button on top left corner) seems to make LO quit.

Version: 7.0.0.0.alpha1 (x64)
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU 线程: 2; 操作系统: Windows 10.0 Build 18363; UI 渲染: Skia/Raster; VCL: win; 
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded
Comment 1 rygle 2020-08-08 06:51:22 UTC
Reproduced on both LO 7.0.0.3 and 7.0.1.0 Dev (2020-08-08_07.31.28), both x64 builds on Windows

Same as the OP, I chose to not install the Online Update component.

When I click on Online Update in the options dialogue, I get teh same error message, however the program crashes as soon as I click OK or the close "X" button. It does not hang, just quits.
Comment 2 Mike Kaganski 2020-08-09 13:58:53 UTC
*** Bug 135129 has been marked as a duplicate of this bug. ***
Comment 3 Mike Kaganski 2020-08-09 13:59:04 UTC
*** Bug 135318 has been marked as a duplicate of this bug. ***
Comment 4 Mike Kaganski 2020-08-09 13:59:16 UTC
*** Bug 135544 has been marked as a duplicate of this bug. ***
Comment 5 Mike Kaganski 2020-08-09 13:59:56 UTC
*** Bug 135535 has been marked as a duplicate of this bug. ***
Comment 6 Mike Kaganski 2020-08-09 14:01:07 UTC
In LibreOffice_6.3.0.4_Win_x64.msi, we have three elements in FeatureComponents table for gm_o_Onlineupdate:

> gm_o_Onlineupdate    auto_onlineupdate_lib_updatecheckui__libreoffice_program
> gm_o_Onlineupdate    auto_onlineupdate_lib_updchk__libreoffice_program
> gm_o_Onlineupdate    gid_file_share_registry_onlineupdate_xcd__libreoffice_share_registry



In LibreOffice_7.0.0.3_Win_x64.msi, we only have one entry related to gm_o_Onlineupdate: the last one.
Comment 7 Mike Kaganski 2020-08-09 16:13:58 UTC
The relevant places are:

Repository.mk:

> ...
> $(eval $(call gb_Helper_register_libraries_for_install,OOOLIBS,onlineupdate, \
> 	$(if $(ENABLE_ONLINE_UPDATE), \
> 		updatecheckui \
> 		updchk \
> 	) \
> ))
> ...

scp2/AutoInstall.mk
scp2/InstallModule_onlineupdate.mk
scp2/InstallScript_setup_osl.mk
scp2/source/onlineupdate/file_onlineupdate.scp
scp2/source/onlineupdate/module_onlineupdate.scp

And they seem to be not modified lately in the related places...
As I mentioned in bug 135579 comment 2, I suspect changes in tdf#130911.
Comment 8 Mike Kaganski 2020-08-09 21:21:34 UTC
... and building MSI for current master produces all three entries ...

May cloph have any idea what is different in the generation of MSI package?
Comment 9 baffclan 2020-08-09 22:30:58 UTC
*** Bug 135587 has been marked as a duplicate of this bug. ***
Comment 10 Mike Kaganski 2020-08-12 19:26:09 UTC
*** Bug 135680 has been marked as a duplicate of this bug. ***
Comment 11 Ming Hua 2020-08-13 17:41:38 UTC
*** Bug 135695 has been marked as a duplicate of this bug. ***
Comment 12 Mike Kaganski 2020-12-18 11:36:03 UTC
*** Bug 139028 has been marked as a duplicate of this bug. ***
Comment 14 Panos Stokas 2021-02-08 06:59:46 UTC
Created attachment 169568 [details]
Online update crash

I've just upgraded to LO 7.1 from the last 6.x version and when I go to Options > LibreOffice > Online Update  it crashes.

May be useful: the last checked string as underlined in the screenshot.

Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 15 raal 2021-02-15 05:50:47 UTC
*** Bug 137229 has been marked as a duplicate of this bug. ***
Comment 16 baffclan 2021-03-06 08:17:36 UTC
Crash in: mergedlo.dll

This bug was filed from the crash reporting server and is br-c3151715-e95f-4cd7-893c-e1cb5b771e70.
=========================================

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 8e49505fa7352023c252bf794ae84c9082d7264e
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL
Comment 18 Mike Kaganski 2021-03-16 12:57:29 UTC
*** Bug 141064 has been marked as a duplicate of this bug. ***
Comment 19 Ming Hua 2021-03-21 02:39:12 UTC
*** Bug 141118 has been marked as a duplicate of this bug. ***
Comment 20 Xisco Faulí 2021-04-13 07:43:21 UTC
*** Bug 141662 has been marked as a duplicate of this bug. ***
Comment 21 Xisco Faulí 2021-04-16 10:09:20 UTC
I do reproduce the issue when I build LibreOffice myself with

--enable-64-bit
--with-package-format=msi
--enable-online-update
--enable-breakpad
--without-junit
--without-helppack-integration
--enable-extension-integration
--enable-scripting-beanshell
--enable-scripting-javascript
--enable-ext-wiki-publisher
--enable-ext-nlpsolver
--with-vendor=Xisco
--disable-dependency-tracking
--enable-mergelibs

however, if I don't use "--enable-mergelibs" I don't reproduce it.
Comment 22 Xisco Faulí 2021-04-18 17:16:46 UTC
After a long bisection, I found this issue started to happen after

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c63148ba139bd6b9ae7a0f9e24e51f29e5370963

author	Noel Grandin <noel.grandin@collabora.co.uk>	2020-03-11 07:51:54 +0100
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-03-11 08:36:39 +0100
commit	c63148ba139bd6b9ae7a0f9e24e51f29e5370963 (patch)
tree	fee101874fc4d88f6e0e4bc6264963bfe6ba6b94
parent	6b40c791b50bcadbdd62f990adf08e783902144f (diff)
Revert "Revert "add some libs to libmerged""

My proposal would be to remove the update checker from the libmerged for now: https://gerrit.libreoffice.org/c/core/+/114247
Comment 23 Commit Notification 2021-04-18 19:41:11 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6064446f828f8cd612f7d6660153b2eb1139239b

tdf#132901: do not add updatecheck to libmerged

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Xisco Faulí 2021-04-19 12:08:24 UTC
Just to me sure, I jut downloaded a recent daily build from https://dev-builds.libreoffice.org/daily/master/current.html including my patch and the issue is fixed in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 6aa418bc1db541d40cbc34fb0be9f16cb0019c65
CPU threads: 1; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: pt-PT
Calc: threaded

Closing as RESOLVED FIXED
Comment 25 Commit Notification 2021-04-19 13:53:35 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/2b258e8c5e0bd12af1ecea76be99bb384327fda9

tdf#132901: do not add updatecheck to libmerged

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2021-04-19 14:28:05 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c656b1048f0efbbe36c78de357dd03845c38177c

tdf#132901: do not add updatecheck to libmerged

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2021-04-20 09:26:11 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-3":

https://git.libreoffice.org/core/commit/2854c1a37d60990e319c7218c58f24eb2c807c97

tdf#132901: do not add updatecheck to libmerged

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Dieter 2021-04-29 15:27:24 UTC
*** Bug 140560 has been marked as a duplicate of this bug. ***
Comment 29 Ming Hua 2021-05-01 09:48:47 UTC
Confirmed in 7.2.0 master daily build (2021-04-30):
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 18e5e948dd66e41f17b0a63bf631d98aee84a03b
CPU threads: 2; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: zh-CN (zh_CN); UI: zh-CN
Calc: threaded

There is no "Online Update" section anymore in Tools > Options > LibreOfficeDev if the feature is not selected at installation time.

Thanks Xisco for the fix!