Bug Hunting Session
Bug 120512 - FILEOPEN DOCX Tables in document do not appear until deleting a row in MS Word
Summary: FILEOPEN DOCX Tables in document do not appear until deleting a row in MS Word
Status: RESOLVED DUPLICATE of bug 116194
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2018-10-11 12:31 UTC by NISZ LibreOffice Team
Modified: 2019-12-09 12:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The document with the issue. (28.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-11 12:32 UTC, NISZ LibreOffice Team
Details
The original document exported as PDF with MS Word. (5.34 KB, application/pdf)
2018-10-11 12:32 UTC, NISZ LibreOffice Team
Details
The fixed document after deleting the problematic row. (27.23 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-11 12:32 UTC, NISZ LibreOffice Team
Details
A screenshot showcasing the issue. (78.62 KB, image/png)
2018-10-11 12:33 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-10-11 12:31:31 UTC
Description:
This document has a few simple, 1 column width tables that do not appear in LibreOffice Writer. Deleting one specific row/cell fixes the tables in the document.

Steps to Reproduce:
1.Steps to reproduce:
    1. Open the attached Table-lost.docx and Table-found.docx files in LibreOffice Writer and compare the results.
2.
3.

Actual Results:
The tables are lost in the Tables-lost.docx files.

Expected Results:
Tables should appear in both files.



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-10-11 12:32:03 UTC
Created attachment 145601 [details]
The document with the issue.
Comment 2 NISZ LibreOffice Team 2018-10-11 12:32:23 UTC
Created attachment 145602 [details]
The original document exported as PDF with MS Word.
Comment 3 NISZ LibreOffice Team 2018-10-11 12:32:48 UTC
Created attachment 145603 [details]
The fixed document after deleting the problematic row.
Comment 4 NISZ LibreOffice Team 2018-10-11 12:33:13 UTC
Created attachment 145604 [details]
A screenshot showcasing the issue.
Comment 5 Roman Kuznetsov 2018-10-11 15:06:59 UTC
confirm in

Version: 6.2.0.0.alpha0+
Build ID: d9ad59da50c1172fe98f94370221c9c1b688200a
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-08_23:34:44
Locale: ru-RU (ru_RU); Calc: threaded
Comment 6 Xisco Faulí 2018-10-12 12:21:46 UTC
Regression introduced by:

author	Luboš Luňák <l.lunak@collabora.com>	2014-04-23 14:34:54 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2014-04-23 14:57:36 +0200
commit	cf33af732ed0d3d553bb74636e3b14c55d44c153 (patch)
tree	2e83f55d54ab51faa1121f4bc31f71ec9e34fdd3
parent	71b4af858ea698f9c3fcffdfc61e3f70a7b10f63 (diff)
handle w:gridBefore by faking cells (fdo#38414)

Bisected with: bibisect-43max

Adding Cc: to Luboš Luňák
Comment 7 Gabor Kelemen 2018-10-28 22:45:05 UTC
*** Bug 120256 has been marked as a duplicate of this bug. ***
Comment 8 Timur 2019-06-06 13:08:23 UTC
I hope it's safe enough to mark this as a dupe.

*** This bug has been marked as a duplicate of bug 116194 ***