Bug 120674 - LibO crashes each time I try to add an object (button, check box, etc.) in a Dialog form
Summary: LibO crashes each time I try to add an object (button, check box, etc.) in a ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: highest critical
Assignee: Armin Le Grand (CIB)
URL:
Whiteboard: target:6.2.0 target:6.1.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2018-10-18 11:03 UTC by Paolo
Modified: 2018-10-29 16:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["basctl::DlgEdObj::SetDefaults()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo 2018-10-18 11:03:02 UTC
Description:
I'm programming Calc and I need to create a Dialog Box with some object. I can create the empty dialog box without problems. But I cannot insert any object in it (buttons, check box, list box, etc.): each time I try to insert one of these object LO crashes

Steps to Reproduce:
1. Open BASIC IDE
2. Edit dialog box
3. Try to insert an object

Actual Results:
Libre Office crashes and dialog box remains empty

Expected Results:
Inserting objects in dialog box in order to personalize it and use it as I need


Reproducible: Always


User Profile Reset: No



Additional Info:
Operating System where crashes: Ubuntu Linux 18.04.
No problem with Windows 10
Comment 1 tommy27 2018-10-18 11:42:59 UTC
which Linux version do you use?
did the same issue happen with LibO 6.0.6 too?
Comment 2 Xisco Faulí 2018-10-18 11:50:32 UTC
Reproduced in

Versión: 6.1.2.1
Id. de compilación: 65905a128db06ba48db947242809d14d3f9a93fe
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded
Comment 3 Xisco Faulí 2018-10-18 12:15:38 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4b4942224b550235da228655677b5c068a053254

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-16 22:34:50 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-05-25 12:31:32 +0200
commit	4b4942224b550235da228655677b5c068a053254 (patch)
tree	a660a04a1f7a3eee910da780ece271d68942201d
parent	f8edef392245c292398a80f6a858ca19f32df9c3 (diff)
SOSAW080: Derive SdrObjGroup from SdrObjList

Bisected with: bibisect-linux64-6.2

Adding Cc: to Armin Le Grand
Comment 4 Oliver Brinzing 2018-10-18 16:25:33 UTC
reproduced crash with

Version: 6.1.3.1 (x64)
Build-ID: a9670562c26181ec3afbe381c9ff499ae88c98b7
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: 

and

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b9234b43ed259a10cf9077032af0f79740f01d8b
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); Calc: threaded
Comment 5 Armin Le Grand (CIB) 2018-10-19 12:07:27 UTC
Yup, another case where without check the SdrPage was accessed from SdrObject with the SdrObject not being inserted to a SdrPage yet. This worked in the past since a ptr at SdrObject to the SdrPage was set early without the SdrObject being added to the SdrPage (inconsistent stage). Added the needed workaround to DlgEdObj::EndCreate() to have a valid DlgEdForm at the new DlgEdObj when DlgEdObj::SetDefaults() is called.
Comment 6 Armin Le Grand (CIB) 2018-10-19 12:08:15 UTC
Fix at gerrit: https://gerrit.libreoffice.org/#/c/62000/
Comment 7 Commit Notification 2018-10-22 08:28:43 UTC
Armin Le Grand committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=92b849b9297cbf78bddf5e48bdbd44303a7021db

tdf#120674 set DlgEdForm early in DlgEdObj::EndCreate

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-10-23 21:07:16 UTC
Armin Le Grand committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e582b7755c9d1e7e358cf5734c8b93d5219622d&h=libreoffice-6-1

tdf#120674 set DlgEdForm early in DlgEdObj::EndCreate

It will be available in 6.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-10-27 17:05:28 UTC
Armin Le Grand committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ed093ba595a8989928d363cf7752dedb546199f&h=libreoffice-6-1-3

tdf#120674 set DlgEdForm early in DlgEdObj::EndCreate

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2018-10-29 16:18:53 UTC
Verified in

Version: 6.2.0.0.alpha1+
Build ID: 19a0698079fbba36646a2d06eaec3a7fde60b2f5
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Armin, Thanks for fixing this!!!