Bug 121637 - change the default behavior of Calc to include a header and footer with page and sheet numbers
Summary: change the default behavior of Calc to include a header and footer with page ...
Status: RESOLVED DUPLICATE of bug 99296
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Header-Footer
  Show dependency treegraph
 
Reported: 2018-11-22 19:22 UTC by Roeland
Modified: 2021-08-31 08:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
comparison in excel, albeit in Dutch (40.98 KB, image/png)
2018-12-09 19:01 UTC, Roeland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roeland 2018-11-22 19:22:45 UTC
Description:

When creating a new spreadsheet and exporting to pdf or printing it there’s also a header and footer exported with sheet and page number (“sheet1” and “page 2”) for example.

This header/footer is per default set as on. There's no way to know this until you print/export your fist spreadsheet, whereafter the search begins why these words are included.

This is not wysiwyg behaviour. It’s always a search for new people how to remove these (unwanted) words.

 
Can the default behaviour be changed to not include header and footer with page and sheet numbers? If people want something like this, the option should be to enable it, not to get this enabled from default. When creating a pdf, one is expecting an exact copy of the spreadsheet that’s been made.

Steps to Reproduce:
1. install LibreOffice
2. create a new spreadsheet
3. exort to pdf or print

Actual Results:
There will automaticly a header and footer be exported as well, with the sheet and page number.

Expected Results:
The actuel spreadsheet that is created is exported, without anything that hasn't been chosen by the user.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roeland 2018-12-09 19:01:53 UTC
Created attachment 147402 [details]
comparison in excel, albeit in Dutch

I added a screenshot of how this works in Excel (which I have to use at work). Default header and footer is "none", there's an option to select page and sheet number, but only if wanted.
Comment 2 Cor Nouws 2019-01-01 18:52:48 UTC
Thanks for filing, Roeland.

I would not support the idea if headers/footers are active.
There are some reports about that issue ..

 > one for UX.. feel free to join (the) meeting(s)!
Comment 3 Heiko Tietze 2019-01-02 11:31:23 UTC
Disabling header/footer has been requested in bug 121759 and 99296 but got refused. I'll summarize at the other ticket.

*** This bug has been marked as a duplicate of bug 99296 ***