Bug 121830 - FILEOPEN PPTX Video file permanently paused during slideshow
Summary: FILEOPEN PPTX Video file permanently paused during slideshow
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6....
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Media-Playback PPTX
  Show dependency treegraph
 
Reported: 2018-11-30 18:58 UTC by Buovjaga
Modified: 2018-12-12 15:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2018-11-30 18:58:26 UTC
1. Open attachment 140889 [details] from Bug 116643
2. Go to slide 4
3. Select the picture

With gen and gtk2 backends we see the media control toolbar appear. GTK3 says Picture1 selected. The video does not play in the slideshow.

Arch Linux 64-bit
Version: 6.1.3.2
Build ID: 6.1.3-2
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 9059457a1a8385cb80b5dd2c797cee77af4222a9
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 30 November 2018
Comment 1 Durgapriyanka 2018-12-01 01:15:34 UTC Comment hidden (obsolete)
Comment 2 Buovjaga 2018-12-01 09:18:15 UTC Comment hidden (obsolete)
Comment 3 raal 2018-12-01 15:50:21 UTC
This seems to have begun at the below commit.
Adding Cc: to Jan Holesovsky ; Could you possibly take a look at this one?
Thanks

5a4eaa341cdf46e679a5063dddfdf0c0f86b588c is the first bad commit
commit 5a4eaa341cdf46e679a5063dddfdf0c0f86b588c
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Sep 7 01:04:21 2017 +0200

    source sha:2f07a533ed7b52fb0420e6f0a98f42019dcf185f

author	Jan Holesovsky <kendy@collabora.com>	2017-09-05 17:15:03 +0200
committer	Jan Holesovsky <kendy@collabora.com>	2017-09-06 14:47:42 +0200
commit	2f07a533ed7b52fb0420e6f0a98f42019dcf185f (patch)
tree	5a36dbe2198a518eec2279dc92d0f57eef5eedbd
parent	e64ebbb7ac530f82bf26a67fed0e1d22b254ff93 (diff)
tdf#106867: Import target for commands in PPTX.
Comment 4 Caolán McNamara 2018-12-04 16:12:16 UTC
I don't see a significant difference between gtk2 and gtk3 on my machine, in both cases the video is paused by EffectCommands::TOGGLEPAUSE in slideshow/source/engine/animationnodes/animationcommandnode.cxx by AnimationCommandNode::activate_st. Which matches with the bisect commit.

I get the impression from this code that there should be an unpause scheduled in which doesn't seem to arrive
Comment 5 Buovjaga 2018-12-04 16:16:05 UTC
Hmh, it seems I was confused. Indeed, GTK2 has the same behaviour.
Comment 6 Caolán McNamara 2018-12-04 16:47:13 UTC
confident enough that this is a generic problem rather than a GTK3 one so removing that tag.

original pptx xml looks like...

<p:cmd type="call" cmd="togglePause">
 <p:cBhvr>
  <p:cTn id="12" dur="1" fill="hold">
  </p:cTn>
  <p:tgtEl>
   <p:spTgt spid="124">
   </p:spTgt>
  </p:tgtEl>
 </p:cBhvr>
</p:cmd>

and https://gerrit.libreoffice.org/#/c/64548/ would fix this in the sense that the video is paused for a short time and then continues. But I don't really know how this is supposed to work to know if that's even close to right fix.
Comment 7 Buovjaga 2018-12-05 09:36:43 UTC
(In reply to Caolán McNamara from comment #6)
> and https://gerrit.libreoffice.org/#/c/64548/ would fix this in the sense
> that the video is paused for a short time and then continues. But I don't
> really know how this is supposed to work to know if that's even close to
> right fix.

After applying the patch, Picture1 selected is still shown in the status bar instead of media controls, but the video *does* play during the slideshow.
Comment 8 Buovjaga 2018-12-05 10:57:26 UTC
(In reply to Buovjaga from comment #7)
> (In reply to Caolán McNamara from comment #6)
> > and https://gerrit.libreoffice.org/#/c/64548/ would fix this in the sense
> > that the video is paused for a short time and then continues. But I don't
> > really know how this is supposed to work to know if that's even close to
> > right fix.
> 
> After applying the patch, Picture1 selected is still shown in the status bar
> instead of media controls, but the video *does* play during the slideshow.

Hmm, maybe my observation is useless as the media controls are shown in the sidebar and they work fine.
Comment 9 Commit Notification 2018-12-05 12:53:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1aa10fcb668f67f4313b7170a4090027e52164c5%5E%21

tdf#121830 TogglePause should reset to original state on deactivate_st ?

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2018-12-05 13:06:15 UTC
the major brokenness seems fixed, thb seems happy enough that this fix is how its supposed to work. backport to 6-2 in gerrit
Comment 11 Commit Notification 2018-12-05 23:17:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d6b1e268796aac1448f8fe6a153d4aa129466c76%5E%21

tdf#121830 TogglePause should reset to original state on deactivate_st ?

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2018-12-06 13:01:13 UTC
issue verified in

Version: 6.3.0.0.alpha0+
Build ID: fcc76610649a9830859f9e2efe2a06dbc6db74da
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

However, it introduced bug 121942
Comment 13 Commit Notification 2018-12-09 21:15:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/8b550ff4c320e3c3e1495b4a38858c23c420dc86%5E%21

tdf#121830, tdf#121942 TogglePause should reset to original...

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-12-12 15:58:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-4":

https://git.libreoffice.org/core/+/1ec50207dfe7ac7463ee9dff5b89c26af8b4e3b8%5E%21

tdf#121830, tdf#121942 TogglePause should reset to original...

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.