Bug 121899 - Crash in: OutputDevice::GetInverseViewTransformation()
Summary: Crash in: OutputDevice::GetInverseViewTransformation()
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-12-04 13:14 UTC by Gabor Kelemen
Modified: 2018-12-04 16:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["OutputDevice::GetInverseViewTransformation()"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-12-04 13:14:42 UTC
This bug was filed from the crash reporting server and is br-5866c3fa-7e3f-4140-a99c-aac9b9ea3c2f.
=========================================

I was playing with attachment #140295 [details] of bug #116148 setting different hatching spacings on the chart data series / data points. Also tried to use the side bar as well the Area dialog.
Then I closed the file without saving and it crashed.
Comment 1 Roman Kuznetsov 2018-12-04 14:32:17 UTC
repro in

Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded

crashreport.libreoffice.org/stats/crash_details/233cba1c-9a68-46fe-b6f8-f02452018324

Steps:
1. Open presentation
2. Double click on bar in chart -> you are in Chart edit mode
3. Double click on any vertical bar -> opens dialogue Data Series
4. On tab Area change type to Color and select any color for bars
5. Push OK
6. DON'T click anywhere! And just close LibreOffice. Select "Don't Save" in dialogue
7. LO is crashes with recovery window

But! don't repro in

Версия: 6.2.0.0.beta1
ID сборки: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
Потоков ЦП: 4; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded
Comment 2 Xisco Faulí 2018-12-04 15:26:37 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 1ee8d4f63adf3113a4733a479c8faf9eb65f7b8d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

seems to be win only...
Comment 3 Xisco Faulí 2018-12-04 15:35:26 UTC
No need to change the color to reproduce it:
1. Open Impress
2. Insert a chart
3. Double click on any chart's bar
4. Close LibreOffice without saving
-> Crash!
Comment 4 Xisco Faulí 2018-12-04 15:37:49 UTC
Actually I can reproduce it in

Versió: 6.1.3.2
ID de la construcció: 1:6.1.3~rc2-0ubuntu0.16.04.1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 5 Xisco Faulí 2018-12-04 16:12:43 UTC
Another crash caused by 2c317751c4b7661c10bd9eb11094febeccd1b816 which is reverted in 6.1 branch. in 6.2 and master it's fixed by Mike Kaganski in 9ce21daf20faae0e5c8dd8eeb0909106e23a4319