Bug Hunting Session
Bug 103226 - Toolbars are to be hidden in Notebookbar mode
Summary: Toolbars are to be hidden in Notebookbar mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Kshitij
URL:
Whiteboard:
Keywords:
: 121762 121763 121764 121765 121766 121767 (view as bug list)
Depends on:
Blocks: UNO-Command-New Notebookbar
  Show dependency treegraph
 
Reported: 2016-10-14 23:06 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-12-10 13:24 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-10-14 23:06:54 UTC
Contextual toolbars pop up in notebookbar mode when they should not, like when selecting an image or being in a table.
Comment 1 Joel Madero 2016-10-16 05:29:38 UTC
Clearly something UX needs to deal with.
Comment 2 Yousuf Philips (jay) (retired) 2017-04-24 16:40:29 UTC
This was to be implemented in the easy UI switching mechanism in bug 101249, but Syzmon wasnt able to complete it.

This should be done as a UNO command, so that it can easily be used when needed. Hiding of toolbars is available in read only mode (.uno:EditDoc), as well as full screen mode (.uno:FullScreen), and the .uno:AvailableToolbars UNO command should be disabled.
Comment 3 QA Administrators 2018-04-25 02:32:35 UTC Comment hidden (obsolete)
Comment 4 andreas_k 2018-04-25 23:16:28 UTC
If you use notebookbar implementation no toolbars should be shown in addition, only when the user want to show the additional toolbar (so if the user activate the toolbar (e.g. draw toolbar))
Comment 5 Pedro 2018-05-10 16:05:33 UTC
Would this create any kind of conflict with the Calc chart toolbar?
This is something that we should try to do for 6.1 now that the Tabbed bar is in good shape.
Comment 7 Commit Notification 2018-07-06 15:21:08 UTC
Kshitij Pathania committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6d1c9d49bd262ba6746f5d5d2dd4e73da72b2324&h=libreoffice-6-1

tdf#103226 Notebookbar:Disabled appearence of context toolbars

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-11-21 22:44:22 UTC
The commit was reverted in https://cgit.freedesktop.org/libreoffice/core/commit/?id=9a6169529eb687190531225bfe9fef850325ee9e due to bug 121591 and bug 119945.
Putting this issue back to NEW
Comment 9 Maxim Monastirsky 2018-11-28 16:06:18 UTC
*** Bug 121763 has been marked as a duplicate of this bug. ***
Comment 10 Maxim Monastirsky 2018-11-28 16:06:50 UTC
*** Bug 121765 has been marked as a duplicate of this bug. ***
Comment 11 Maxim Monastirsky 2018-11-28 16:07:17 UTC
*** Bug 121764 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2018-11-28 16:07:32 UTC
*** Bug 121762 has been marked as a duplicate of this bug. ***
Comment 13 Maxim Monastirsky 2018-11-28 16:08:34 UTC
*** Bug 121766 has been marked as a duplicate of this bug. ***
Comment 14 Pedro 2018-11-28 16:30:58 UTC
Maxim, instead of marking my bugs as duplicates as soon as I make them could you please
Comment 15 Pedro 2018-11-28 16:34:50 UTC
*** Bug 121762 has been marked as a duplicate of this bug. ***
Comment 16 Pedro 2018-11-28 16:35:25 UTC
*** Bug 121767 has been marked as a duplicate of this bug. ***
Comment 17 Pedro 2018-11-28 16:37:57 UTC
Ooops, sorry.

With the reversion of Kshitij's patch we really need someone else to resolve this issue now that the Tabbed UI is out of experimental.
This one of the blockers to move it out of experimental so it is a big regression to have this showing up again for 6.2
Comment 18 Pedro 2018-11-28 20:57:01 UTC
*** Bug 121764 has been marked as a duplicate of this bug. ***
Comment 19 andreas_k 2018-11-29 03:41:29 UTC
If this bug can't be fixed, notebookbar will move back to experimental.

This is a showstopper
Comment 20 andreas_k 2018-12-08 23:14:49 UTC
(In reply to andreas_k from comment #19)
> If this bug can't be fixed, notebookbar will move back to experimental.
> 
> This is a showstopper

Fixed.

Is this a meta bug? cause otherwise this bug is fixed.
Comment 21 Heiko Tietze 2018-12-09 09:26:22 UTC
(In reply to andreas_k from comment #20)
> Is this a meta bug? cause otherwise this bug is fixed.

I would create a new ticket as META Toolbar issues around NB and link every single problem separately to this item. So let's close this.