Bug 121976 - Freezes for a few minutes when opening a file
Summary: Freezes for a few minutes when opening a file
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, perf, regression
Depends on:
Blocks: DOC-Opening Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2018-12-08 03:27 UTC by Alexander
Modified: 2019-08-27 14:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The file is hung (561.00 KB, application/msword)
2018-12-08 03:28 UTC, Alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2018-12-08 03:27:04 UTC
Description:
We have many users who show this problem with different files. with doс extension and docx.
Please help in the diagnosis.
In MS Word 2013, this file opens without problems.

Steps to Reproduce:
1. Open file
2. Scroll
3.

Actual Results:
Freezes for a few minutes when opening a file

Expected Results:
The file should open without hangs.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alexander 2018-12-08 03:28:08 UTC
Created attachment 147372 [details]
The file is hung
Comment 2 Dieter Praas 2018-12-08 08:31:08 UTC
I can't reproduce it with

Version: 6.2.0.0.beta1 (x64)
Build ID: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 3 Luke 2019-02-06 21:39:40 UTC
Reproducible in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 4ed7f10d7676db0d20c706b915706d894e2113c5
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US

Bugdoc loads but writer freezes when you scroll down.
Comment 4 Xisco Faulí 2019-02-12 17:11:49 UTC
Not reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 5 raal 2019-08-26 20:16:36 UTC
This seems to have begun at the below commit.
Adding Cc: to Mike Kaganski ; Could you possibly take a look at this one?
Thanks

5ab89b966087d48e41d4bf4809a53e7e0e89cb86 is the first bad commit
commit 5ab89b966087d48e41d4bf4809a53e7e0e89cb86
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Feb 8 17:28:37 2017 +0100

    source sha:6f5024de2e1a5cc533527e45b33d9a415467c48d

author	Mike Kaganski <mike.kaganski@collabora.com>	2016-12-08 23:01:03 +0300
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-12-12 08:23:30 +0000
commit	6f5024de2e1a5cc533527e45b33d9a415467c48d (patch)
tree	de8f7248a9f0361e23dcbb1eacb72f67071d51a9
parent	7740e945e0c74d057c424cced079adc766cc5604 (diff)
tdf#104425 sw: split rows w/large min height (fix layout loop)