Bug Hunting Session
Bug 122229 - Navigator: Buttons 'promote/Demote chapter' are disfigured
Summary: Navigator: Buttons 'promote/Demote chapter' are disfigured
Status: RESOLVED DUPLICATE of bug 115986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Navigator Icon-Theme-Elementary
  Show dependency treegraph
 
Reported: 2018-12-20 17:01 UTC by Christian Lehmann
Modified: 2019-05-27 08:33 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
navigator icon set (20.95 KB, image/png)
2018-12-21 15:46 UTC, Christian Lehmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2018-12-20 17:01:01 UTC
Description:
The following mistake was new in LO 6.1.3.2 und persists in 6.1.4.2: In the navigator side bar, there must be two arrows for 'Promote Chapter' and 'Demote Chapter'. Actually:
- There is one button showing a downwards arrow and named 'Promote chapter'. It does move the chapter up. So the text is correct, the arrow is wrong.
- The second button is missing altogether. It should be named 'Demote chapter' and show a downward arrow.

Steps to Reproduce:
1. Press F5 to show Navigator.

Actual Results:
There is only one button to move a chapter up or down, and it bears the wrong icon.

Expected Results:
There should be two buttons as described above.


Reproducible: Always


User Profile Reset: No



Additional Info:
Incidentally, the terms 'promote' and 'demote' are appropriate for the actions 'Promote/Demote Level'. What is meant with 'Promote/Demote Chapter' should actually be called 'Raise/Lower chapter' or 'Move chapter up/down'.
Comment 1 Dieter Praas 2018-12-21 07:07:41 UTC
I can't confirm it with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

or

Version: 6.1.4.2 (x64)
Build-ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded
Comment 2 Christian Lehmann 2018-12-21 09:28:54 UTC
An update on the original report:

If the Navigator side bar is wide enough, both of the promote/demote chapter icons appear. Only if the width is insufficient, the last icons in the row are hidden. The first one to disappear is just the upwards arrow which I had missed.
This works better in the Windows version: Shrinking the width of the bar is blocked at the point where icons would get hidden. Either transfer this solution to the Linux version or else show a symbol at the right edge indicating that there are more icons (like in the Firefox Bookmark symbol bar).

In the Windows version, associations of texts with the arrowhead icons are okay (^ "Kapitel höher verschieben"; v "Kapitel niedriger verschieben"). In the Linux version, they are inverted as reported before: ↓ "Promote chapter"; ↑ "Demote chapter". The buttons do what the text says; the arrows are wrong. Swap arrow symbols. And while you are at it, improve the texts as suggested before.
Comment 3 Xisco Faulí 2018-12-21 15:33:36 UTC
Hello Christian Lehmann,
which icon set are you using ?
Comment 4 Christian Lehmann 2018-12-21 15:36:13 UTC
Hello Xisco,
I have no knowledge of different icon sets. I have just the icon set that the installer chose. In comment 2, I imitated the icons; you may recognize them.
Comment 5 Xisco Faulí 2018-12-21 15:40:37 UTC
Go to Tools - Settings - View to check it. OTOH, it would be nice to share a screnshot. Thanks
Comment 6 Christian Lehmann 2018-12-21 15:46:55 UTC
Created attachment 147760 [details]
navigator icon set

I assume the vertical arrows must be in the order ↑↓.
Comment 7 Christian Lehmann 2018-12-21 15:48:16 UTC
Icon style: Automatic (Elementary)
Comment 8 Heiko Tietze 2018-12-31 09:24:18 UTC
Arrows/Directional symbols are in my opinion always a suboptimal solution. But in this case I agree that promote (move the chapter upward) cannot point downwards. 
Andreas, Rizal: Tango points up with "double arrows" for promote while Colibre, I assume that's what Christian is talking about but because of Linux it could also be Elementary, changed the direction. 

The issue with cropped controls is known and requires a better implementation of the sidebar.
Comment 9 V Stuart Foote 2018-12-31 16:00:59 UTC
@Christian,

Could you please try a different icon theme?

Done from Tools -> Options -> View: "Icon style"

Seems the issue with reversed Promote/Demote icons in the Navigator deck occurs just with the Elementary theme. And *is* present on Windows builds (6.1.4.2) when Elementary icon style is selected. 

And there is similar issue with the icon's used for Next/Previous in the Find toolbar--bug 122367
Comment 10 Christian Lehmann 2018-12-31 16:24:51 UTC
Sorry, I have no access to my Linux for six weeks to come.
On Windows 7, results for the various styles are as follows:
Colibre, Breeze, Karasa Jaga, SiFr, Tango: okay.
Elementary: icons swapped.
Thus, it does seem to be a problem limited to the Elementary style.
Moreover, I second Heiko in that several of the icons are not particularly iconic.
Comment 11 V Stuart Foote 2018-12-31 18:51:54 UTC
Is this a dupe of bug 115986 which is not actually corrected?
Comment 12 Christian Lehmann 2018-12-31 18:58:44 UTC
Yes. The two reports could be merged.

And in fact, although 115986 is said to be corrected, it is not.
Comment 13 Rizal Muttaqin 2018-12-31 22:56:52 UTC
i can tell many more "bug"s in pre 6.2 release cycle for elementary theme. Instead of send particular patch I propose to backport latest elementary build to current released version. Moreover, it would change the policy which prevent icon backporting so we as designer could backport other icons theme as well. Definitely icons would not break stability.
Comment 14 Heiko Tietze 2019-01-02 11:43:47 UTC

*** This bug has been marked as a duplicate of bug 115986 ***
Comment 15 Christian Lehmann 2019-05-27 08:33:20 UTC
The inversion issue was indeed a duplicate; sorry for that.

The terminology issue raised in my original report, "Additional Info", remains to be solved. Not only the icons should be unequivocal, the tooltips should be, too.