Download it now!
Bug 122255 - Notebook bar, tabbed UI, Empty group with dropdown menu for Review tab in Writer with German UI
Summary: Notebook bar, tabbed UI, Empty group with dropdown menu for Review tab in Wri...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 122248 (view as bug list)
Depends on: 116629
Blocks: Notebookbar-Resize
  Show dependency treegraph
 
Reported: 2018-12-21 12:30 UTC by Marina Latini (SUSE)
Modified: 2019-01-10 12:21 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (28.22 KB, image/png)
2018-12-21 12:31 UTC, Marina Latini (SUSE)
Details
Same behaviour in spanish (27.68 KB, image/png)
2018-12-26 16:03 UTC, Xisco Faulí
Details
how the review tab look in english and german language (110.54 KB, image/png)
2019-01-10 12:21 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (SUSE) 2018-12-21 12:30:35 UTC
Description:
With the German UI and tabbed notebook bar, the review tab shows a very long empty group with a dropdown menu.

Steps to Reproduce:
1. Select the German UI
2. Use the Tabbed notebook bar
3. Open the Review tab

Actual Results:
There is a very long empty group and the icons are available only using the dropdown menu

Expected Results:
It's possible to view the name of that group and the full group is available through the dropdown 


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Repro on:
Version: 6.2.0.1 (x64)
Build-ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (en_US); UI-Sprache: de-DE
Calc: threaded
Comment 1 Marina Latini (SUSE) 2018-12-21 12:31:14 UTC
Created attachment 147739 [details]
screenshot
Comment 2 andreas_k 2018-12-22 13:36:15 UTC
sorry but have labels is a design decision. I prefer to have short groups so that the empty space is not to big, but separate groups only cause this empty space is also not a good decision. MSO did it that way that when the window shrink labels were removed, but than the UI jump around all the time (which is not what we want).

So the final solution (for now) is to have the same shrinking mechanism than for the standard toolbar. I suggest to have the arrow the same style than in the standard toolbar see BUG 116629.

-> wfm
Comment 3 Xisco Faulí 2018-12-26 16:03:16 UTC
Created attachment 147842 [details]
Same behaviour in spanish
Comment 4 Xisco Faulí 2018-12-27 10:20:19 UTC
*** Bug 122248 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2019-01-09 19:40:43 UTC
(In reply to Marina Latini (CIB) from comment #0)

> Actual Results:
> There is a very long empty group and the icons are available only using the
> dropdown menu

Can you show a screen print of the drop down pls ?
Comment 6 Heiko Tietze 2019-01-10 11:36:57 UTC
We discussed the topic briefly in the design meeting. What goes into a Notebookbar is a design decision. And while the English "Edit Mode" is slightly smaller than the German "Bearbeitungsmodus" both work well for me from the technical POV. The dropdown is not shown when you size the Window reasonably (>1540px width vs ~1070px in case of English). One issue is the lengthy German term "Automatische Rechtschreibprüfung" for "Auto Spellcheck".

See also the guideline at https://wiki.documentfoundation.org/Design/ToolBar
Comment 7 andreas_k 2019-01-10 12:21:57 UTC
Created attachment 148214 [details]
how the review tab look in english and german language

Here is the difference between german and english. the english review tab didn't need 1280 px but in german it need way more space cause labels are way longer in german than in english.

The HIG for tabbed layout is that you group the commands into tabbs and cause you have than more space for each tabb, the commands get in addition to the icon labels. This improve the usability cause you have not only an icon for an not that often used command, you also get the label. But when you add labels, than the UI is different between different languages. However this is an UI decission of the UI layout and I think have icons and labels is an huge benefit for the tabbed NB.

That's also the reason why on the home tab there are less labels, cause on the hometab you have the most common used actions which mean you will remember the icon cause you need them more often.

About the resizing, yes the resizing is different to MSO ribbons. In LibreOffice the resizing is really simple, from right to left always on group will be hidden after the other behind an arrow. so the empty space when one group was hidden or not can be huge, when the group is huge. So I look close that the groups are not to big. So if you find an large group (more than 4 commands) let me know, than I will make the group smaller. In the Review tab example two groupes will be hidden with german language. the right group is only ONE command and the next group are two commands so I can't make the group smaller.

MSO will show/hide the labels depend on the application window wide, this have the benefit that you can show way longer all commands, but on the other side the UI will jump around and sometimes some commands will be grouped into one drop down menu. I prefer as it is now in LibO (but yes, the system can be improved).

So the solution will be:
- review the translation label lenght. As fare as I know the HIG say also to have short command labels (cause it's easier and faster to read, will help also the menubar entries)
- if there are big groupes, make them smaller, at least the very right once groupes should be smaller
- make instead of the hidden group arrow ">" two arrows ">>" like it is in standard toolbar layout when an icon was hidden.