Bug Hunting Session
Bug 122404 - Extension manager stops responding after declining license during extension installation (gen/gtk2)
Summary: Extension manager stops responding after declining license during extension i...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.1.5 target:6.2.0
Keywords: bibisected, bisected, regression
: 121376 122651 122731 (view as bug list)
Depends on:
Blocks: Extension-Manager
  Show dependency treegraph
 
Reported: 2019-01-01 14:18 UTC by Aron Budea
Modified: 2019-05-13 16:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-01-01 14:18:22 UTC
I encountered this accidentally when checking bug 122250 (steps are different).

- Start installing an extension featuring a license dialog that can be declined, eg: http://calc-info.de/files/BasicAddonBuilder_LibreOffice_0.5.2.oxt
- Decline license.

=> Extension manager becomes unresponsive, can't be closed, buttons can't be clicked.

Bibisected to the following commit using repo bibisect-win32-6.2. Adding Cc: to Caolán McNamara, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f2a39e1d9184b7cda32b713b699d19ac3d023849
In master: https://cgit.freedesktop.org/libreoffice/core/commit/?id=01de2fbdedc693dc46c6d3fde276820a52b42a9c
author		Caolán McNamara <caolanm@redhat.com>	2018-11-28 11:12:55 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-28 13:24:13 +0100

Resolves: tdf#121746 block toplevels from closing...
Comment 1 Telesto 2019-01-01 15:59:58 UTC
No repro for me with:
Version: 6.3.0.0.alpha0+
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-06_23:55:16
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL
Comment 2 Aron Budea 2019-01-01 16:31:59 UTC
Ah, I forgot to add versions, I tested with 6.3.0.0.alpha0+(993913469e74e9db9743004bbe36aa412411671c) & 6.2.0.1 / Windows 7.

Also, no need for the license statement thing, it's enough to cancel out when it asks "For whom do you want to install extension?"
Comment 3 Xisco Faulí 2019-01-01 19:42:40 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: ef58bf56ad292656ad2de0a417eda72cc170f782
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

nor in

Versión: 6.2.0.1
Id. de compilación: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 4 Xisco Faulí 2019-01-10 00:19:57 UTC
I can reproduce it in gen and gtk2. No need to decline the licence, The extension manager is no longer functional if the extension is successfully installed.

I do confirm the issue was introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=01de2fbdedc693dc46c6d3fde276820a52b42a9c

Surprisingly, I don't reproduce it in

Versión: 6.2.0.1
Id. de compilación: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

Adding Cc: to Caolán McNamara
Comment 5 Xavier Van Wijmeersch 2019-01-10 10:18:32 UTC
confirm with

Version: 6.3.0.0.alpha0+
Build ID: 2e189c2464de007b3d59ba37d4f3f1cfbe5b480c
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.2.0.1.0+
Build ID: 2e93b856152e5598a1aad870711e8bc13abb666b
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2019-01-10 14:35:47 UTC
*** Bug 121376 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2019-01-11 10:58:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e94dc6f63a05ab7744b720847c13bd0e2f674417%5E%21

Resolves: tdf#122404 unlock just the toplevels that were locked

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2019-01-11 11:05:54 UTC
fixed in master, backports in gerrit
Comment 9 Xisco Faulí 2019-01-11 12:55:06 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: a0210c5c5e8fd47b55567a8b18788d57d2b7decb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, Thanks for fixing this!!
Comment 10 Xisco Faulí 2019-01-11 12:58:12 UTC
*** Bug 122651 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2019-01-11 13:10:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/71fad56863301f47f19fdd47ab93099ad098474e%5E%21

Resolves: tdf#122404 unlock just the toplevels that were locked

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-01-11 13:10:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3a4a90e6e59e16e2ea0883caba87e114a07642f3%5E%21

Resolves: tdf#122404 unlock just the toplevels that were locked

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xavier Van Wijmeersch 2019-01-11 19:39:29 UTC
thx its working with

Version: 6.2.1.0.0+
Build ID: 3a4a90e6e59e16e2ea0883caba87e114a07642f3
CPU threads: 2; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded


@Caolán, Thanks for fixing this!!
Comment 14 Xisco Faulí 2019-01-15 14:18:35 UTC
*** Bug 122731 has been marked as a duplicate of this bug. ***
Comment 15 Commit Notification 2019-01-21 21:01:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/0df6bc4160292c34c8aa3f3f0df7fadfc12e2712%5E%21

Resolves: tdf#122404 unlock just the toplevels that were locked

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.