Bug 122433 - LO Draw seems to limit export of PNGs to a width of 1000 pixels regardless of the size of the content
Summary: LO Draw seems to limit export of PNGs to a width of 1000 pixels regardless of...
Status: RESOLVED DUPLICATE of bug 123693
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Graphics-Export
  Show dependency treegraph
 
Reported: 2019-01-02 20:45 UTC by xordevoreaux
Modified: 2019-02-27 08:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xordevoreaux 2019-01-02 20:45:05 UTC
Description:
I have images, which, at 96 dots per inch, are 1500 pixels wide by 900 pixels high. The content is used for displaying on a monitor only, not printed.

These exported PNG images in past versions of LO Draw accommodated a width of 1500 pixels, but now, regardless of printer settings and export settings, snap to a fixed maximum width of 1000 pixels.  With 4k monitors, this limitation is ridiculously small.

Steps to Reproduce:
1. Create content consuming a width of 1500 pixels wide and 900 pixels high
2. Attempt to export the content as a PNG.


Actual Results:
Export reduces the width to 1000 pixels wide, making the image small and hard to read.

Expected Results:
Width of export should be width of content.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 xordevoreaux 2019-01-08 20:39:56 UTC
TIFF format is unaffected by this, but still suffer from bug 117160 with the white lines appearing top and left (or both).
Comment 2 xordevoreaux 2019-01-10 16:24:14 UTC
Still broken in Version: 6.2.0.2 (x64)
Comment 3 Dominik Wild 2019-02-15 11:44:30 UTC
Up until 6.2 it has always been possible to enter any width and height. But since 6.2 there is this limit of 1000 pixels for all the bitmap formats (gif, png, bmp, jpg), which is pretty inconvient because I used to export images for 1920x1080 screens.
Comment 4 V Stuart Foote 2019-02-27 08:34:32 UTC

*** This bug has been marked as a duplicate of bug 123693 ***