Bug 123693 - Libreoffice Draw Export to picture has size limit of 1000
Summary: Libreoffice Draw Export to picture has size limit of 1000
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.2
Keywords:
: 122433 123854 123931 (view as bug list)
Depends on:
Blocks: Graphics-Export
  Show dependency treegraph
 
Reported: 2019-02-25 09:05 UTC by Paulo Horta
Modified: 2019-03-08 08:32 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo Horta 2019-02-25 09:05:20 UTC
Description:
When exporting a LibreOffice Draw document to a pictures, the size is now limited to 1000. When trying to "force" a higher value, Libreoffice crashes.
It was working fine before.

Steps to Reproduce:
1. Create something in LibreOffice Draw. A rectangle, for example.
2. Goto menu File->Export...
3. Choose a picture file type: PNG or JPEG. Save.
4. On the picture options window, choose pixels or points.
5. Try to set witdh or height to a value higher than 1000. (ex. 1600x1200)
6. Change Pixels to Points or vice-versa.

Actual Results:
The value cannot be higher than 1000 or the application crashes.

Expected Results:
It is expected to have values higher than 1000 and export it correctly. 


Reproducible: Always


User Profile Reset: No



Additional Info:
This was working fine until last or before than last update.

About LibreOffice:
Version: 6.2.0.3
Build ID: 6.2.0-3
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: pt-PT (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 1 V Stuart Foote 2019-02-25 09:58:10 UTC
Confirmed on Windows 10 Pro 64-bit en-US (1803) with
Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: group threaded

and current master/6.3.0
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 41e56742d0c1547004c43130fc73707a62791512
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-25_03:11:03
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

With Draw unit of measure set to Millimeter or Points, and a canvas size of 1200 x 1600 a sample drawing saved.

On export to SVG and TIFF, as well as PDF export retain canvas size, but other export dialogs (BMP, EMF, GIMP, JPEG, PNG, WMF) all show a canvas size reduced below 1000 of the current unit.
Comment 2 Mike Kaganski 2019-02-25 10:00:42 UTC
The limit-to-1000 part is a regression from https://gerrit.libreoffice.org/plugins/gitiles/core/+/4ce5d39689fda418e8f2d7d9c1124190b2cbad7a
Comment 3 Mike Kaganski 2019-02-25 10:18:39 UTC
Also I see that no matter what resolution I use, since https://gerrit.libreoffice.org/plugins/gitiles/core/+/046df0a876b3d948bb1e14443c00c180bc8cccaa, I see a sequence of "Image filter not found" warning and "Error saving the document Untitled 1: General Error. General input/output error." after confirming the resolution when trying to export to PNG on Windows. Also reproducible on current master (Build ID: ae4e0a81753dd280f6b77b5ee61cf7e9f85e5cfe). No application crash.

But possibly it's a different bug that needs a separate bug report.
Comment 4 Caolán McNamara 2019-02-26 09:29:31 UTC
raising the limit is trivial anyway
Comment 5 V Stuart Foote 2019-02-27 08:34:32 UTC
*** Bug 122433 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2019-02-27 21:19:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/627b46de426a9a44ee3297136b98c503b915ca37%5E%21

tdf#123693 raise max size

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2019-02-27 21:24:28 UTC
raised that max to some massive size, fixed in master, backports to 6-2 in gerrit. If some problem persists then open a new bug as I'll take this just for the "size limit" problem
Comment 8 Commit Notification 2019-02-28 20:42:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/37fa4d75ef7f1f419dcd3f69c9c168992699735d%5E%21

tdf#123693 raise max size

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 V Stuart Foote 2019-03-01 02:01:00 UTC
Thanks, fixed now...

Version: 6.3.0.0.alpha0+
Build ID: beba45a5639bc32ca6893885ca3b1f07e3175c08
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 10 Gabor Kelemen 2019-03-05 12:27:05 UTC
*** Bug 123854 has been marked as a duplicate of this bug. ***
Comment 11 Gabor Kelemen 2019-03-08 08:32:16 UTC
*** Bug 123931 has been marked as a duplicate of this bug. ***