Download it now!
Bug 122488 - Toolbar icons to insert row/column in table are misleading with Sifr
Summary: Toolbar icons to insert row/column in table are misleading with Sifr
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.2
Keywords:
Depends on:
Blocks: Icon-Theme-Sifr
  Show dependency treegraph
 
Reported: 2019-01-04 17:23 UTC by William Gathoye
Modified: 2020-08-09 18:18 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sifr still needs improvement (1.49 KB, image/png)
2019-01-04 17:24 UTC, William Gathoye
Details
sifr icon looking good (100.30 KB, image/png)
2019-01-14 07:51 UTC, BogdanB
Details
Make icons to add columns / rows more distinguishable between left and right / top and bottom versions (6.31 KB, image/png)
2019-01-20 19:22 UTC, William Gathoye
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Gathoye 2019-01-04 17:23:24 UTC
Description:
Following bug 122407, where we experienced an issue with Colibre. The issue is present for Sifr as well.

Maybe for the darker gray column/row you displayed in the icon, this could be better to put that darker column/row upper/lower, more at the left/right depending on the icon? (cf. screenshot).

Because right now we have to have a close look to see the icons differences, especially when our theme is set to "small".

Steps to Reproduce:
1. With the Sifr icon theme
2. Insert a table
3. Try to insert a column or a row using the toolbar
4. Try to achieve this without having to restart again


Actual Results:
Misleading comprehension of the icon

Expected Results:
Immediate comprehension about how the icons work without the need to hover with our mouse pointer to see the tooltip.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 William Gathoye 2019-01-04 17:24:09 UTC
Created attachment 148039 [details]
Sifr still needs improvement
Comment 2 BogdanB 2019-01-14 07:50:48 UTC
For me on version 6.3 it's ok.
Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: ro-RO (ro_RO); UI-Language: en-US
Calc: threaded


See the attachament
Comment 3 BogdanB 2019-01-14 07:51:24 UTC
Created attachment 148299 [details]
sifr icon looking good

sifr icons looking good
Comment 4 William Gathoye 2019-01-20 19:21:09 UTC
@BogdanB It seems there is a misunderstanding here.

I mean the current icons are not easily distinguishable between the version adding a column to the left and the icon adding a column to the right. This is especially true with hidpi screen on portable computer using LibreOffice with the small icons variant sets.

This is why I was proposing to put the darker columns more at the left for the icon adding a column at the left. The same logic applies for the right, but in reverse order for obvious reasons.
And the same applies for the icons related to adding rows.

See the example I provided.

Please let me know if this is still unclear.
Comment 5 William Gathoye 2019-01-20 19:22:38 UTC
Created attachment 148456 [details]
Make icons to add columns / rows more distinguishable between left and right / top and bottom versions
Comment 6 BogdanB 2019-01-20 20:54:12 UTC
I agree that the icon resolution can be improved, but on a regular screen I can see the arrow perfect.

But I confirm the bug, the arrow can ne moved a little right, or left, depending of the case, in order to make thing easier to read.
Comment 7 William Gathoye 2019-01-20 21:01:02 UTC
@BogdanB I'm not only speaking of the arrow, but I'm also speaking of the grey column/row. The arrow is way too small to see it completely at a glance especially as we have to speed up when taking notes at the university :).

This is why I was asking to have the grey column/row just below/next to the arrow in order to have it more at the left/right or top/bottom as well. cf. the differences between my dirty mock-up and the current icons. :)
Comment 8 Heiko Tietze 2019-01-21 20:24:45 UTC
It's more a design decision than an UX topic. So removing needsUX and adding the icon designers.
Comment 9 Papamatti 2019-04-14 14:30:21 UTC
Okay, I'm the designer of these icons so I try to decribe what these icons mean:

The meaning is you are inside the current grey column/row.
If you press the icon, for example the one left of the grey column you insert a column left of your current cursor position!

Hope this helps for clarification. :-)
Comment 10 William Gathoye 2019-04-14 20:34:21 UTC
This helps indeed, even if I had understood the icons meaning properly before as well =D

But even in the case we are using this feature extensively, when we are in a rush taking notes like mad in order to follow the teacher's steps, having just an arrow is not enough to distinguish both icons.

I was expecting the column/row (depending on the case) to be more at the left/right / top/bottom in order to improve these differences.

Because when the icons are set to small or when we have a HiDPI screen, even if we understand the icons purpose, our eyes need to focus for some time (a few seconds) to see if we are not pressing the wrong one. These seconds are what makes the difference especially when our courses are given quite fast.

By this use case, we understand the changes you'll have to make will give another meaning to the icons wrt. the row/column we are in.

Please let me know if you aren't understanding everything I wrote or if you want to publish your first ideas of correction  :)

All the best,
Comment 11 Commit Notification 2020-02-22 05:50:20 UTC
rizmut committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ee8914cd0bf017e2d294a6d5d4f52587c0a8aef4

Sifr: Fix for tdf#122488 icons for insert row/column

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-02-22 14:27:14 UTC
rizmut committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/ab3cc6102b09ddea7ea0f3ef26e6231caaa261c4

Sifr: Fix for tdf#122488 & tdf#130864

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 BogdanB 2020-08-09 18:18:09 UTC
Wow, I understand now much better what your problem was with this icons.
It's much much better now!

Verified in
Version: 7.0.0.3
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded