Bug Hunting Session
Bug 122523 - CUSTOMIZE DIALOG: Duplication of Function name
Summary: CUSTOMIZE DIALOG: Duplication of Function name
Status: RESOLVED DUPLICATE of bug 108458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2019-01-07 08:11 UTC by Дмитрий
Modified: 2019-06-12 11:55 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the dialog window - Customize (54.94 KB, image/png)
2019-01-07 08:11 UTC, Дмитрий
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Дмитрий 2019-01-07 08:11:18 UTC
Created attachment 148085 [details]
Screenshot of the dialog window - Customize

Translations into English from Russian via - translate.yandex.ru

When assigning hot keys, it is impossible to select the Necessary function "Highlight color ", so there are two functions with the same name and different behavior.

*Original on Russian*
При назначении горячих клавиш невозможно однозначно выбрать необходимую функцию "Цветовая подсветка", так присутсвуют две функции с одинаковым названием и разлчным поведением.
Comment 1 Dieter Praas 2019-01-07 18:55:19 UTC
I confirm this with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

There are a lot of functions with the same name, for example

Bibliography Entry
Borders (Shift to Overwrite)
Bottom
Bullets and Numbering
Center
Centered
Close
Comment
...
Comment 2 Xisco Faulí 2019-01-08 15:09:04 UTC
Also reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Dieter Praas 2019-01-08 15:43:26 UTC
Xisco, just for clarification, because you changed importance to lowest: These are not different commands with the the same name (see comment 0), but duplicates of the same comment, right?
Comment 4 Дмитрий 2019-01-09 07:16:13 UTC
 Dieter Praas, I have assigned these commands different hot-keys and in one case the text is removed by hightlight, and in the other case nothing happens to the text. From what I make a choice that the functions are still different.
Comment 5 Dieter Praas 2019-01-09 08:10:09 UTC
(In reply to Дмитрий from comment #4)
> From what I make a choice that the functions are still different.

Or there is no function with the duplicates, what is very annoying and not trival.
Comment 6 Xisco Faulí 2019-01-15 17:35:48 UTC
*** Bug 122666 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2019-03-22 15:35:41 UTC
*** Bug 123494 has been marked as a duplicate of this bug. ***
Comment 8 Muhammet Kara 2019-06-12 09:24:04 UTC
IIRC They are not the same command. I would add a description field (maybe under the Keys box) to show the descriptions of the commands. So that user can identify the right command. (Maybe also with its uno command)

Like:

(.uno:Foo)
Foo is a command used to do bar on the selected text.
Comment 9 Xisco Faulí 2019-06-12 09:46:50 UTC
(In reply to Muhammet Kara from comment #8)
> IIRC They are not the same command. I would add a description field (maybe
> under the Keys box) to show the descriptions of the commands. So that user
> can identify the right command. (Maybe also with its uno command)
> 
> Like:
> 
> (.uno:Foo)
> Foo is a command used to do bar on the selected text.

+1
Comment 10 Maxim Monastirsky 2019-06-12 11:26:48 UTC

*** This bug has been marked as a duplicate of bug 108458 ***
Comment 11 Heiko Tietze 2019-06-12 11:53:58 UTC
.uno:CharBackColor and .uno:BackColor have the same label. We must not assign the same label to different function and my proposal is to rename CharBackColor to "Highlight character".

Since we got many of these issues not being sure ourself what exact command is behind the name we could also show the command name in a tooltip perhaps together with other information. Meaning you hover over a function name in the customize dialog and the tooltip shows:

  Label: Highlight color
   Name: uno:CharBackColor
Tooltip: 
 Source: GenericCommands.xcu

(Maybe the last is a bit too much.)
Comment 12 Heiko Tietze 2019-06-12 11:55:24 UTC
Mid-air collision ;-)

*** This bug has been marked as a duplicate of bug 108458 ***