Download it now!
Bug 122668 - LibO 6.2.x KDE5 VCL regression: lines not appearing in presentation
Summary: LibO 6.2.x KDE5 VCL regression: lines not appearing in presentation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-01-12 03:33 UTC by sergio.callegari
Modified: 2019-05-30 11:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test slide showing the issue on my screen (1920x1080) (38.39 KB, application/vnd.oasis.opendocument.presentation)
2019-01-12 03:41 UTC, sergio.callegari
Details
Screenshot of the presentation (21.79 KB, image/png)
2019-01-12 03:46 UTC, sergio.callegari
Details
6-3-kde5 (21.88 KB, image/png)
2019-05-14 10:21 UTC, Vera Blagoveschenskaya
Details
6-3-gtk3 (22.71 KB, image/png)
2019-05-14 10:21 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2019-01-12 03:33:18 UTC
Description:
Seen in KDE (bug may only be preset with newer KDE5 VCL).

I have some slides with diagrams, schematics, etc. made with LibO < 6.2.  Lines in these drawings are 0.2 mm.

In presentation mode some of these lines are not shown.

Previously this was an issue only with the "presenter screen" available on the lapto when presenting with a projector. Now the issue is also present in the main presentation itself, breaking presentations.

If needed, I'll try to distill a test case.

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 sergio.callegari 2019-01-12 03:41:33 UTC
Created attachment 148255 [details]
Test slide showing the issue on my screen (1920x1080)
Comment 2 sergio.callegari 2019-01-12 03:46:51 UTC
Created attachment 148256 [details]
Screenshot of the presentation
Comment 3 raal 2019-01-12 07:45:11 UTC
I cannot confirm with Version: 6.3.0.0.alpha0+
Build ID: 892a5cfe557edb405ec0037676f02a1c24dd76ec
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
and  VCL: x11;
Comment 4 sergio.callegari 2019-01-12 09:56:11 UTC
Not happening when using the KDE4 VCL plugin, but in this case you have much more flicker with the presentation transition effects, as it was in LibO up to 6.1.
Comment 5 Xisco Faulí 2019-01-12 17:30:42 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: a0210c5c5e8fd47b55567a8b18788d57d2b7decb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

nor in

Version: 6.2.1.0.0+
Build ID: bbdd753f1e0155c483a554d3f28cbc3f1521105d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 sergio.callegari 2019-01-13 17:01:01 UTC
Yes, I think that you need the kde5 VCL to have the issue.

- Out of curiosity. Cannot seem to be able to start with the gtk3 VCL, kde5 is selected if I ask for gtk3 on my system (I do not have gnome integration packages and that may be the reason).  Furthermore, I cannot use X11 since it hangs when opening complex presentations.
Comment 7 sergio.callegari 2019-01-13 17:10:15 UTC
Incidentally... also 6.1 hangs when dealing with complex presentations if invoked with SAL_USE_VCLPLUGIN=gen libreoffice6.1, so it is really difficult for me to test with different VCLs
Comment 8 Michael Weghorn 2019-01-15 13:32:05 UTC
(In reply to sergio.callegari from comment #6)

I cannot reproduce here with a recent master build and using the kde5 VCL plugin:

Version: 6.3.0.0.alpha0+
Build ID: de63114d76433b5a1f1ed0286e28545c72330630
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

The behaviour might be somehow dependent on video card, screen,...

> - Out of curiosity. Cannot seem to be able to start with the gtk3 VCL, kde5
> is selected if I ask for gtk3 on my system (I do not have gnome integration
> packages and that may be the reason).  Furthermore, I cannot use X11 since
> it hangs when opening complex presentations.

Wrt gtk3, yes, I think you need the gnome-integration package. Can you possibly test to install that one and see what the behaviour is like with gtk3?
Comment 9 sergio.callegari 2019-05-11 15:00:24 UTC
Issue is still present in LibO 6.2.4 RC1.

Goes away in any 6.2 version using the gtk3 VCL.

Possibly related to bug 125213.
Comment 10 Vera Blagoveschenskaya 2019-05-14 10:20:36 UTC
Well, I see the difference between kde5-view and gtk3-view.

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Pls look at the screenshots.
Seems it is #tdf125213
Comment 11 Vera Blagoveschenskaya 2019-05-14 10:21:23 UTC
Created attachment 151396 [details]
6-3-kde5
Comment 12 Vera Blagoveschenskaya 2019-05-14 10:21:41 UTC
Created attachment 151397 [details]
6-3-gtk3
Comment 13 Michael Weghorn 2019-05-29 09:10:33 UTC
This has been fixed by the following commit, s. also the corresponding gerrit change [1].


commit 86cab846c1a122dd4dd5f5c4ca5750a0fc397c6b
Author: Jan-Marek Glogowski <glogow@fbihome.de>
Date:   Fri May 24 15:36:39 2019 +0000

    Qt5 implement SalSurface support for cairo
    
    Current qt5+cairo uses the plain VCL canvas. This patch is just a
    copy of Gtk3Surface (minus comments) with a different update call.
    This way the Cairo path now uses the Cairo canvas instead.
    
    It fixes at least tdf#122668 for me, but other Impress bugs might
    be fixed this way too.
    
    Change-Id: Iba511c851001753328293c28e53eaa4acc4315d0
    Reviewed-on: https://gerrit.libreoffice.org/72921
    Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
    Tested-by: Jenkins
    Reviewed-by: Aleksei Nikiforov <darktemplar@basealt.ru>



[1] https://gerrit.libreoffice.org/72921
Comment 14 Michael Weghorn 2019-05-30 11:21:58 UTC
Backport for 6.2: https://gerrit.libreoffice.org/#/c/73198/