Download it now!
Bug 125213 - Regression: Impress 6.2.x KDE5 very poor antialiasing in presentations
Summary: Regression: Impress 6.2.x KDE5 very poor antialiasing in presentations
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-05-11 14:49 UTC by sergio.callegari
Modified: 2019-05-30 11:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (21.76 KB, application/vnd.oasis.opendocument.presentation)
2019-05-11 14:50 UTC, sergio.callegari
Details
Presentation rendering with LibO 6.1 or LibO 6.2 and the gtk3 VCL (11.31 KB, image/png)
2019-05-11 14:51 UTC, sergio.callegari
Details
Presentation rendering with LibO 6.2 and the KDE5 VCL (11.87 KB, image/png)
2019-05-11 14:53 UTC, sergio.callegari
Details
6-2 (23.11 KB, image/png)
2019-05-14 10:10 UTC, Vera Blagoveschenskaya
Details
6-3 (23.15 KB, image/png)
2019-05-14 10:10 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2019-05-11 14:49:08 UTC
Description:
Using the KDE5 vcl, LibO 6.2 has very poor antialiasing in impress presentations.

The attached documents show a testcase and an example.

Note that the attached documents also show another problem. This consists in some line misalignment. In other words, objects that look fully aligned from the position and size dialog, appear misaligned in presentation. This occurs in all LibO version and is not the issue at hand. That problem is probably related to bug 44266.

Conversely, the current issue is about line thickness being lost both in graphical objects (e.g., the line above Vo) and text characters, (e.g., note the bottom of the o in Vo, or the top of the circle in the d in Vd).

This issue is probably related also to bug 122668.

The issue is only evident with the KDE5 VCL. With the gtk3 VCL the rendering is the same in LibO 6.1 and LibO 6.2.

Steps to Reproduce:
Open the test document and try to show the presentation, both in LibO 6.1 and in LibO 6.2 (with either the KDE5 or the GTK3 vcl). 

Actual Results:
You will see differences in the antialiasing in presentation, with the one obtained on the KDE5 VCL being noticeably bad.

Expected Results:
Antialiasing should have an acceptable quality even with the KDE5 VCL.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 sergio.callegari 2019-05-11 14:50:18 UTC
Created attachment 151305 [details]
Test document
Comment 2 sergio.callegari 2019-05-11 14:51:06 UTC
Created attachment 151306 [details]
Presentation rendering with LibO 6.1 or LibO 6.2 and the gtk3 VCL
Comment 3 sergio.callegari 2019-05-11 14:53:11 UTC
Created attachment 151307 [details]
Presentation rendering with LibO 6.2 and the KDE5 VCL

Note the non homogeneous line thickness and the poorer font rendering than in LibO 6.1 (KDE4 VCL) or LibO 6.2 with the gtk3 VCL.
Comment 4 Vera Blagoveschenskaya 2019-05-14 10:09:44 UTC
Hello, I've checked with 

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

and with

Version: 6.2.4.0.0+
Build ID: d3778236deb7d1e13f70f229c33ab6cfdc1f197f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-05-03_21:31:32
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Well, I can see the fact of poor antialiasing in the bottom of the o in Vo and in vertical lines near AdVd.

Pls look at the screens.
Comment 5 Vera Blagoveschenskaya 2019-05-14 10:10:10 UTC
Created attachment 151394 [details]
6-2
Comment 6 Vera Blagoveschenskaya 2019-05-14 10:10:32 UTC
Created attachment 151395 [details]
6-3
Comment 7 Michael Weghorn 2019-05-29 09:11:01 UTC
This has been fixed by the following commit, s. also the corresponding gerrit change [1].


commit 86cab846c1a122dd4dd5f5c4ca5750a0fc397c6b
Author: Jan-Marek Glogowski <glogow@fbihome.de>
Date:   Fri May 24 15:36:39 2019 +0000

    Qt5 implement SalSurface support for cairo
    
    Current qt5+cairo uses the plain VCL canvas. This patch is just a
    copy of Gtk3Surface (minus comments) with a different update call.
    This way the Cairo path now uses the Cairo canvas instead.
    
    It fixes at least tdf#122668 for me, but other Impress bugs might
    be fixed this way too.
    
    Change-Id: Iba511c851001753328293c28e53eaa4acc4315d0
    Reviewed-on: https://gerrit.libreoffice.org/72921
    Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
    Tested-by: Jenkins
    Reviewed-by: Aleksei Nikiforov <darktemplar@basealt.ru>



[1] https://gerrit.libreoffice.org/72921
Comment 8 Michael Weghorn 2019-05-30 11:22:23 UTC
Backport for 6.2: https://gerrit.libreoffice.org/#/c/73198/