Bug Hunting Session
Bug 122799 - Remove option to adjust icon size at the Notebookbar
Summary: Remove option to adjust icon size at the Notebookbar
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, needsDevEval, skillDebug
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2019-01-18 08:13 UTC by Heiko Tietze
Modified: 2019-03-29 11:50 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2019-01-18 08:13:37 UTC
Under Tools > Options > LibreOffice > View we provide an option to change the icon size at the Notebookbar likewise it's possible for standard toolbars. But the NB has a predefined size and does not respond to the changed icons. This results in issues like bug 116228 and contradicts different icon sizes in the NB variant.

So the proposal is to remove the option.
Comment 1 Szymon Kłos 2019-01-18 11:30:54 UTC
Yes, It might be a good idea. It works only when we restart the app if I remember.
Comment 2 andreas_k 2019-02-05 08:25:10 UTC
This is not a bug it's only a bit more complicate to implement an customizable UI. eg. in tabbed, tabbed compact, groupedbar and groupedbar_compact the icon size come from the settings dialog. Only in tabbed and groupedbar it's a bit difficult to have them customizable, but it work.

Not a bug!
Comment 3 Xisco Faulí 2019-02-12 14:15:12 UTC
@Heiko, do you agree with Andreas in comment 2 ?
Comment 4 Heiko Tietze 2019-02-12 14:25:03 UTC
(In reply to Xisco Faulí from comment #3)
> @Heiko, do you agree with Andreas in comment 2 ?

No, I filed the ticket and request the change (would do it myself if there is more agreement). Don't care if you set it as enhancement or bug.
Comment 5 andreas_k 2019-02-13 13:41:16 UTC
I'd definitly against this request!
Comment 6 jan d 2019-02-13 14:01:08 UTC
What is the user need assumed here? Having large targets vs. more things on the screen? 

>  But the NB has a predefined size and does not respond to the changed icons.

Does that mean that all the things in a notebook bar are positioned absolutely by pixel distances from some corner (top-left or so)? So things to not "flow" like the toolbars, where an icon early in order pushes the other icons further back?
Comment 7 Heiko Tietze 2019-02-14 13:39:24 UTC
We discussed the proposal positively in the design meeting. Rather than customizing the NB the designer/community has to provide different variants.
Comment 8 Pedro 2019-02-14 13:42:43 UTC
I'm with Andreas and I am completely against this.
Comment 9 andreas_k 2019-02-14 14:44:11 UTC
sorry but NEVER EVER!

The best example is the tabbed compact notebookbar there all items are in one horizontal row, so when you change the icon size from default 16 px to 24 px, there is no visual issue. 

And when you use 32px icons the tabbed compact notebookbar is an touch friendly UI!
Comment 10 V Stuart Foote 2019-02-14 15:47:54 UTC
Sorry Heiko, but you know my long standing thoughts on all facets of MUFFIN being flexible to encourage customization (e.g. bug 33223). And I'd still insist the Notebook bar needs an API similar to that of the Sidebar (bug 91806) so devs/power users can roll their own extensions that modify the "core" NB flavors, either with full NB or as addition to the "core".

We already have MUFFIN  specific NB enhancement bug 101704 for inability of stable extensions to be incorporated into the NB (bug 116532 or bug 122316)  

IMHO removing the Icon size selection from the NB as here would move us the wrong direction--and is a misinterpretation of MUFFIN. All flavors of the NB are flexible and dynamic--none are hard coded in src files, just the layout parsing rules for the XML.

Yes the Icon size toggle now can cause visual glitches like bug 116228 but it is transient, and probably could be corrected (e.g. re-sync without restart).

A personal use case, I find the Icon size toggle for the NB helpful in Writer to exactly fit two pages side by side at 100% on my 1920x1200 dpi display. With the small icons it fits nicely, with the default larger icons it throws up the verticle scroll.

IMHO => NAB and WF
Comment 11 Cor Nouws 2019-02-14 16:19:56 UTC
At first I didn't comment after reading the minutes, but seeing the comments, indeed I wonder if it's really needed to remove.
Notably: the person doing tons of work on the Notebook Bar is against changing it.