Download it now!
Bug 122933 - ENDNOTE enhancement -- endnotes per chapter / document
Summary: ENDNOTE enhancement -- endnotes per chapter / document
Status: RESOLVED DUPLICATE of bug 102835
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2019-01-24 14:23 UTC by peter josvai
Modified: 2019-01-24 16:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2019-01-24 14:23:57 UTC
Description:
endnotes are still in immature both on the readers' part and on the writers', including Libreoffice Writer :) 

it would be great, to start with, if similarly to footnotes, we had options for endnotes like
"per chapter" / "per document" (that latter makes sense in the case of master document)

the reason for this suggestion is that people not necessarily like to get to the endnotes "blindly", by clicking on a  number...

it could also happen that one wants to go through the endnotes... 
just for curiosity... 
and once you are reading / studying the endnotes, browsing through them, 
it would be GREAT improvement if you could see them under chapter headings...

chapters could be taken as new documents linked into a master document, or/and    text under headings... let's now only mention "heading 1" / "h1"... (and forget h2, h3 depths... cause the point is not to make things complex, like difficult, but to make them felxible and intelligent...

....................
2 NOTEs:

#1
ENDNOTES are, I believe, extremely important cause they are the best known means to place "linked info" into an ebook... 

#2
looking at the marked up xml in an ODT document's "zip container", once can see HOW utterly intelligent tasks are being performed whenever an endnote is placed somewhere... not to mention joining documents into a master document...


it is TOTALLY sophisticated already... and my suggestion would very probably just mean a clever utilization of this sophistication, the utilization of what has been made possible already... and would NOT require migrating to a higher level of complexity whatsoever :)
I mean, I'm basically certain that LiO  Writer has long been able to do this extra trick :) 

-- thank you for developing Libreoffice! ---



Steps to Reproduce:
1. create a Master Document
2. insert 2 documents (which both have ENDNOTES) into it (as "insert / file")
3. look at the ENDNOTES in the Master Document

Actual Results:
it is beautifully displayed in a merged order...
however, there's no indication as to which document or chapter each ENDNOTE belongs to...

Expected Results:
having the suggested ENHANCEMENT, endnotes could be displayed 
with separators for chapters / documents...

like:

- - chapter one - -
endnote 1
endnote 2
- - chapter two - -
endnote 3
endnote 4

.......................
PLUS, it would be great if the ENDNOTES could be copied as and pasted into a WYSIWYG html editor... or into a libreoffice Writer document as they are...



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter Praas 2019-01-24 16:21:58 UTC

*** This bug has been marked as a duplicate of bug 102835 ***