Bug Hunting Session
Bug 123178 - TEMPLATES -- "open new" instead of "open" // at "Templates / Manage Templates"
Summary: TEMPLATES -- "open new" instead of "open" // at "Templates / Manage Templates"
Status: RESOLVED DUPLICATE of bug 104074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
 
Reported: 2019-02-05 11:24 UTC by peter josvai
Modified: 2019-02-14 13:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2019-02-05 11:24:04 UTC
Description:
only through using it can we make a menu more intuitive :) 

a few MINOR suggestions:

when we right click on a template (at MANAGE TEMPLATES), it will bring up 

OPEN
EDIT
SET AS DEFAULT
------- (separator)
Rename
Delete

I think, the separator should go below "set as default", 
cause the first two menu items refer to the IMMEDIATE use of the template, 
while the other 3 refer to ORGANIZING the templates...

- - -

the main suggestion that I'd like to propose, however, is 
to change 
OPEN to "Open new document" 
and 
EDIT to "Edit this template"

PS:
personally, I was in love with the briefness of this menu...
but making it clear(er) what menu items are for should enjoy priority :)


- - - thank you for developing LibreOffice - - -



Steps to Reproduce:
1. File / Templates / Manage Templates right click on a template
2. 
3.

Actual Results:
since the context menu that comes up is like this:

Open
Edit
... 
the rest

the user who wants to OPEN the template, both to see what's inside (styles) and to perhaps edit it..
will be frustrated cause a new document is created... 
which means, the template couldn't be accessed :) 
as it couldn't be opened :)

there is another reason why this additional information "new document" in addition to "Open" should be added, namely, that 
the user can land here, at Manage Templates from File / New / Templates...
in which case she or he will want to "create a new document"...
but if s/he right clicks before just clicking on the template blindly, 
s/he will see "Open" and "Edit" as two options...
neither of which would be what she expects...
cause what the user wants in this case is "create a new document" and not "open" (a template)

 

Expected Results:
when going CTRL+SHIFT+N (or file/templates, manage templates),
the it should be clear for the user 
that the options are OPENing a new document 
and editing the template

and NOT 
OPENing (the template that has been right-clicked)
or 
EDITing (the template that has been right-clicked)



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter Praas 2019-02-05 12:34:37 UTC
I agree to both suggestions
a) separator below "set as default"
b) "Open new document". Perhaps also "Use" and "Edit" would make it more clear
Comment 2 Heiko Tietze 2019-02-14 13:29:47 UTC
Good point, let's continue in the other ticket.

*** This bug has been marked as a duplicate of bug 104074 ***