Download it now!
Bug 123224 - Do not extend ReferenceMarks when editing on its border (start or end)
Summary: Do not extend ReferenceMarks when editing on its border (start or end)
Status: RESOLVED DUPLICATE of bug 81720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Cross-Reference
  Show dependency treegraph
 
Reported: 2019-02-07 11:05 UTC by Adomas Venčkauskas
Modified: 2020-01-08 14:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adomas Venčkauskas 2019-02-07 11:05:27 UTC
Description:
ReferenceMarks are used to insert citations and store underlying citation data by reference managers such as Zotero and Mendeley. The Zotero developers are working on some enhancements to the citing functionality[1] which might lead to users wanting to edit or insert text on the border of ReferenceMarks (either start, or end). As LibreOffice Writer currently stands, this functionality cannot be enabled for it, because if you place the text cursor on the border of a ReferenceMark, it extends the mark, rather than adding text right outside of it. This is not the case with Word Fields and Google Docs links, which Zotero uses to provides citing functionality on corresponding doc processors.

Presumably this is a trivial change both codewise and UX-wise for LibreOffice, but be beneficial in letting us provide a better, on-par with Word, citing functionality.

Steps to Reproduce:
1. Insert some text in Writer
2. Select a portion of the text -> Insert -> Cross-Reference -> Set Reference, set some text in the "Name" field and click "Insert"
3. Ensure field shading is enabled
4. Place the cursor outside the newly created ReferenceMark, then place it on the edge of the ReferenceMark, type something.

Actual Results:
The ReferenceMark is extended

Expected Results:
The newly typed text remains outside of the ReferenceMark


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2019-02-07 12:02:48 UTC
I confirm this behaviour with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 411f3a050ac2be598019d512f8ccfe041080c28f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-14_03:17:11
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

and also in

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL


As far as I can see, this behaviour occurs only if you select "Set Reference" and not with "Insert Reference", "Headings", "Numbered Paragraphs" or "Bookmarks"

So I would treat this as a bug instead of enhancement.

I set the Importance to high, because functionality with zotero is a must be for a lot of users.
Comment 2 Henrique Capeleiro Maia 2019-04-21 16:47:58 UTC
I also confirm this happening on 

Version: 6.2.2.2
Build ID: 6.2.2-4
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: pt-BR (en_US.UTF-8); UI-Language: en-US
Calc: threaded

It has been a long standing behaviour since I first noticed it quite some time ago.
Comment 3 Alex Thurgood 2019-04-23 11:02:06 UTC
Possible duplicate of bug 64361 ?
Comment 4 Adomas Venčkauskas 2019-04-23 11:09:02 UTC

*** This bug has been marked as a duplicate of bug 64361 ***
Comment 5 Adomas Venčkauskas 2019-04-23 11:09:32 UTC
Yes, it's a duplicate, thanks for pointing it out, Alex
Comment 6 Juang Dse 2019-07-04 12:28:45 UTC
*** Bug 126125 has been marked as a duplicate of this bug. ***
Comment 7 Juang Dse 2019-07-09 08:03:13 UTC

*** This bug has been marked as a duplicate of bug 81720 ***