Download it now!
Bug 64361 - EDITING: Complex fields added by Zotero expand to include text typed after them
Summary: EDITING: Complex fields added by Zotero expand to include text typed after them
Status: RESOLVED DUPLICATE of bug 81720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields
  Show dependency treegraph
 
Reported: 2013-05-08 14:37 UTC by Milan Bouchet-Valat
Modified: 2019-07-09 08:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document to illustrate the problem (does not require Zotero) (9.80 KB, application/vnd.oasis.opendocument.text)
2013-05-08 14:37 UTC, Milan Bouchet-Valat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2013-05-08 14:37:13 UTC
Created attachment 79024 [details]
Document to illustrate the problem (does not require Zotero)

The Zotero citation management tool inserts complex fields through a LO/OO plug-in. These fields can appear in various forms, but typically they look like "(Author YYY)", while the field itself contains many properties, like this: "ZOTERO_ITEM CSL_CITATION{"prop1":"val1", ...}".

The problem can be reproduced without having Zotero installed. In the attached document, text typed after these fields is included into the field (with a grey background). This does not happen with text typed immediately after inserting the field: it only happens when one writes something and then goes back to the end of the field (not visible on this document, since one needs Zotero for this).

This behaviour is problematic since Zotero will erase all the text typed in these fields when e.g. changing citation styles or refreshing the references. Then user text can be lost. More generally, I don't think it makes sense to allow changing the text of the field by typing *at the end* of it. Even if typing text in the middle of the field was deemed useful, typing text after it should always result in a normal text being inserted.

I have not been able to reproduce this with fields inserted from LO itself, but I'm not very familiar with this mechanism. I don't think the bug can come from Zotero. Please note that Zotero is a very valuable addition to LO for academics, making it a credible alternative to the MS Word/EndNote couple.


[This is reproducible with LO 4.0.2.2 but is a very old issue.]
Comment 1 Maris Nartiss 2013-06-13 11:59:58 UTC
Just "me too". I use Mendeley (based on Zotero) and also sometimes get hit by this issue. Editing document with higlighted fields helps to see when issue appears and not continue editing till type/delete dance stops editing of the field content. Still more robust or user friendly approach would be nice.
Comment 2 QA Administrators 2015-10-14 19:56:24 UTC Comment hidden (obsolete)
Comment 3 sonajaqufe 2015-10-16 16:07:02 UTC
Works on Win7 Pro 64bit, with LibreOffice 5.0.2.2 and Zotero 4.0.28.7 and its LO Integration 3.5.10 :-)
Comment 4 Milan Bouchet-Valat 2015-10-16 18:21:53 UTC
Sorry, but it still happens here on Linux with LO 5.0.2.2. You need to enter some text, remove it, and type more to reproduce the problem.
Comment 5 QA Administrators 2016-11-08 11:05:56 UTC Comment hidden (obsolete)
Comment 6 Milan Bouchet-Valat 2016-11-10 22:16:30 UTC
Still present in LO 5.2.
Comment 7 Xisco Faulí 2017-06-26 18:44:49 UTC
This bug was never confirmed by a third person.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 8 Milan Bouchet-Valat 2017-06-26 20:19:51 UTC
Yes, it's been confirmed by one person other than me. It still happens with  LO 5.3.0.3 (I don't see a reason to think it would have been fixed in 5.3.4).
Comment 9 Xisco Faulí 2017-06-26 23:52:35 UTC Comment hidden (obsolete)
Comment 10 V Stuart Foote 2017-06-27 03:30:42 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2018-06-28 02:47:35 UTC Comment hidden (obsolete)
Comment 12 Milan Bouchet-Valat 2018-06-28 07:00:06 UTC
Still present in 6.0.4.2.
Comment 13 Alex Thurgood 2019-04-23 11:00:48 UTC
Isn't bug 123224 a DUPLICATE of this ? It seems to replicate what is being described here ?
Comment 14 Adomas Venčkauskas 2019-04-23 11:09:02 UTC
*** Bug 123224 has been marked as a duplicate of this bug. ***
Comment 15 Juang Dse 2019-07-01 14:14:23 UTC
*** Bug 126125 has been marked as a duplicate of this bug. ***
Comment 16 Dieter 2019-07-01 14:34:46 UTC
I confirm it with

Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Steps to reproduce
1. Open a new document
2. Insert Zotero citation
3. Type something after citation (text doesn't extend citation)
4. Delete text after citation or put cursor at the end of citation
5. Type text

Result: text extends citation
Comment 17 Juang Dse 2019-07-01 15:47:59 UTC
I wonder if the duplicate bug 123224 is not the simpler one. It is unrelated to Zotero, doesn't require any attachment, and seems to nail down exactly what is happening.

So instead of having bug 123224 being a duplicate of this one, should it not be vice versa?
Comment 18 Juang Dse 2019-07-09 08:03:58 UTC

*** This bug has been marked as a duplicate of bug 81720 ***