Bug Hunting Session
Bug 123228 - selection from Firefox themes (own theme) no longer works ( Firefox changed the API & removed the footer images)
Summary: selection from Firefox themes (own theme) no longer works ( Firefox changed t...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords:
: 123240 123249 123781 123911 123955 124228 124311 124404 125209 126502 (view as bug list)
Depends on:
Blocks: Firefox-Themes
  Show dependency treegraph
 
Reported: 2019-02-07 15:41 UTC by Max Merbald
Modified: 2019-09-18 15:17 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Merbald 2019-02-07 15:41:48 UTC
Description:
I just installed LibreOffice 6.2 which came in today and the theme from Firefox themes which I had used for ages was gone. I cannot bring it back because the dialog box in "chose firefos theme" keeps telling me there are no search results. Whatever I try, there are no search results whatsoever. 

Steps to Reproduce:
1. open dialog box for firefox dialog.
2. no themes are shown, result is "No search results"

Actual Results:
as I said, no firefox theme can be installed, none is shown to be selected.

Expected Results:
installation of a firefox theme 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Julien Nabet 2019-02-07 15:53:22 UTC
Muhammet: thought you might be interested in this one.
Comment 2 Xisco Faulí 2019-02-07 15:58:43 UTC
Yes, Firefox changed the API ( again ), so it doesn't work anymore...
Comment 3 Xisco Faulí 2019-02-07 23:00:37 UTC
*** Bug 123240 has been marked as a duplicate of this bug. ***
Comment 4 Julien Nabet 2019-02-08 07:55:09 UTC
*** Bug 123249 has been marked as a duplicate of this bug. ***
Comment 5 Julien Nabet 2019-02-08 08:00:21 UTC
Michael: considering that we may quickly have several dups of this one, thought it could be interesting to put Persona/themes management again on ESC.
(last time was http://document-foundation-mail-archive.969070.n3.nabble.com/minutes-of-conference-ESC-call-td4249713.html).
Should we finally deprecate this feature and put it as an extension?
Comment 6 David 2019-02-08 08:24:47 UTC
I second Julien's suggestion. Better to ship "Themes" as an extension, and perhaps include a larger variety of pre-installed themes like "solid grey" (I really like that one!)
Comment 7 Michael Meeks 2019-02-08 09:46:20 UTC
Sounds sensible wrt. ESC - sure, will try to remember to add it - Muhammet may have some ideas about how to do this. I agree that downloading them is far from ideal, and shipping them pre-canned and/or as extensions and controlling the packaging thereof is likely to be a far better idea. It would be nice not to depend on Mozilla there.
Comment 8 Max Merbald 2019-02-08 12:45:34 UTC
Would this still enable me to chose a theme from firefox? Or any own one?
Comment 9 Leandro Martín Drudi 2019-02-08 17:07:08 UTC
In january I try in a Beta2 and works. Something happens.
Comment 10 Muhammet Kara 2019-02-08 21:34:22 UTC
(In reply to Michael Meeks from comment #7)
> Sounds sensible wrt. ESC - sure, will try to remember to add it - Muhammet
> may have some ideas about how to do this. I agree that downloading them is
> far from ideal, and shipping them pre-canned and/or as extensions and
> controlling the packaging thereof is likely to be a far better idea. It
> would be nice not to depend on Mozilla there.

Depending on MOZ API for themes proved itself to be unreliable. I would vote for deprecating the search feature (or turning it to an experimental feature) in 6.3.

Some ideas might be:
* Theme packs via extensions
* A gallery for local/installed-via-extension themes
Comment 11 David 2019-02-10 12:24:11 UTC
@Muhamett would extension-themes be experimental in 6.3 too? Or stable?
Comment 12 Peter Maunder 2019-02-11 17:43:13 UTC
I also find that you can no longer use your own Personas already installed and used in your gallery/personas user folder using 6.2.0.3. I am unable to restore the personas using expert configuration or modifying the .xcu file directly. 

Perhaps my update is no longer correct. For example  for the .xcu file

<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="Persona" oor:op="fuse"><value>own</value></prop></item>
<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="PersonaSettings" oor:op="fuse"><value>default-personas;Default-Personas;default-personas/preview.jpg;default-personas/default-header.jpg;default-personas/default-footer.jpg;#0000ff;#000000</value></prop></item>

and for the OWN personalization option using expert configuration 

default-personas;Default-Personas;default-personas/preview.jpg;default-personas/default-header.jpg;default-personas/default-footer.jpg;#0000ff;#000000

Any advice??
Comment 13 Peter Maunder 2019-02-13 17:54:13 UTC
The personas_list.txt appears to have inconsistent line entries. For example the default on in 6.2 on my system is.

white;White;white/preview.png;white/header.png;white/footer.png;;#000000;#ffffff
gray;Gray;gray/preview.png;gray/header.png;gray/footer.png;;#000000;#ffffff
dark;Dark;dark/preview.png;dark/header.png;dark/footer.png;#ffffff;#000000
pink;Pink;pink/preview.png;pink/header.png;pink/footer.png;;#000000;#ffffff
sand;Sand;sand/preview.png;sand/header.png;sand/footer.png;;#000000;#ffffff
green;Green;green/preview.png;green/header.png;green/footer.png;;#000000;#ffffff

The dark Personas line has one less ; (semi-colon) between the FOOTER.PNG and the first colour selection #RGB indicator. I suspect this is the correct line and the others have an extra ; (semi-colon),

Which is the correct option?
Comment 14 Muhammet Kara 2019-02-16 16:13:12 UTC
(In reply to Peter Maunder from comment #13)
> The personas_list.txt appears to have inconsistent line entries. For example
> the default on in 6.2 on my system is.
> 
> white;White;white/preview.png;white/header.png;white/footer.png;;#000000;
> #ffffff
> gray;Gray;gray/preview.png;gray/header.png;gray/footer.png;;#000000;#ffffff
> dark;Dark;dark/preview.png;dark/header.png;dark/footer.png;#ffffff;#000000
> pink;Pink;pink/preview.png;pink/header.png;pink/footer.png;;#000000;#ffffff
> sand;Sand;sand/preview.png;sand/header.png;sand/footer.png;;#000000;#ffffff
> green;Green;green/preview.png;green/header.png;green/footer.png;;#000000;
> #ffffff
> 
> The dark Personas line has one less ; (semi-colon) between the FOOTER.PNG
> and the first colour selection #RGB indicator. I suspect this is the correct
> line and the others have an extra ; (semi-colon),
> 
> Which is the correct option?

I have no idea how those extra ; chars slipped in. Good cache!
Comment 15 Muhammet Kara 2019-02-16 16:15:52 UTC
I have taken a look at the API results, and it looks like that MOZ API no longer gives detailed info about personas (file urls), and it gives a single url to an xpi file instead. And the footer part seems to be gone (by looking into the unzipped zpi file). I have checked a few personas, and there were only the header files.
Comment 16 Muhammet Kara 2019-02-16 18:16:33 UTC
I confirm that the footers are gone for good. I propose disabling the "Load Firefox theme" button (with a tooltip like "The Mozilla Themes API is currently unreachable.") until we figure out what to do with these changes.
Comment 17 Dieter Praas 2019-03-01 09:59:51 UTC
*** Bug 123781 has been marked as a duplicate of this bug. ***
Comment 18 Max Merbald 2019-03-08 11:54:50 UTC
The problem has not been solved with version 6.2.1, it's still the same.
Comment 19 Julien Nabet 2019-03-09 08:16:16 UTC
*** Bug 123955 has been marked as a duplicate of this bug. ***
Comment 20 Xisco Faulí 2019-03-20 17:41:52 UTC
*** Bug 124228 has been marked as a duplicate of this bug. ***
Comment 21 Xisco Faulí 2019-03-25 10:28:13 UTC
*** Bug 124311 has been marked as a duplicate of this bug. ***
Comment 22 Eric 2019-03-25 14:12:42 UTC
If I am understanding this correctly then both bugs 123228 and 124311 are marked as duplicates of each other?  Shouldn't it be only one direction?
Comment 23 Xisco Faulí 2019-03-28 17:41:28 UTC
*** Bug 124404 has been marked as a duplicate of this bug. ***
Comment 24 Heiko Tietze 2019-04-17 10:32:17 UTC
*** Bug 123911 has been marked as a duplicate of this bug. ***
Comment 25 Max Merbald 2019-04-22 11:43:11 UTC
6.2.3 has also not solved the problem.
Comment 26 Commit Notification 2019-04-23 07:08:57 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0d28abe085293604eb3127626da9c5a520b25c21%5E%21

tdf#123228: Disable Firefox theme search

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2019-04-24 12:35:20 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/872e2463da2c3f0f50536fbf68a594631e9a7740%5E%21

tdf#123228: Disable Firefox theme search

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Max Merbald 2019-04-24 15:05:45 UTC
Sounds good - my thanks to Muhammet! :)
Comment 29 Tim Chambers 2019-05-06 06:10:08 UTC
Is there any chance of investigating an easy interface to already downloaded personas in the user profile when revising the personalisation?
Comment 30 Julien Nabet 2019-05-11 07:48:29 UTC
*** Bug 125209 has been marked as a duplicate of this bug. ***
Comment 31 Max Merbald 2019-05-22 15:29:27 UTC
Disabling cannot be the final solution, can it?
Comment 32 Franklin Weng 2019-05-22 15:34:46 UTC
(In reply to Max Merbald from comment #31)
> Disabling cannot be the final solution, can it?

Definitely not.  I'm also wondering how it works.  If we can download and apply Firefox theme before, then there should be a way to manually download the theme and apply it.  However I couldn't find the way either.
Comment 33 Muhammet Kara 2019-05-22 15:37:39 UTC
In reply to Tim Chambers from comment #29)
> Is there any chance of investigating an easy interface to already downloaded
> personas in the user profile when revising the personalisation?

Yep. That's intended.

(In reply to Max Merbald from comment #31)
> Disabling cannot be the final solution, can it?

Unfortunately it is, unless someone find a way to access the data which was removed from all themes by Mozilla. (the footer images)

(In reply to Franklin Weng from comment #32)
> (In reply to Max Merbald from comment #31)
> > Disabling cannot be the final solution, can it?
> 
> Definitely not.  I'm also wondering how it works.  If we can download and
> apply Firefox theme before, then there should be a way to manually download
> the theme and apply it.  However I couldn't find the way either.

Problem is not downloading but the content. The same theme downloaded a year ago and now are different. Current themes are missing the footer images.
Comment 34 Max Merbald 2019-05-31 22:11:17 UTC
That sounds more complicateed than I thought when I filed the bug. Anyway, just 6 different colours to personalise LO is not a big lot. Well, I guess it's going to take a while to find a solution. Thank you anyway for your work!

I think it would be nice if you could just use an image from your computer to personalise LO.
Comment 35 Adolfo Jayme 2019-07-25 12:52:58 UTC
*** Bug 126502 has been marked as a duplicate of this bug. ***
Comment 36 Max Merbald 2019-09-18 15:17:12 UTC
How are things looking? So far you don't seem to have found a solution.