Bug 124083 - Import filter issue with DOCX with embedded graph in decimal precision of x-axis values
Summary: Import filter issue with DOCX with embedded graph in decimal precision of x-a...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:6.4.0 target:6.3.2
Keywords: bibisected, bisected, regression
: 124405 127128 (view as bug list)
Depends on:
Blocks: OOXML-Chart Chart-Data
  Show dependency treegraph
 
Reported: 2019-03-14 16:40 UTC by Devon Powell
Modified: 2019-09-02 19:42 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
graph is displaying values similar to '0.1, 0.2, 0.3....' on the X-Axis of the graph, the conversion service changes this to 1.0, 2.0, 3.0 (deleted)
2019-03-14 16:42 UTC, Devon Powell
Details
Document to check the issue. (15.46 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-03-18 16:45 UTC, Devon Powell
Details
chart as in MS Word 2016 (29.09 KB, image/png)
2019-03-18 16:59 UTC, V Stuart Foote
Details
chart as in LO 6.2.1 Writer (35.04 KB, image/png)
2019-03-18 17:00 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Devon Powell 2019-03-14 16:40:34 UTC
Description:
When a word document is created with an embedded graph, and that graph is displaying values similar to '0.1, 0.2, 0.3....' on the X-Axis of the graph, the conversion service changes this to 1.0, 2.0, 3.0

Steps to Reproduce:
1.Open attached file in MS Word and LibreOffice
2.Notice the x-axis of the embedded graph showing different decimal precision within LibreOffice
3.

Actual Results:
Decimal values are not precise on X-axis

Expected Results:
Decimal values should be precise on X- axis


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Devon Powell 2019-03-14 16:42:10 UTC
Created attachment 149971 [details]
graph is displaying values similar to '0.1, 0.2, 0.3....' on the X-Axis of the graph, the conversion service changes this to 1.0, 2.0, 3.0
Comment 2 Devon Powell 2019-03-14 16:55:02 UTC
Comment on attachment 149971 [details]
graph is displaying values similar to '0.1, 0.2, 0.3....' on the X-Axis of the graph, the conversion service changes this to 1.0, 2.0, 3.0

Test
Comment 3 Devon Powell 2019-03-14 17:19:00 UTC Comment hidden (obsolete)
Comment 4 V Stuart Foote 2019-03-15 04:36:04 UTC
Confirmed with sample document on Windows 10 Home 64-bit en-US (1809) with
Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: group threaded

and on recent master/6.3.0alpha0+

Chart X axis values are decimal when opened in Word 2016, but are filter imported incorrectly to LibreOffice Writer. Values on the X-axis are labeled as if incorrectly scaled.
Comment 5 Guilhem Moulin 2019-03-15 13:40:30 UTC
The content of attachment 149971 [details] has been deleted for the following reason:

Deleted attachment per user request.
Comment 6 V Stuart Foote 2019-03-15 14:04:27 UTC
@Mohammed,

With removal of sample document, this issue can not be worked. Please prepare an anonymized example document that reproduces the issue and attach it. Then set the status back to NEW.

Thank you.
Comment 7 Devon Powell 2019-03-18 16:45:47 UTC
Created attachment 150077 [details]
Document to check the issue.
Comment 8 Devon Powell 2019-03-18 16:47:15 UTC
Test document attached.
Comment 9 V Stuart Foote 2019-03-18 16:58:49 UTC
Confirming the labeling applied to X-axis is incorrect as if a scal factor is being applied.

See attached screen clips...
Comment 10 V Stuart Foote 2019-03-18 16:59:21 UTC
Created attachment 150078 [details]
chart as in MS Word 2016
Comment 11 V Stuart Foote 2019-03-18 17:00:03 UTC
Created attachment 150079 [details]
chart as in LO 6.2.1 Writer
Comment 12 V Stuart Foote 2019-03-18 17:01:26 UTC
No improvement to handling of X-axis mislabeling on current Windows build of Master/6.3.0alpha0+
Comment 13 Gabor Kelemen 2019-08-14 10:03:57 UTC
@Balazs, could you please take a look at this one?
Comment 14 Gabor Kelemen 2019-08-27 07:29:56 UTC
Bibisected using bibisect-win32-5.3 repository to:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4bcf1872bbe9db1388769485a7e4c0cbcce3d53c

author	Jean-Tiare Le Bigot <admin@jtlebi.fr>	2016-10-13 23:43:41 +0200
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-11-06 06:02:27 +0000
Comment 15 László Németh 2019-08-30 11:18:54 UTC
tdf#124083 OOXML import: fix broken charts with missing value X

Importing NaN value X, ie. where only "ptCount" was defined without
explicit data, messed up the charts replacing all X values with sequence
1, 2, 3..., showing data points in wrong X positions, also showing the
invalid "NaN" data points. Now internal data table contains the original
X values, including NaNs, fixing broken charts.
Comment 16 Commit Notification 2019-08-30 11:19:37 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4afd65776457be3391f3e1340da614dffc8f227b%5E%21

tdf#124083 OOXML import: fix broken charts with missing value X

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Gabor Kelemen 2019-09-01 08:34:33 UTC
*** Bug 124405 has been marked as a duplicate of this bug. ***
Comment 18 Gabor Kelemen 2019-09-01 08:42:12 UTC
*** Bug 127128 has been marked as a duplicate of this bug. ***
Comment 19 Xisco Faulí 2019-09-02 12:23:12 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Balázs Varga, thanks for fixing this issue!!
Comment 20 Commit Notification 2019-09-02 19:42:54 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/7eb4d9d0763b8e0d6dc1d35a30f3bb9291b596f5%5E%21

tdf#124083 OOXML import: fix broken charts with missing value X

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.