Bug Hunting Session
Bug 124100 - Provide UI location to display a program icon for Extensions installed via Extension Manager, similar to buttons next to address bar in FireFox or Edge
Summary: Provide UI location to display a program icon for Extensions installed via E...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.2.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: UI
  Show dependency treegraph
 
Reported: 2019-03-15 14:56 UTC by 00
Modified: 2019-04-02 07:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
" Extension Manager " toolbar (360.90 KB, image/png)
2019-03-15 14:59 UTC, 00
Details
1、In "Customize", add the option of " Extension Manager ". (50.93 KB, image/png)
2019-03-15 15:01 UTC, 00
Details
In the "Extension Manager", After the "Add" software installation is complete, "Button" of "pattern", "Automatically" install "Options" in "One of the toolbars". (51.94 KB, image/png)
2019-03-18 15:45 UTC, 00
Details
Google→"Extension Manager" toolbar (75.69 KB, image/png)
2019-03-21 07:52 UTC, 00
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 00 2019-03-15 14:56:22 UTC
Description:
The " Extension Manager " toolbar is the same as the toolbar of the browser.
The " Extension Manager " toolbar, Because there is a "button", it can be pressed with a mouse, which will add a lot of functions.
Since "Firefox" is a free software, it is good to copy the design of "Firefox" directly.
Writer, Calc, Impress, Draw, Math, Base, all use this design.



method:
1、In "Customize", add the option of " Extension Manager ".
2、Enforce every software in the " Extension Manager ", there must be a "pattern" of the tool bar.
   ◎、because "pattern" is the "button".



in conclusion:
1、I think the " Extension Manager " toolbar will definitely attract more people to write programs.
2、Because the browser has the " Extension Manager " toolbar, it attracts more people to write programs, and Google uses this trick to defeat Microsoft.
3、The " Extension Manager " toolbar is also considered a "strategy."



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 00 2019-03-15 14:59:31 UTC
Created attachment 150001 [details]
" Extension Manager " toolbar
Comment 2 00 2019-03-15 15:01:05 UTC
Created attachment 150003 [details]
1、In "Customize", add the option of " Extension Manager ".
Comment 3 V Stuart Foote 2019-03-15 20:38:20 UTC
As usual I can not figure out what you are suggesting...


Are you saying we need a button on a toolbar for the "Extension manager" dialog?

Or, are you saying we need to migrate the Extension manager dialog to be a toolbar?

Or, are you saying we should implement the Extension manager as XHTML for manipulation via a Web browser, and integrate with our TDF hosted Extensions site https://extensions.libreoffice.org/extensions

Personally, I do not see a need for *any* change to the existing Extension Manager dialog.
Comment 4 00 2019-03-16 07:51:25 UTC
(In reply to V Stuart Foote from comment #3)

Not the same as what you said.

"124100" is a new report of "122685". (Because I don't know whether to use the "Expansion Kit" or the "Extension Manager", so there is "124100"......)
Https://bugs.documentfoundation.org/show_bug.cgi?id=122685

When the software is installed in the "Extension Manager", the "button" of the software "pattern" will appear in the toolbar.
Just like the design of the browser, you can copy the design of "Firefox" if necessary.
Comment 5 V Stuart Foote 2019-03-16 16:55:38 UTC
(In reply to 和尚蟹 from comment #4)
> 
> When the software is installed in the "Extension Manager", the "button" of
> the software "pattern" will appear in the toolbar.
> Just like the design of the browser, you can copy the design of "Firefox" if
> necessary.

OK. 

Most LibreOffice extensions will provide their own developer designed/managed Toolbars, so probably not a Toolbar.

I could see some utility to extending the Extension manager to place a visible Icon for each installed extension much as FireFox does with its extensions, or Chrome does (just for its "user" widget e.g. Guest, or Google UserID), or even Windows OS does with applet icons placed onto the Taskbar.

Perhaps it could done as a "Frame Decoration" applied to the LibreOffice Main menu--where we currently have the "X" to close document button, and the "LibreOffice update available" button located.

Toolbar or Frame decoration, would have to be a framework in core, for Extension devs to be able to link to.
Comment 6 Heiko Tietze 2019-03-18 09:05:09 UTC
Extensions should integrate into the program and I don't see a benefit from such a toolbar. Let's take some examples: templates, color palettes, gallery packs... (don't have any UI). And ultimately my take is to have much more of these customization in extensions.

In case of additional functionality (say: macros) it adds toolbar, menu entries, or any other control (eg. http://wollmux.org/). For what purpose/use case would the proposed meta toolbar be added? Managing (list, add, delete ett.) the extensions is done in the dedicated dialog, which can be opened per shortcut and customized (btw, I object the shortcut since the dialog is a rarely used function).
Comment 7 00 2019-03-18 15:45:45 UTC
Created attachment 150070 [details]
In the "Extension Manager", After the "Add" software installation is complete, "Button" of "pattern", "Automatically" install "Options" in "One of the toolbars".
Comment 8 00 2019-03-19 15:01:06 UTC
"Extension Manager" toolbar, supporting "piracy".
Comment 9 Adolfo Jayme 2019-03-20 14:13:59 UTC
@和尚蟹: I can’t really see the benefit of this. We are not a browser.
Comment 10 00 2019-03-21 07:24:58 UTC
Support "piracy", No mistakes.
"Extension Manager" toolbar, Really "by the way" to support "piracy."

"Installation version" Office→"by the way" to support "piracy."
"Online version" Office→"Piracy" is not supported. (because it will catch pirated copies)
Comment 11 00 2019-03-21 07:41:13 UTC
(In reply to Adolfo Jayme from comment #9)

Dude, "A few years ago" Google's "Online version", There is already an "Extension Manager" toolbar, Go to "Try it out" yourself.
Because Google saw the benefits, So Google will do this.

"Installation version" is not the same as "Design" of "Online version", So use the "browser" to explain.
Comment 12 00 2019-03-21 07:52:01 UTC
Created attachment 150136 [details]
Google→"Extension Manager" toolbar
Comment 13 Heiko Tietze 2019-04-02 07:59:38 UTC
(In reply to V Stuart Foote from comment #3)
> Personally, I do not see a need for *any* change to the existing Extension
> Manager dialog.

(In reply to Adolfo Jayme from comment #9)
> I can’t really see the benefit of this. We are not a browser.

I agree. Extensions are handled in a dedicated dialog, which is easy accessible. No need to change this.