Bug 125024 - Impress corrupts presentations being stored
Summary: Impress corrupts presentations being stored
Status: RESOLVED DUPLICATE of bug 100348
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-29 09:59 UTC by Kim Mongan
Modified: 2019-05-21 17:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Correct presentation in ODP format (5.67 MB, application/vnd.oasis.opendocument.presentation)
2019-04-29 11:00 UTC, Kim Mongan
Details
Corrupted PPTX (11.63 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-04-29 11:10 UTC, Kim Mongan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kim Mongan 2019-04-29 09:59:42 UTC
Description:
Impress corrupts presentations being stored, and this problem occurs in almost every release.  I have been fighting with this for years now.  This definitely does not seem to be tested enough before releasing a new version of impress.  Sometimes the odp is corrupted, most of the time ppt and pptx are corrupted.  In the present release 6.2.2.2 the presentations that I use are ok in odp format, but ppt and pptx are corrupted when I store them and try to use them again.

Steps to Reproduce:
1. Create a presentation with text, background pictures, videos
2. Store the presentation in different formats (ODP, PPT, PPTX)
3. After storing view the presentations again, they will look different, have corrupted text, what ever.  With this release ODP seems to be working OK, the previous release PPT worked.  Never know what format I should use to store my presentation in so that it will not be corrupted.  The worse part, you never know what works and what does not and often have to rework your presentation after storing it !!!! 

Actual Results:
I will provide a ODP that will be corrupted when storing it in PPT or PPTX.

Expected Results:
No error messages, just corrupted presentations.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Kim Mongan 2019-04-29 11:00:47 UTC
Created attachment 151062 [details]
Correct presentation in ODP format
Comment 2 Kim Mongan 2019-04-29 11:10:47 UTC
Created attachment 151063 [details]
Corrupted PPTX

The PPTX Format is corrupted, this corruption varies depending upon what all is in the presentation, wrong backgrounds, empty foils, etc.  A foil with embedded video was just an empty foil.  In this reduced version of my presentation the PPT looks like it is OK, in any case the corruption was not as bad as the PPTX corruption.
Comment 3 Timur 2019-04-30 14:06:30 UTC
Bugzilla is not "document based", like "this document doesn't display nice" or "story based" like "When I do my work, I have problems..". 
Bugzilla is "issue based", so a single issue must be pointed at, with exact steps to reproduce. 
Each issue (section break, paragraph break, text box size, picture position...) should be analyzed and checked for already reported bugs.

So, please write exact steps to reproduce with source ODT attachment 151062 [details].
Is this different from Bug 125023?
And confirm you searched for existing bugs before reporting. 
Thank you.
Comment 4 Kim Mongan 2019-05-16 20:49:23 UTC
You say that this bug report should be issued based.  I thought that is what this is.  The issue is that a presentation is getting stored improperly.  For example, when the presentation is stored in PPTX format the background of a slide may become entirely different.  Or the slide with a video is completly empty, not even a place holder for the video.
As already mentioned, each release seems to bring new problems.  I have been using the product for years, recently the only format I could use was PPT.  Storing in ODP Format corrupted my presentation - I had to redo it and store it in PPT format.
The release I am working with now is correctly stored in ODP format, but storing it in PPT or PPTX corrupts it.  Why PPT or PPTX - because many people use Powerpoint and at least Powerpoint Viewer, and most do not have the ODP patch.

So, please write exact steps to reproduce with source ODT attachment 151062 [details].
The steps are already listed below and presentations have been provided.  I just did a test again.  Created a presentation with a slide with text and a background (water picture), a second slide with a video.  Nothing more.
ODP - everything was fine. 32.330 KB
PPT - the text was fine, but just a video place holder and no video stored.  324 KB
PPTX - the text was present, but shadow was gone, not even a video place holder was present.  39 KB
  
Is this different from Bug 125023? Yes.

And confirm you searched for existing bugs before reporting. I do not know where to start to look.  Also, this problem has been around for years so it does not seem to be adressed.

A simple test like above shows that Libre Office is not storing documents properly, worse yet, no error messages occur or indication that something is wrong.  Users store there presentations, often hours of work, expecting to be able to use them.  After storing and then calling them up again they find their work corrupted at the least.  This is a major issue about the usability and reliability of the product.

Thank you.
Comment 5 QA Administrators 2019-05-17 03:10:18 UTC Comment hidden (obsolete)
Comment 6 raal 2019-05-21 17:19:24 UTC
(In reply to Kim Mongan from comment #4)

> 
> So, please write exact steps to reproduce with source ODT attachment 151062 [details]
> [details].
> The steps are already listed below and presentations have been provided.  I
> just did a test again.  Created a presentation with a slide with text and a
> background (water picture), a second slide with a video.  Nothing more.
> ODP - everything was fine. 32.330 KB
> PPT - the text was fine, but just a video place holder and no video stored. 
> 324 KB
> PPTX - the text was present, but shadow was gone, not even a video place
> holder was present.  39 KB
>   

Tested with Version: 6.3.0.0.alpha1+
Build ID: 38ac0586448d4f07811b139f62f62686b029feba
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 

PPT - I didn't found video in odp nor ppt
PPTX  - confirm the fontwork on the first slide is lost. It's duplicate of bug 100348. 

Please create separate bug for ppt issue, but we need reproducible test case, so attach odp with video, which is lost after export to ppt.

*** This bug has been marked as a duplicate of bug 100348 ***