Download it now!
Bug 125029 - Menus prefer going up
Summary: Menus prefer going up
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2019-04-29 15:28 UTC by JL
Modified: 2019-12-12 08:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshots (404.88 KB, image/png)
2019-04-29 15:28 UTC, JL
Details
Better (more visible) screenshots (294.18 KB, application/pdf)
2019-04-29 15:34 UTC, JL
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JL 2019-04-29 15:28:35 UTC
Created attachment 151071 [details]
screenshots

LO 6.1.5.2 on Debian Buster, installed from .deb packages from LO website, window manager XFCE, large workspace extents comprising one screen above the other.

The LO menus prefer to open upwards if there is sufficient space on the screen for them to do so. This is particularly problematic when they break across monitors, but I would consider it counter-intuitive in any case. I have not found any other application which does this, so it appears thus far to be LibreOffice specific. There are a couple of complaints found via Google search about upward opening menus even at the top of the screen which I suspect may be related due to poor reporting of the screen extents, but I haven't found other mention of the issue in this form.

I have attached an image containing screenshots showing the direction the menus go in depending on the position of LibreOffice on the screen. It applies to all menus and, as far as I can tell, all applications within the suite. 

If this is a feature rather than a bug, could I make a plea for a switch under Options to turn it off?

Potentially related is that right-click menus within LibreOffice seem to expand to the left if the click position was to the right of the screen's centreline. That is odd, but not nearly so detrimental to usability.

The workspace shown in the screenshots comprises a lower monitor at 3040x2160 and an upper one at 1920x1080.
Comment 1 JL 2019-04-29 15:34:52 UTC
Created attachment 151072 [details]
Better (more visible) screenshots
Comment 2 Xisco Faulí 2019-06-10 16:54:02 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 JL 2019-06-12 14:37:25 UTC
Confirm still the case in 6.2.4.2.

Further info: It seems to be calculating on the basis of the tallest menu (e.g. format in Writer). If there is just enough space between the menu bar and the top of the screen for that menu to open upwards, they all go up, and if just too little they all go down.

Adrian
Comment 4 Xisco Faulí 2019-12-10 15:36:32 UTC
Hi JL,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 5 JL 2019-12-11 23:04:54 UTC
Hurrah! The problem seems to be solved. Menus now go down by preference if there is space for them to do so. 

Many thanks to those involved in implementing the cure.
Comment 6 QA Administrators 2019-12-12 03:41:12 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2019-12-12 08:33:45 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.