Bug 125182 - Moving or renaming a file on Mac does not update window title bar
Summary: Moving or renaming a file on Mac does not update window title bar
Status: RESOLVED DUPLICATE of bug 92752
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Titlebar
  Show dependency treegraph
 
Reported: 2019-05-08 23:22 UTC by Pierre Thibault
Modified: 2022-07-27 14:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Thibault 2019-05-08 23:22:08 UTC
Description:
On the Mac version of LibreOffice, the window title bar of an open document displays the name of the file and Cmd-Click or Ctrl-Click displays the location of the file. If the file is moved or renamed while the document is open then, the file name or the location displayed is not updated. It should be. This is, as I know, affecting all document type.

Steps to Reproduce:
1. Create a new writer document and save the document somewhere.
2. Close the document.
3. Open the document.
4. Rename the or move the document in the Finder.

Actual Results:
Results for each steps:

1. The document has no icon displayed in the title bar after being saved.
2.
3. The document now displays an icon in the title bar.
4. The title bar is not updated with the new document name or location.

Expected Results:
Expected results for each steps:

1. Document icon should be displayed after saving.
2.
3.
4. The title bar should be updated with the new file name or document location but it is not.


Reproducible: Always


User Profile Reset: No



Additional Info:
After changing the file name of the document while it is open, saving the document  again triggers an alert that the document has changed while it has not.
Comment 1 Alex Thurgood 2019-05-14 07:25:20 UTC
Confirmed with :

Version: 6.3.0.0.alpha0+
Build ID: 03a2f3ec4316a3953c2fa40e6e59c2ebbc824d09
CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 psidiumcode 2021-04-29 18:30:38 UTC
*** Bug 141855 has been marked as a duplicate of this bug. ***
Comment 3 Michael Warner 2022-07-27 14:22:56 UTC

*** This bug has been marked as a duplicate of bug 92752 ***