Bug Hunting Session
Bug 125219 - kde5/wayland: Issues with slide show with videos
Summary: kde5/wayland: Issues with slide show with videos
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords:
Depends on:
Blocks: Wayland KDE
  Show dependency treegraph
 
Reported: 2019-05-11 19:30 UTC by Michael Weghorn
Modified: 2019-06-25 18:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2019-05-11 19:30:32 UTC
Version: 6.3.0.0.alpha0+
Build ID: 425a570a114d9a087e5320f071604f64d43fcec1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Steps to reproduce:

0) Use kde5 VCL plugin in a Plasma Wayland session
1) open a presentation containing a video in Impress (e.g. attachment 145517 [details] from bug 120452)
2) start slide show by pressing F5

Expected result: Slide show starts and plays the video. Sound is audible and video is displayed on screen.

Actual Results: Differing from time to time:
* better case: slide show starts and audio is audible, but video is not displayed on screen
* bad case: Impress crashes

Notes:
* This is explicitly for the qt5/kde5 on Wayland case. X11 is not affected in this way.
* s.a. bug 122293 that may hold related information, e.g. the reference to the related commit that probably made video-playback with gstreamer work with gtk3 on Wayland.
Comment 1 Vera Blagoveschenskaya 2019-05-13 06:35:11 UTC
I reproduced variant 1) slide show starts and audio is audible, but video is not displayed on screen

Version: 6.3.0.0.alpha0+
Build ID: 98630a0bd49bd80652145a21e4e0d0ded792b36b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-04_04:44:35
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Michael Weghorn 2019-05-24 19:50:29 UTC
s.a. additional information on bug 125271

Another approach I quickly tested was using "qwidget5videosink" similar to the way Caolán's commit 8543fbc72fafc0d71a8760752ca2ef5b7119cb5c added the use of "gtksink" for the gtk3 case.
Comment 3 Michael Weghorn 2019-05-24 19:55:41 UTC
Another issue when opening the file with the video in Impress is that the behaviour described in bug 122293 is still observable for that Impress window
-> check again once the main issue described here is fixed and possibly move to a separate bug report
Comment 4 Commit Notification 2019-06-09 03:29:46 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6fd4bfee60e93ee29c3e68587ff4665650b31a56%5E%21

tdf#125219 qt5: Try qwidget5videosink on Wayland

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Weghorn 2019-06-09 03:35:19 UTC
Video playback works as expected on Wayland now, but requires that GStreamer's "qwidget5videosink" [1] is available, otherwise the video is shown in separate window(s) and misplaced.
On Debian testing, e.g. "qwidget5videosink" can be installed via the package 'qtgstreamer-plugins-qt5'.


(In reply to Michael Weghorn from comment #3)
> Another issue when opening the file with the video in Impress is that the
> behaviour described in bug 122293 is still observable for that Impress window
> -> check again once the main issue described here is fixed and possibly move
> to a separate bug report

I don't reproduce this on master any more; this is independent of my above commit (no longer appeared without my commit either).

[1] https://gstreamer.freedesktop.org/data/doc/gstreamer/head/qt-gstreamer/html/qtvideosink_overview.html
Comment 6 Vera Blagoveschenskaya 2019-06-17 06:29:34 UTC
Can't reproduce anymore.

Version: 6.4.0.0.alpha0+
Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-15_11:49:26
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Commit Notification 2019-06-25 18:54:54 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/cc4051bddd7bad2ba28f9e827e6d75f0aacb6649%5E%21

tdf#125219 qt5: Try qwidget5videosink on Wayland

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.