Download it now!
Bug 125517 - LO Impress: Can't stop presentation with video and go to the next slide
Summary: LO Impress: Can't stop presentation with video and go to the next slide
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords:
Depends on:
Blocks: KDE 132172
  Show dependency treegraph
 
Reported: 2019-05-27 06:52 UTC by Vera Blagoveschenskaya
Modified: 2020-07-27 12:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
video to test (4.17 MB, application/vnd.oasis.opendocument.presentation)
2019-05-27 06:52 UTC, Vera Blagoveschenskaya
Details
video how to reproduce it (17.18 MB, video/quicktime)
2019-05-27 06:53 UTC, Vera Blagoveschenskaya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vera Blagoveschenskaya 2019-05-27 06:52:21 UTC
Description:
Can't stop presentation with video and go to the next slide

Steps to Reproduce:
1. Open document with video (in the attachment). It contains 1 slide with video, 2 and 3 with text
2. Start presentation from the 1st slide.



Actual Results:
Video plays normally, but I can't stop it and go to the next slide. I can't even finish the presentation.
I tried to push left/right/center mouse buttons, Enter, Space, Esc, any key..

Reproduced from time to time. 5/10
See video in the attachment

Expected Results:
Go to the next slide by pressing Space, exit the presentation by pressing Esc


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha1+
Build ID: 40e2a0d7039eee9c5377996da3949680903e1016
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-22_13:55:35
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

DO NOT reproduce if to start LO with GTK3.
It's KDE5 issue
Comment 1 Vera Blagoveschenskaya 2019-05-27 06:52:52 UTC
Created attachment 151694 [details]
video to test
Comment 2 Vera Blagoveschenskaya 2019-05-27 06:53:18 UTC
Created attachment 151695 [details]
video how to reproduce it
Comment 3 Julien Nabet 2019-05-27 08:37:58 UTC
Michael: considering tdf#125219 that I put in cc, thought you might be interested in this one.
Comment 4 Michael Weghorn 2019-05-28 06:46:33 UTC
From my observation (with master as of commit 9d18bc40416b651340804f44ba5fae65f3bbbcfa and some unrelated changes on top):

* After starting presentation, using keyboard (right arrow key) works just fine, as do the Space key and Esc.
* Using the left mouse button to go forward works **if** the mouse click is done outside of the area where the video resides.
* Left-Clicking "into the video" using the left mouse button does not go to the next slide.
* After left-clicking where the video is, pressing right arrow key, Space or Esc also don't lead to any reaction.
* left-clicking somewhere outside of the video area makes everything work as expected again.

So it seems that left-clicking into the area where the video resides somehow "captures" the keyboard. This doesn't happen for gtk3.

@Vera: Can you confirm this behaviour from your side?
Comment 5 Michael Weghorn 2019-05-28 07:04:51 UTC
As a side note, my tests in comment 4 refer to the X11 case. Retesting with Wayland once bug 125219 is fixed might be interesting.
Comment 6 Vera Blagoveschenskaya 2019-05-28 07:11:09 UTC
(In reply to Michael Weghorn from comment #4)
> @Vera: Can you confirm this behaviour from your side?

Michael, thanks a lot for your clarification of the steps!
Indeed, mouse clicking to the area outside the video doesn't lead to slide changing.

Thus, I set the status 'New'.
Comment 7 Michael Weghorn 2019-05-30 12:47:47 UTC
(In reply to Michael Weghorn from comment #5)
> As a side note, my tests in comment 4 refer to the X11 case. Retesting with
> Wayland once bug 125219 is fixed might be interesting.

FWIW, I cannot reproduce on Wayland with https://gerrit.libreoffice.org/#/c/72968/3 applied (and package qtgstreamer-plugins-qt5 installed on Debian testing).
Comment 8 Commit Notification 2019-06-12 21:23:01 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/25edbded9946801effd117b9c46de0f8b4bc5632%5E%21

tdf#125517 Qt5 implement a minimal Qt5ObjectWindow

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-06-13 01:57:00 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/03352dc301bb7e67445e81d017376aa24264e9a3%5E%21

tdf#125517 Qt5 implement a minimal Qt5ObjectWindow

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Vera Blagoveschenskaya 2019-06-17 06:37:51 UTC
I've checked the behavior for 

Version: 6.4.0.0.alpha0+
Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-15_11:49:26
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

mouse clicking to the area outside the video leads to crash.
I'll try to attach the crash report a bit later.
Comment 11 Vera Blagoveschenskaya 2019-06-17 06:39:30 UTC
(In reply to Vera Blagoveschenskaya from comment #10)
> I've checked the behavior for 
> 
> Version: 6.4.0.0.alpha0+
> Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-06-15_11:49:26
> Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> mouse clicking to the area outside the video leads to crash.
> I'll try to attach the crash report a bit later.

Sorry 
click INSIDE the video --> leads to crash
Comment 12 Michael Weghorn 2019-06-17 06:59:46 UTC
(In reply to Vera Blagoveschenskaya from comment #10)
> I've checked the behavior for 
> 
> Version: 6.4.0.0.alpha0+
> Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
> CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-06-15_11:49:26
> Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> mouse clicking to the area outside the video leads to crash.
> I'll try to attach the crash report a bit later.

I can't reproduce with

Version: 6.4.0.0.alpha0+
Build ID: abd059fcd81975e2e4f9188734fc8418299caf6b
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

on Debian testing. Neither clicking inside or outside the area where the video is leads to a crash in my case.

@Vera:
Maybe this should be filed as a separate bug report?
In case you find the time to do so, bibisecting [1] this issue might also help; the new bibisect repository for 6.4 has kde5 enabled. [2]

[1] https://wiki.documentfoundation.org/QA/Bibisect
[2] https://qa.blog.documentfoundation.org/2019/06/13/bibisect-linux-64-6-4-is-available-with-kde5-support/
Comment 13 Jan-Marek Glogowski 2019-06-19 17:56:23 UTC
The original bug is fixed. Neither Michael nor myself get a crash. Please open a new bug report for the crash, so we can investigate what is broken now for you.
Comment 14 Vera Blagoveschenskaya 2019-06-20 08:03:14 UTC
Original problem is verified fixed
New bug with crash --> https://bugs.documentfoundation.org/show_bug.cgi?id=126020