Bug Hunting Session
Bug 126508 - Crash and document recovery on option change of view -> icon style
Summary: Crash and document recovery on option change of view -> icon style
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.2 rc
Hardware: All All
: highest critical
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.3.0 target:6.4.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 126816 (view as bug list)
Depends on:
Blocks: Options-Dialog-View
  Show dependency treegraph
 
Reported: 2019-07-22 12:28 UTC by V Stuart Foote
Modified: 2019-08-11 09:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
WinDbg32 stack trace of TB39 build with symbols (13.10 KB, text/plain)
2019-07-22 14:55 UTC, V Stuart Foote
Details
windbg32 ST for non-OpenGL (11.33 KB, text/plain)
2019-07-22 15:09 UTC, V Stuart Foote
Details
bt with debug symbols (5.84 KB, text/plain)
2019-07-28 11:15 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2019-07-22 12:28:01 UTC
A change of icon themes causes crash and recovery

With any module open to a new empty document 

Tools -> Options -> View -> Icon style list box 

completing with OK will crash.

reported on macOS for bug 125510, but present on Windows builds of master / 6.4.0alpha1+

Not present with StartCenter 

=-testing-=
Windows 10 Home 64-bit en-US (1903) with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 140b070bb187e3d5e35a588a1d187e3a40e11547
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-20_12:36:59
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 V Stuart Foote 2019-07-22 14:55:43 UTC
Created attachment 152944 [details]
WinDbg32 stack trace of TB39 build with symbols
Comment 2 V Stuart Foote 2019-07-22 15:09:23 UTC
Created attachment 152945 [details]
windbg32 ST for non-OpenGL

Just to be sure, checked and also crash/recover mergedlo!vcl::Window::RemoveEventListener with Default rendering. 

ST attached.
Comment 3 V Stuart Foote 2019-07-22 15:14:19 UTC
@Ashod, this may be your recent work on the Sidebar...
Comment 4 V Stuart Foote 2019-07-22 18:49:43 UTC
None of Ashod's stuff has posted yet.

@Samuel? Assume change to selected icon theme would be tracked in Sidebar state

https://gerrit.libreoffice.org/#/c/75719/ looks suspect...
Comment 5 V Stuart Foote 2019-07-26 16:45:37 UTC
Adjusting importance per QA guide, still needs a bibisect...
Comment 6 Julien Nabet 2019-07-28 11:15:39 UTC
Created attachment 153012 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
Comment 7 Julien Nabet 2019-07-28 11:22:54 UTC
By reverting partially the quote commit, so with this patch:
diff --git a/sfx2/source/sidebar/SidebarController.cxx b/sfx2/source/sidebar/SidebarController.cxx
index 22b022bf09ee..5af03faa08ea 100644
--- a/sfx2/source/sidebar/SidebarController.cxx
+++ b/sfx2/source/sidebar/SidebarController.cxx
@@ -733,6 +733,7 @@ void SidebarController::SwitchToDeck (
     const DeckDescriptor& rDeckDescriptor,
     const Context& rContext)
 {
+    maFocusManager.Clear();
     const bool bForceNewDeck ((mnRequestedForceFlags&SwitchFlag_ForceNewDeck)!=0);
     const bool bForceNewPanels ((mnRequestedForceFlags&SwitchFlag_ForceNewPanels)!=0);
     mnRequestedForceFlags = SwitchFlag_NoForce;

I don't reproduce the crash.
Comment 8 Ashod Nakashian 2019-07-28 19:01:06 UTC
The backtrace doesn't hint at a change I had done, though valgrind might show something not visible in the bt.

If the partial revert to Samuel's commit resolves it, then great.

Let me know if need anything from me please.
Comment 9 Xisco Faulí 2019-07-29 09:31:02 UTC
Regression introduced by:

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-07-16 17:41:48 +0200
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-07-18 10:27:25 +0200
commit	b58aa94f1f365c746135470bceb97cc182c289bc (patch)
tree	2f4b915889695ac214988d66312498864ead62ed
parent	2b4efc32e822bf41c4b729137718f3c70f692a89 (diff)
tdf#126424 Don't dispose decks before saving their state

Bisected with: bibisect-linux64-6.4

Adding Cc: to Samuel Mehrbrodt

The patch is present in 6.3.0.2. IMHO, this should block the 6.3 until it's fixed
Comment 10 Samuel Mehrbrodt (CIB) 2019-07-29 09:32:15 UTC
There is already a patch from Julien in comment 7.
@Julien: Would you please push that patch to gerrit for review? Or should I do that?
Comment 11 Xisco Faulí 2019-07-30 09:10:57 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #10)
> There is already a patch from Julien in comment 7.
> @Julien: Would you please push that patch to gerrit for review? Or should I
> do that?

Hi Samuel,
Considering LibreOffice 6.3 RC3 is going to be tagged this week, I was wondering if you could submit the patch yourself ( I could do it as well if needed ), I'd rather not to wait for someone else ( just in case he's on vacation / absent ) otherwise we wouldn't make it in time
Comment 12 Samuel Mehrbrodt (CIB) 2019-07-30 09:21:41 UTC
(In reply to Xisco Faulí from comment #11)
> (In reply to Samuel Mehrbrodt (CIB) from comment #10)
> > There is already a patch from Julien in comment 7.
> > @Julien: Would you please push that patch to gerrit for review? Or should I
> > do that?
> 
> Hi Samuel,
> Considering LibreOffice 6.3 RC3 is going to be tagged this week, I was
> wondering if you could submit the patch yourself ( I could do it as well if
> needed ), I'd rather not to wait for someone else ( just in case he's on
> vacation / absent ) otherwise we wouldn't make it in time

Done: https://gerrit.libreoffice.org/#/c/76589/ and https://gerrit.libreoffice.org/#/c/76590/
Comment 13 Commit Notification 2019-07-30 14:26:11 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/857f68d68b3d0092f109845cfd93482871a0793d%5E%21

tdf#126508 Fix crash when changing icon style

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-07-30 17:39:52 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-0":

https://git.libreoffice.org/core/+/63ccc97e1699d90da2532e4294cdaff670ad1a3f%5E%21

tdf#126508 Fix crash when changing icon style

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-07-31 05:13:03 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b25284244a4a0e5ff480538133ee18f471a4bfc8%5E%21

tdf#126508 Fix crash when changing icon style

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2019-07-31 12:38:14 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 7680623292f272cf1a8cceb4abb5a67bb5469918
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Samuel, @Julien, thanks for fixing this issue!
Comment 17 V Stuart Foote 2019-08-01 04:09:37 UTC
Also verified fixed on Windows builds
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 5c30c20101f72d973ff28c228f755e635cad14d5
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

(In reply to Xisco Faulí from comment #16)
> ...
> @Samuel, @Julien, thanks for fixing this issue!

+1
Comment 18 Julien Nabet 2019-08-11 09:03:59 UTC
*** Bug 126816 has been marked as a duplicate of this bug. ***