Download it now!
Bug 126901 - openTemplate does not offer template list
Summary: openTemplate does not offer template list
Status: RESOLVED DUPLICATE of bug 104074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2019-08-14 00:31 UTC by TorrAB
Modified: 2019-08-20 18:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2019-08-14 00:31:35 UTC
Description:
open any writer document, hit ~fmo to OpenTemplate: you get the standard open-file window (as for OpenFile), which (usually) contains no template.
Now, hit ~fmm to ManageTemplates: you get the list of templates; click one to open it.
The OpenTemplate choice seems defective.


Steps to Reproduce:
open any writer document, hit ~fmo to OpenTemplate: you get the standard open-file window (as for OpenFile), which (usually) contains no template.
Now, hit ~fmm to ManageTemplates: you get the list of templates; click one to open it.
The OpenTemplate choice seems defective.


Actual Results:
no template list

Expected Results:
obtain a list of templates to choose from


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2019-08-20 16:09:52 UTC
I confirm the described behaviour and I also would prefer to get a template list (=> Status NEW); informations from LO-help:
"Opens a dialog where you can select a template for editing." [1]

Let's also ask design team for further input.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

and

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group

[1] https://help.libreoffice.org/6.4/en-US/text/shared/01/01110400.html?&DbPAR=WRITER&System=WIN
Comment 2 Maxim Monastirsky 2019-08-20 18:40:30 UTC
The purpose of this command is to allow editing templates, which aren't listed in the template manager. That's why it shows the file open dialog. See Bug 61396 where it was added to the menu.

Only that its title is confusing: "Open Template" sounds like:
1. It's going to show a list of templates to choose from.
2. After selecting a template, a new document will be created, based on the selected template.

Both are wrong. It shows the file open dialog to allow selecting the template from an arbitrary place, and it open the template itself for editing, not a new document based on the template.

*** This bug has been marked as a duplicate of bug 104074 ***