Bug 127012 - UI: Presenter Console changes slides on every click of the mouse.
Summary: UI: Presenter Console changes slides on every click of the mouse.
Status: RESOLVED DUPLICATE of bug 127921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-08-18 16:06 UTC by Roland Taylor
Modified: 2019-12-06 14:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Taylor 2019-08-18 16:06:38 UTC
Description:
Even scrolling, the presenter console in LibreOffice Impress 6.3 is changing slides any time you click. It is causing major problems when presenting. I had to use LibreOffice 6.2.

Steps to Reproduce:
1. Start a presentation.
2. Click anywhere (even on the scrollbar).

Actual Results:
The slide will change.

Expected Results:
No slide change unless actually clicking on "next" or "previous", or otherwise changing the slide.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Nothing.
Comment 1 Roland Taylor 2019-08-18 16:07:36 UTC
Forgot to mention, this is the snap version on Ubuntu 19.04 - so it is as pristine as can be.
Comment 2 Roland Taylor 2019-08-18 16:07:55 UTC Comment hidden (obsolete)
Comment 3 bchemnet 2019-09-25 14:06:56 UTC
I can confirm this bug in 6.3.2.1 (Debian).  It is quite annoying.  For example, if I switch between displaying notes and slides in Presenter Console, the slide advances.  If I scroll the slides to look ahead, the slide advances.  Etc.  Basically this renders interaction with Presenter Console impossible.

I also did not have this problem with 6.2 or earlier versions, but I cannot say exactly when it was introduced.
Comment 4 Xisco Faulí 2019-09-26 14:54:34 UTC
it seems to be a regression based on the summary
Comment 5 Roland Taylor 2019-11-10 15:39:03 UTC
This bug still occurs on Ubuntu 19.10.

Now I'm stuck with 6.3 and will need to find a way to downgrade or install 6.2 until this bug is fixed.
Comment 6 Samuel Mehrbrodt (CIB) 2019-11-13 07:13:51 UTC

*** This bug has been marked as a duplicate of bug 127921 ***