Download it now!
Bug 127066 - UI: Font size in input line (formular bar) larger than in other UI elements
Summary: UI: Font size in input line (formular bar) larger than in other UI elements
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Thorsten Wagner
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: needsUXEval
: 127133 (view as bug list)
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2019-08-21 06:09 UTC by Thomas Lendo
Modified: 2020-06-08 09:46 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2019-08-21 06:09:39 UTC
Thanks to the great work of Thorsten Wagner, some bugs regarding the input line in Calc were fixed.

One change with this fixes is an increassed font size in the input line. It's really better readable now but it feels not appropriate in comparison to other UI elements.

Mike Kaganski remarks in bug 101443 comment 51:
"I don't quite get the increase of the font size here. If it is "unreadable on some OS X resolutions", then other UI elements (like Name Box) would be also unreadable; in general, the application UI font settings should just follow OS settings; so this part of change makes some change that looks unneeded, partial, and incorrect - if something doesn't follow OS settings, it should be fixed in a proper place and have universal effect. Currently, it just makes a single UI control inconsistent."

Therefore I request the design team to discuss this change.
Comment 1 Thorsten Wagner 2019-08-22 14:35:01 UTC
Calc input line is a special widget which is used in Calc only. In relation to other UI widgets this widget may contain a lot of text like direct input to Calc cells.

It's only a small effort to revert font size equal to the other UI elements, but this will restore worse readability especially with larger amounts of text.
Comment 2 Mike Kaganski 2019-08-22 18:04:49 UTC
A transcript from #libreoffice IRC chat:

> Marqeaux has joined
> Marqeaux: Hi everybody. I want to ask a question about the formula bar in Calc. The font size in the formula bar has been increased for better readability. Is there a way to make the font size in the formula bar smaller again, just like it was in previous versions of LibreOffice?
> Marqeaux: Oh, I'm using LibreOffice 6.3.0. I forgot to mention that piece of information...
> quikee[m]: Marqeaux: interesting ... it's the same size for me
> Marqeaux: I got LibreOffice 6.3.0. on more machines installed. The formula bar shows a bigger font (too big for my taste), and the formula bar is also increased in height. It used to have the same height as the cell bar (where you see in which cell you are)...
> Marqeaux: I prefer the situation like it was in LO 6.2. (the formula bar, I mean...)
> Marqeaux: ;)
> mikekaganski: Marqeaux: I confirm font size increase in 6.3
> quikee[m]: maybe it manifests in windows. I was looking in Linux with gtk3 backend
> quikee[m]: we modified the scrollbars of the formula bar.. could be that has influenced the size
> mikekaganski: quikee[m]: /me bisects
> Marqeaux: Is there a way in the expert configuration to alter the size of the fonts in the formula bar, and also the height of the formula bar?
> quikee[m]: Marqeaux: no, I don't think so... increase is also not intentional so it looks like you "found" a bug
> mikekaganski: Marqeaux: ... which needs a bug report
> mikekaganski: quikee[m]: 04b60370a73b79e3aa0a04bc7cff45dff1db6286
> Marqeaux: I made a screenshot of what I see (on multiple machines, not only on Xubuntu): https://mupload.nl/img/edk3kknwn.png
> mikekaganski: Marqeaux: so it was intentional in the end: tdf#101443
> Marqeaux: I guess it's intentional, because more and more software follow the GTK3 guidelines. I think it's awful, because GTK3 makes everything big and bold, and with no borders. I looks like a "Fischer-Price" kinda of approach....
> mikekaganski: Marqeaux: it wasn't because of "GTK3" (and most LO users are on Windows btw); it was because of the previous font was unreadable on some macOS (not using GTK3 also)
> mikekaganski: Marqeaux: "In addition to inputline redesign, character size has been increased to 120% of original size. This prevents very small / unreadable inputline character sizes on some OS X resolutions"
> Marqeaux: Ah, alright. But anyway.... I takes up too much space now. It's fine that the fonts in the formula bar are bigger, but I hope that there's a way to make it "normal" again...
> mikekaganski: Marqeaux: the commit mentioned above has the min font size fixed (16, strange size for UI actually). You may file an enhancement request to make it user-configurable or smaller.
> Marqeaux: Yes, I also found it a very strange decission to make it that big. It just doesn't fit into the GUI. I think it's better to make it user-configurable, rather than to leave it "hard-coded". Although my eyes aren't that good (I wear glasses and I'm middle aged), but I never had trouble reading the formula bar as it was before.
> Marqeaux: Where can I file an enhancement request?
> mikekaganski: Marqeaux: I already wrote a comment there in the original bug. I gave you the link to the bug, and that's the site where we write and track reports.
> mikekaganski: Marqeaux: please file your request separately regardless of my comment: it would help to provide arguments when needed. Please put the mentioned bug to See Also in the new report. Thanks.
> Marqeaux: Thanks for the advice. I will report it, along with my arguments. Thank you too! ;)
> Marqeaux has disconnected: Quit: Ik ben weg! Tot ziens allemaal!

I still think that it's easy to make a smaaaall tweak - just to make this little thingie a bit bigger... and then do another tiny tweak to change that a little... and so on. But if there's a problem with readability of some text size that is used throughout our application, and there's no such problems in other applications on that OS, then that means that either we use wrong text size *universally* in our app (which means we don't get correct size from OS), or (if we use proper size) that we render text wrong (blurry?). And tweaking text size in one specific control to workaround is just wrong. A fix is needed, but in a different place. Please don't enrich the codebase with hacks that would make it a PITA later to find why something works differently and unexpectedly.

And in general - that patch included *different* fixes - something that is *never* a good thing, e.g. in case when you need to revert one change, but not another.
Comment 3 Heiko Tietze 2019-08-23 05:47:52 UTC
How about an (expert) option here? 

The general approach would be something like Browsers offer where you can zoom into the content. We could do the same for font size and maybe kind reintroduce bug 101646 (UI scaling), which receives a lot of interest, but per control vs. per application. Though, this sounds like an overkill to me.
Comment 4 Mike Kaganski 2019-08-23 06:18:30 UTC
(In reply to Heiko Tietze from comment #3)

Fixing bug 101646 as a whole makes lots more sense than implementing some per-control things like this. I vote against a setting for this one, but am neutral about bug 101646 (but would love a better fix that would simply malke LO correctly follow OS settings).
Comment 5 V Stuart Foote 2019-08-23 12:09:39 UTC
(In reply to Mike Kaganski from comment #4)
> (In reply to Heiko Tietze from comment #3)
> 
> Fixing bug 101646 as a whole makes lots more sense than implementing some
> per-control things like this. I vote against a setting for this one, but am
> neutral about bug 101646 (but would love a better fix that would simply
> malke LO correctly follow OS settings).

Agree with Mike's take on it (comment 2 comment 4), should not be doing this one widget at a time. Reimplementing UI scaling for bug 101646 would be massive, but so would establishing a framework (with expert config settings) to do it per widget which would be the other approach.

Also, would point out the other "Formula Bar" (inputwin.cxx/.hxx) for use in writer Tables is now even more radically different UI to the sc flavor.
Comment 6 V Stuart Foote 2019-08-24 01:46:38 UTC
*** Bug 127133 has been marked as a duplicate of this bug. ***
Comment 7 Thorsten Wagner 2019-08-24 10:33:10 UTC
Preparing a patch to revert font size to 100% of UI font size
Comment 8 Heiko Tietze 2019-08-26 07:09:57 UTC
(In reply to Thorsten Wagner from comment #7)
> Preparing a patch to revert font size to 100% of UI font size

Please add me to the reviewers.
Comment 9 Thorsten Wagner 2019-08-26 13:26:11 UTC
Change submitted to Gerrit: https://gerrit.libreoffice.org/78140/
Comment 10 Commit Notification 2019-09-05 03:15:56 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e757a88f5141a2816d6c69bff5234c9f8802c79a%5E%21

tdf#127066 Font size of Calc input bar aligned to UI font size

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 V Stuart Foote 2019-09-07 13:15:01 UTC
The partial reversion [1] to work on bug 101443 [2] still needs backport to 6.3
  
The oversize font in the calc formula bar was released in 6.3.0 and unfortunately into 6.3.1 as well, need to restore it to 100% of UI font size in 6.3 as has been done for master/6.4.0

=-ref-=
[1] https://gerrit.libreoffice.org/78140
[2] https://gerrit.libreoffice.org/71937
Comment 12 Commit Notification 2019-09-08 07:51:54 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-2":

https://git.libreoffice.org/core/+/b613ca105b080bb275d6f687b6b443b10b27c284%5E%21

tdf#127066 Font size of Calc input bar aligned to UI font size

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-09-08 11:56:36 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/cd28e8b36c95a8de71b9a8a0ac6702b8018eedac%5E%21

tdf#127066 Font size of Calc input bar aligned to UI font size

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 V Stuart Foote 2019-09-08 13:25:47 UTC
@Adolfo, Heiko -- thanks for the backports...
Comment 15 Commit Notification 2019-09-09 16:14:19 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-2":

https://git.libreoffice.org/core/+/856565e99d9f3245d1ccb0563eeed6cdfd557afc%5E%21

Revert "tdf#127066 Font size of Calc input bar aligned to UI font size"

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Heiko Tietze 2019-09-09 16:17:49 UTC
Shouldn't have picked for 6.3._2_ but 6.3. So I reverted this patch and Adolfo's work should do the backport.