Bug 127327 - GTK2 backend → Corrupted thumbnail generation (6.3.1 RC)
Summary: GTK2 backend → Corrupted thumbnail generation (6.3.1 RC)
Status: RESOLVED DUPLICATE of bug 125461
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 126846 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-04 06:01 UTC by Timur Davletshin
Modified: 2019-09-05 11:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File with black thumbnail (7.82 KB, application/vnd.oasis.opendocument.text)
2019-09-04 11:14 UTC, Timur Davletshin
Details
LO with recent documents showing black thumbnail (63.40 KB, image/png)
2019-09-05 07:23 UTC, Timur Davletshin
Details
Nautilus showing black thumbnail generated by LO 6.3 with gtk2 backend (45.93 KB, image/png)
2019-09-05 07:26 UTC, Timur Davletshin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur Davletshin 2019-09-04 06:01:31 UTC
Description:
Thumbnail generation is broken in GTK2 backend (6.3.1 RC)

Steps to Reproduce:
1. Switch to GTK2 backend
2. Create any document
3. Save it
4a. Preview thumbnail in recent documents is black
4b. Rename saved file to zip and open it. Thumbnail PNG inside is black too.

Actual Results:
Black thumbnail

Expected Results:
Preview reflects document content


Reproducible: Always


User Profile Reset: Yes



Additional Info:
GTK3 and QT/KDE works fine.
Comment 1 Timur Davletshin 2019-09-04 06:03:30 UTC
Probably it is linked to https://bugs.documentfoundation.org/show_bug.cgi?id=126254
Comment 2 Julien Nabet 2019-09-04 06:43:51 UTC
Caolán: should we consider it as a WONTFIX since gtk2 will be soon dropped?
Comment 3 Timur Davletshin 2019-09-04 06:49:27 UTC
(In reply to Julien Nabet from comment #2)
> Caolán: should we consider it as a WONTFIX since gtk2 will be soon dropped?

I believe we should fix gtk3 issues first before dropping gtk2.
Comment 4 Timur Davletshin 2019-09-04 06:52:01 UTC
(In reply to Julien Nabet from comment #2)
> Caolán: should we consider it as a WONTFIX since gtk2 will be soon dropped?

6.3. release will have its life cycle for quite a while and leaving users with this bug is not humane )))
Comment 5 Xisco Faulí 2019-09-04 10:20:39 UTC
Could you please share a screenshot ?
We already have these 2 reports -> bug 126791 and bug 125461
Comment 6 Timur Davletshin 2019-09-04 11:13:12 UTC
(In reply to Xisco Faulí from comment #5)
> Could you please share a screenshot ?
> We already have these 2 reports -> bug 126791 and bug 125461

I believe it is the same. I believe I used wrong keywords before posting a new bug. Recent document shows internal thumbnail.png, which is generated by LO.
Comment 7 Timur Davletshin 2019-09-04 11:14:14 UTC
Created attachment 153857 [details]
File with black thumbnail

Check preview/thumbnail inside
Comment 8 Timur Davletshin 2019-09-04 11:16:14 UTC
(In reply to Xisco Faulí from comment #5)
> Could you please share a screenshot ?
> We already have these 2 reports -> bug 126791 and bug 125461

This happens only with gtk2 backend. It was introduced in 6.3 I believe. Earlier mentioned bug with black "About" screen was introduced at the same time.
Comment 9 Xisco Faulí 2019-09-04 11:19:34 UTC
Could you please paste the info from Help - about LibreOffice ?
Comment 10 Timur Davletshin 2019-09-04 11:49:03 UTC
(In reply to Xisco Faulí from comment #9)
> Could you please paste the info from Help - about LibreOffice ?

Version: 6.3.0.4
Build ID: 1:6.3.0-2~bpo10+1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: en-US (C.UTF-8); UI-Language: en-US
Calc: threaded

But it works in current 6.3.1 builds too.
Comment 11 Julien Nabet 2019-09-04 12:36:46 UTC
So already fixed in 6.3 branch if prerelease 6.3.1 is ok?
Comment 12 Timur Davletshin 2019-09-04 12:39:17 UTC
(In reply to Julien Nabet from comment #11)
> So already fixed in 6.3 branch if prerelease 6.3.1 is ok?

No, it is not fixed. Only bug with black background of "About" dialog was fixed. Thumbnails in current 6.3.1 builds are black.
Comment 13 Julien Nabet 2019-09-04 13:06:00 UTC
It seems I can't understand anything about this tracker. Uncc myself to avoid polluting.
Comment 14 Timur Davletshin 2019-09-05 07:23:50 UTC
Created attachment 153893 [details]
LO with recent documents showing black thumbnail
Comment 15 Timur Davletshin 2019-09-05 07:26:16 UTC
Created attachment 153894 [details]
Nautilus showing black thumbnail generated by LO 6.3 with gtk2 backend
Comment 16 QA Administrators 2019-09-05 09:35:41 UTC Comment hidden (obsolete)
Comment 17 Caolán McNamara 2019-09-05 11:28:47 UTC
I bisected this to

commit 86ea64f216819696cd86d1926aff0a138ace2baf
Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
Date:   Fri Feb 15 13:14:32 2019 +0100

    Support for native 32bit Bitmap in VCL and SVP (cairo) backend

similar to other similar cases I only see this in VirtualManager as opposed to my real desktop
Comment 18 Caolán McNamara 2019-09-05 11:29:21 UTC
*** Bug 126846 has been marked as a duplicate of this bug. ***
Comment 19 Xisco Faulí 2019-09-05 11:33:49 UTC
(In reply to Caolán McNamara from comment #17)
> I bisected this to
> 
> commit 86ea64f216819696cd86d1926aff0a138ace2baf
> Author: Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
> Date:   Fri Feb 15 13:14:32 2019 +0100
> 
>     Support for native 32bit Bitmap in VCL and SVP (cairo) backend
> 
> similar to other similar cases I only see this in VirtualManager as opposed
> to my real desktop

Hi Caolán,
Same commit as in bug 125461

*** This bug has been marked as a duplicate of bug 125461 ***