Download it now!
Bug 127455 - Cannot update information in a Bibliography Entry
Summary: Cannot update information in a Bibliography Entry
Status: RESOLVED DUPLICATE of bug 128845
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2019-09-09 19:16 UTC by George Politis
Modified: 2019-12-04 13:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Before applying the updates (49.28 KB, image/png)
2019-09-09 19:19 UTC, George Politis
Details
After Applying the update (48.04 KB, image/png)
2019-09-09 19:20 UTC, George Politis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description George Politis 2019-09-09 19:16:21 UTC
Description:
Cannot update information for a "Bibligraphy Entry".
The Bibliography holds all the information the were written upon creation but the entries cannot be updated.

The only work around to this is to change the short name of the entry.

Steps to Reproduce:
1)Insert > Table of contents and Bibliography... > Bibliography Entry...
2) Click "new" and add some information
3) Click "ok" and then "insert".
4) Rick-Click on the rescently created entry > "Bibliography entry..."
5) Click on "Edit" add additional information. Then click "ok" and "apply".


Actual Results:
Bibliography Entry is not updated. It displays the initial entered details upon creation.

Expected Results:
The updated information at the Bibliography entry should be stored.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 George Politis 2019-09-09 19:19:53 UTC
Created attachment 154061 [details]
Before applying the updates
Comment 2 George Politis 2019-09-09 19:20:30 UTC
Created attachment 154062 [details]
After Applying the update

The updates are not stored
Comment 3 alexrayne 2019-09-11 13:34:36 UTC
win8x64 have same bug since 6.3.0.4
Comment 4 Dieter 2019-09-12 12:01:26 UTC
Does it happen with odt-files or only with doc(x) format. If this is the case, it could be a duplicate of bug 105367.
Comment 5 George Politis 2019-09-12 12:24:10 UTC
I "saved as" my (Word 2007-365) docx file to odt file and it has the same issue regarding adding new attributes to the bibliography entry.
In fact not only I cannot update my bibliography entry but during the convertion the type changed from WWW document to Article and the URL attribute was deleted.

Seems relevant to bug 105367.
Comment 6 Dieter 2019-09-15 05:22:10 UTC
(In reply to George Politis from comment #0)
> Actual Results:
> Bibliography Entry is not updated. It displays the initial entered details
> upon creation.

I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: f0c832acb53326ccc9a8c1a47401fbc9e1081feb
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-11_05:46:53
Locale: en-GB (de_DE); UI-Language: en-US
Calc: threaded

but not with

Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

After pressing "Apply" LO asks for confirmation of changing the entry. This doesn't happen in master.
Comment 7 raal 2019-09-19 13:10:27 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one? Thanks

5045ef008c278543c4ec5fa880489ecaf11ddd1c is the first bad commit
commit 5045ef008c278543c4ec5fa880489ecaf11ddd1c
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Jan 23 03:46:48 2019 -0800

    source sha:3b16e997f69efe2e3f6cdf64fe8fb2727b6ebaa7

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-01-18 15:38:07 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-01-21 07:34:09 +0100
commit	3b16e997f69efe2e3f6cdf64fe8fb2727b6ebaa7 (patch)
tree	a0d65d6b892ea39d0da8992cbab6bda579e19cdf
parent	2af5d6006948890229d9e55feb56e0e849bf857d (diff)
cleanup SwAuthEntry manual ref-counting
Comment 8 Xisco Faulí 2019-12-04 13:21:47 UTC
This is a duplicate of bug 128845

*** This bug has been marked as a duplicate of bug 128845 ***