Download it now!
Bug 127611 - Writer: ~h does not toggle Hidden effect
Summary: Writer: ~h does not toggle Hidden effect
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords:
: 135326 (view as bug list)
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2019-09-18 00:57 UTC by TorrAB
Modified: 2020-12-28 08:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2019-09-18 00:57:26 UTC
in Writer, select some text and format it: hit ~o,h,Enter to open Character; choose FontEffects, hit ~l, ~w, or ~b to change (toggle on/off) the Outline, Shadow or Blinking effect.
But ~h does not change Hidden; one must 'confirm' it with the space bar.
Comment 1 V Stuart Foote 2019-09-18 04:26:26 UTC
Suspect the ~h accelerator of the hidden character attribute is conflicting with the ~h of the help action--but it is an annoying keyboard accelerator inconsistency in the UI.
Comment 2 Ming Hua 2020-11-25 23:55:52 UTC
(In reply to V Stuart Foote from comment #1)
> Suspect the ~h accelerator of the hidden character attribute is conflicting
> with the ~h of the help action
I agree the problem is that ~h is assigned as mnemonic for both "Hidden" and "Help".  However the problem can't be easily fixed with a string change, because here ~h is automatically assigned to "Hidden".

I submitted a patch
https://gerrit.libreoffice.org/c/core/+/106670
to address the symptom of the problem without fixing the underlying flaw of the mnemonic auto-generation mechanism.
Comment 3 Gabor Kelemen 2020-12-27 07:12:11 UTC
*** Bug 135326 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2020-12-28 08:29:21 UTC
Ming Hua committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d70d71d1598297686d420d2f3a0ad1b840d67734

tdf#127611 Hardcode mnemonic key for "Hidden" checkbox

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.