Bug 128100 - Add build number for Windows 10 in to About dialog
Summary: Add build number for Windows 10 in to About dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium enhancement
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.4.0
Keywords:
: 128098 128099 (view as bug list)
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2019-10-11 19:57 UTC by Roman Kuznetsov
Modified: 2019-10-13 21:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-10-11 19:57:43 UTC
Description:
Add build number for Windows 10 in to About dialog

MS says we will not have Windows 11,12....etc but they will be update internal build number for current Windows 10. So we'll be have Windows 10 build 1809, Windows 10 build 1903, etc. So I suggest add this build number into About dialog in LO for simplify QA work

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Aron Budea 2019-10-11 23:34:44 UTC
*** Bug 128099 has been marked as a duplicate of this bug. ***
Comment 2 V Stuart Foote 2019-10-12 03:12:54 UTC
*** Bug 128098 has been marked as a duplicate of this bug. ***
Comment 3 Mike Kaganski 2019-10-12 10:08:03 UTC
https://gerrit.libreoffice.org/80712
Comment 4 Commit Notification 2019-10-12 11:36:58 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b7e4e85170e383ecd1cba56913c901783cb8d1d6

tdf#128100: add explicit service pack and build info to Windows version

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Roman Kuznetsov 2019-10-13 21:18:49 UTC
verified in

Версия: 6.4.0.0.alpha0+ (x64)
ID сборки: ccfbe8b478f3daa8b5ec07a7e48dd5fbf8556811
Потоков ЦП: 4; ОС:Windows 10.0 Build 17763; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

thank you, Mike!