Download it now!
Bug 128214 - Impress can only draw on one screen in Wayland
Summary: Impress can only draw on one screen in Wayland
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-17 15:15 UTC by Tom B
Modified: 2020-12-14 14:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom B 2019-10-17 15:15:11 UTC
Description:
When using Wayland instead of Xorg, Impress does not show on both displays. This breaks the core functionality of Libreoffice Impress and means it cannot be used for presentations on Wayland. 

Running the slideshow will only ever display on one display (by default on the laptop screen).

This may only affect KDE as it's the only desktop environment I've tested. 

Steps to Reproduce:
1. Log in to a Wayland KDE session 
2. Create/load a presentation
3. Start  a slide show

Actual Results:
Using the default slide show settings "Presentation Display: Auto External (Display 2)" the slideshow preview correctly appears on the primary display but nothing appears on the external, secondary display.


Using "All displays", 50% of the presentation displays on one screen

Using "Display 1" still displays the preview window on  Display 2 and nothing on display one.

Expected Results:
The slide preview should show on display 1, the presentation on display 2


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
System:

Arch Linux
KDE 5.17
Wayland

Happens with OpenGL enabled and disabled.
Comment 1 Tom B 2019-10-17 15:21:18 UTC
Update: Using the KDE taskbar, I can see the window for "Presenting: Untitled 1". If I move the window to another virtual desktop, I get the preview window on desktop 2 and the slideshow on desktop 1, but they are both on the same screen.

So the problem isn't that the sideshow window isn't being created, but that both windows are being drawn on the same screen.
Comment 2 Timur 2019-10-17 15:30:57 UTC
I don't have wayland to test, but your but title seems too generic. See for example bug 106031 or some other bug. Please try to narrow down the cause and update the title.
Comment 3 Michael Weghorn 2019-11-21 14:38:02 UTC
This sounds like the same as tdf#119719 was describing for X11.
This **might** well be a Qt, KF5 or KWin issue and outside of the control of LibreOffice.

What version of Qt do you have? Do you have any other KDE application that uses multiple screens and works as expected on Wayland?
Comment 4 Michael Weghorn 2019-12-03 18:13:22 UTC
(In reply to Michael Weghorn from comment #3)
> This sounds like the same as tdf#119719 was describing for X11.
> This **might** well be a Qt, KF5 or KWin issue and outside of the control of
> LibreOffice.
> 
> What version of Qt do you have? Do you have any other KDE application that
> uses multiple screens and works as expected on Wayland?

I just tested in a Plasma Wayland session. The behaviour is the same for me when using the "gtk3" VCL plugin instead of the "kf5" one:

Version: 6.5.0.0.alpha0+
Build ID: e849867726fe1112a4bce71bf21a5e3b25c5a0e8
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

This sounds like it was rather a Qt, KF5 or kwin issue, therefore I'm closing this bug as NOTOURBUG.

Please reopen if the issue is still reproducible in e.g. a GNOME Wayland session and using the gtk3 VCL plugin (it's used by default in a GNOME session).
Comment 5 Michael Weghorn 2020-12-14 14:20:53 UTC
I've taken a look at this now and reported a bug for KWin: https://bugs.kde.org/show_bug.cgi?id=430376