Download it now!
Bug 128842 - SLIDESHOW: presenter console overlaps presentation in kde5
Summary: SLIDESHOW: presenter console overlaps presentation in kde5
Status: RESOLVED DUPLICATE of bug 119719
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-11-16 16:43 UTC by mark.wenzel
Modified: 2019-12-12 08:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mark.wenzel 2019-11-16 16:43:31 UTC
Description:
I tried to show the presenter console on one display and the presentation on an other display under opensuse 15.1 with libreoffice 6.2.7.1.

This results in only showing presenter console. The presentation will be displayed in the background of the presenter console. So the presentation is invisible. I can change between both views with Alt-Tab.

I tried several Versions of libreoffice to find out which version is affected. All Versions from 6.2.0 on are affected.

Steps to Reproduce:
1. Use computer with two displays
2. Use opensuse Leap 15.1 with plasma desktop or icewm desktop
3. activate presenter console in libreoffice
4. open presentation
5. start presentation (F5)

Actual Results:
1. Presenter console shows up on presenter (first) display.
2. Presentation shows is invisible and located behind presenter console on presenter (first) display.
3. presentation (second) display shows normal background wallpaper

Expected Results:
1. Presenter console shows up on presenter (first) display.
2. Presentation shows on presentation (second) display.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.7.1
Build-ID: 20(Build:1)
CPU-Threads: 12; BS: Linux 4.12; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 1 Robert Großkopf 2019-11-16 18:32:42 UTC
Could confirm the buggy behaviour.

Have tested with a simple impress-file and LO 6.3.3.2., VCL:kde5. Slide show settings have been set to "Presentation display: Auto External(Display 2) - but nothing could be seen there.
Comment 2 Timur 2019-11-17 08:18:35 UTC
I understand from report and confirmation that this is kde5. 
Please explain why this is a regression, with which version it worked.
Comment 3 Robert Großkopf 2019-11-17 08:55:49 UTC
(In reply to Timur from comment #2)
> I understand from report and confirmation that this is kde5. 
> Please explain why this is a regression, with which version it worked.

Works will all versions up to LO 6.1, fails first with LO 6.2 on the same OpenSUSE system.

Both tests were made with OpenSUSE and KDE. There has been kde4 in LO 6.0, could also be LO 6.1. Also gtk has been changed from 6.1 to 6.2, but we haven't tested with gtk.
Comment 4 Robert Großkopf 2019-11-18 19:02:47 UTC
Other people in German opensuse-user-list tested this one. Seem to work with gtk3, so a special kde5-bug.
Comment 5 Michael Weghorn 2019-12-11 16:33:07 UTC
What Qt version do you have?
Is this with X11 or Wayland?

There is a bug in Qt versions < 5.10 that cause this issue, s. bug 119719 for details; and the problem still seems to be there with newer Qt versions on Wayland, s. bug   128214, so if any of the two conditions are met, there's probably little we can do from LibreOffice side...
Comment 6 mark.wenzel 2019-12-12 08:09:35 UTC
(In reply to Michael Weghorn from comment #5)
> What Qt version do you have?
Qt version is 5.9.7

> Is this with X11 or Wayland?
Problem exists with X11. I did not use Wayland.
Comment 7 Michael Weghorn 2019-12-12 08:30:44 UTC
(In reply to mark.wenzel from comment #6)
> (In reply to Michael Weghorn from comment #5)
> > What Qt version do you have?
> Qt version is 5.9.7

Thanks for the update. This means that you're affected by the Qt bug as described in bug 119719. The problem should go away once a newer Qt version is available/installed.

As a workaround until then, you can start LibreOffice with the environment variable SAL_USE_VCLPLUGIN=gtk3 or SAL_USE_VCLPLUGIN=gtk3_kde5 set to force using the gtk3 or gtk3_kde5 VCL plugin -- or manually arrange the two windows as needed.

*** This bug has been marked as a duplicate of bug 119719 ***