Bug 128243 - UI scaling issues for HiDPI screens -- Windows WDM
Summary: UI scaling issues for HiDPI screens -- Windows WDM
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords:
: 134686 (view as bug list)
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2019-10-18 22:19 UTC by Damian Hofmann
Modified: 2021-04-17 17:29 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
UI Scaling Issues on HiDPI screen (311.33 KB, image/png)
2019-10-18 22:19 UTC, Damian Hofmann
Details
clips Writer & Draw from master 7.0 TB77 build 20200430 on Windows 10 w UI scaled to 225% (661.72 KB, application/x-zip-compressed)
2020-05-01 17:08 UTC, V Stuart Foote
Details
LO7 UI scaled to 275% on Win10 (120.33 KB, image/png)
2020-05-10 16:57 UTC, V Stuart Foote
Details
Sidebar deck on 1920x1080 (148ppi screen) w custom scaling set at 225% (124.32 KB, image/png)
2020-08-15 18:53 UTC, V Stuart Foote
Details
os/DE UI scaling to 225% misapplied to Sidebar elements -- oversize widths (101.25 KB, image/png)
2020-12-01 15:41 UTC, V Stuart Foote
Details
sidebar on LO 7.2.0.0alpha0+ (200.21 KB, image/png)
2021-04-13 17:06 UTC, Damian Hofmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Damian Hofmann 2019-10-18 22:19:32 UTC
Created attachment 155134 [details]
UI Scaling Issues on HiDPI screen

Please excuse my severe choice of words in the title. But after updating to LO 6.3 I ran into so many UI scaling problems on my HiDPI screen, that I had to revert back to LO 6.2. Resolution is 3840x2160 with a scaling factor of 250% configured in Windows settings.

Some of the problems:

1. In the toolbars, all down-pointing triangles for opening the drop-down menues are too large. They either get cut-off or overlap into the neighboring toolbar-button.
2. Some icons in these drop-downs are too small
3. Sidebar takes a huge portion of the screen and can't be made narrower. Drop-down menus and input fields in the sidebar are unnecessarily wide.
4. Icons for selecting the sidebar are too small
5. Icons in the status bar are extremely small. Smaller than the standard sized mouse cursor actually.

See attached screenshot/montage for a better visual explanation of the issues. The screenshot is of LO Writer, but I noticed the same problems in Calc as well.

These issues cause serious usability problems. I tried starting LO in "Safe Mode", but the issues persisted.


Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: de-CH (de_CH); UI-Language: en-US
Calc: threaded
Comment 1 V Stuart Foote 2019-10-18 22:59:51 UTC Comment hidden (obsolete)
Comment 2 Damian Hofmann 2020-01-30 01:27:18 UTC
Reopening because after fixing bug 127434, many of the reported display issues still exist in LO 6.3.4:

[NOT FIXED] 1. In the toolbars, all down-pointing triangles for opening the drop-down menus are too large. They either get cut-off or overlap into the neighboring toolbar-button.

It's no longer as extreme as it was before LO 6.3.4. But those triangles still don't fit.

[NOT FIXED] 2. Some icons in these drop-downs are too small

The "Favorites" in the "Insert Special Characters" drop-down are still too small / barely readable, as shown in attachment from 2019-10-18.

Label "More Options..." in the "Insert Table" drop-down is still cut off, as shown in attachment from 2019-10-18.

[NOT FIXED] 3. Sidebar takes a huge portion of the screen and can't be made narrower. Drop-down menus and input fields in the sidebar are unnecessarily wide.

Seems a little better than before LO 6.3.4. But the sidebar still takes a quarter of my screen and can't be made smaller.

[    FIXED] 4. Icons for selecting the sidebar are too small~
[    FIXED] 5. Icons in the status bar are extremely small. Smaller than the standard sized mouse cursor actually.
Comment 3 Damian Hofmann 2020-05-01 15:44:03 UTC
Retested with LO 6.4.3

* Reported issues with side bar still exist
  * Side bar takes huge amount of screen space, can't be reduced to smaller size, probably due to drop-down menus (e.g. font selection) enforcing too large min-width. 
  * Triangles for drop-down menus still too large, as shown in screen shot
* Options for selecting special characters still too small, as shown in screen shot
* In Writer, in the menu for inserting a table, the label of the button "More Options" still is being cut-off, as shown in screen shot.


Tested with:

Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: de-CH (de_CH); UI-Language: en-US

Windows UI scaling at 200%


Reverting back to LO 6.28, as that is the last version of LO that had usable UI for me.
Comment 4 V Stuart Foote 2020-05-01 17:03:47 UTC
Concur with the Reopened as distinct from bug 127434. And, just checked with current master/7.0.0 (TB77 2020-04-30 build).

With Colibre SVG icon theme, and Windows 10 set to 225% scaling (using the MS Windows 'Advanced scaling settings' from desktop).

A couple of the widgets on the Sidebar deck, notably the color pickers, are not being scaled the same same as other widgets, Sidebar or Toolbars.

The recently welded Sidebar deck has gotten pretty bad--fixed minimum deck width and some fields scaled way to wide results in a comical GUI with just 25% of screen available for document canvas--the rest is the Sidebar!

Some screen clips attached.
Comment 5 V Stuart Foote 2020-05-01 17:08:45 UTC
Created attachment 160191 [details]
clips Writer & Draw from master 7.0 TB77 build 20200430 on Windows 10 w UI scaled to 225%

zip of several screen clips Windows 10 with master/7.00 (TB77 20200430) for Writer and Draw, w/Colibre SVG icon theme (Large or Small size selected for theme). 

Note the Sidebar 'Properties' deck width are too wide for either icon size at this scale factor.
Comment 6 V Stuart Foote 2020-05-10 16:25:50 UTC
With the 7.0.0alpah1 release, scaling of the splitbutton exposure triangles, and the enormous width calculation for the Sidebar decks remain annoyances on the Windows builds.

Does not require use of HiDPI monitor--seems these are LibreOffice miscalcualtion of scaling factors of UI elements visible for WDM scaling above 175% and will show on even modest 96dpi screens (including VM).

Render engine selection makes no difference -- default GDI, OpenGL, Skia Vulkan/Raster all manifest the misScaled UI elements.
Comment 7 V Stuart Foote 2020-05-10 16:57:17 UTC
Created attachment 160613 [details]
LO7 UI scaled to 275% on Win10

LO7 on Windows 10 on a 1920x1080 HD laptop panel. But even on a 4K HiDPI the sidebar deck width seems too wide.

Also, the color picker widgets open their dialog to full size--but their icon on the Sidebar is not scaled the same as the UI.  Likewise, for the Special Symbol split button or dialog, the 'Recents' & 'Favorites' character pickers are not being scaled with the same as the UI.
Comment 8 V Stuart Foote 2020-07-09 15:55:43 UTC
*** Bug 134686 has been marked as a duplicate of this bug. ***
Comment 9 V Stuart Foote 2020-08-15 18:53:08 UTC
Created attachment 164332 [details]
Sidebar deck on 1920x1080 (148ppi screen) w custom scaling set at 225%

This clip shows effect of WDM scaling to 225% on *minimum* width of the Writer sidebar Properties deck with the Table content panel showing.  

@Caolán, * -- excessive width is not the Table content panel as suggested in bug 130197 for aligning content, but seems to reside still in calculating the spin box width size when DE scaling is applied.
Comment 10 V Stuart Foote 2020-12-01 15:41:01 UTC
Created attachment 167727 [details]
os/DE UI scaling to 225% misapplied to Sidebar elements -- oversize widths

@Caolán, saw you'd removed yourself from the related bug 131947 for Linux builds. But I think there really is something off in calculating the correct Sidebar element widths in response to os/DE scaling, here for WDM on Windows. But I think also for some of the Linux backends as well.

Element y-scaled heights seem fine, but the x-scaled widths of the elements are not.  The elements (Glade packing, list boxes, spin buttons) are given too much width when scaled, likewise the corresponding deck width 'minimum' is calculated too wide.

This screen clip is a recent (20201129 - 5abb1980f - TB77) build on Windows 10 with the os/DE 'Advanced Scaling Settings' -> 'Custom Scaling' of 225%.  The Sidebar Properties deck can not be made any narrower than shown. The extra width accumulates from each of the incorrectly x-scaled elements.
Comment 11 V Stuart Foote 2020-12-02 23:45:35 UTC
Spun up a Fedora 33 Workstation VM and enabled Fractional Scaling to 175%, seems the gtk3 backend is not affected, the y-scaling matches the x-scaling for the Sidebar controls, unlike the scaling of Windows WDM. 

=-testing-=
VMWare Workstation 15.5 on Windows 10 64-bit
 
Linux localhost.localdomain 5.9.11-200.fc33.x86_64 #1 SMP Tue Nov 24 18:18:01 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Version: 7.0.3.1
Build ID: 00(Build:1)
CPU threads: 1; OS: Linux 5.9; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 12 V Stuart Foote 2021-04-11 14:50:21 UTC
Could other folks affected please retest with a parallel install [1] of current master against a 7.2 release [2].

Using Win10 Display settings -> Advanced scale settings to set a custom scale of 250% a 15" 1920x1080 px display, and separately to 250% with a 40" 3480 x 2160 px display, the Sidebar controls (notably drop lists & spin boxes) are now reasonably scaled and the full Sidebar Deck is reduced to a workable width.

TB 77 build from 2021-04-10
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 807d059d99e7b99fe45a712428befa17ffa44858
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

At this point => WFM

=-ref-=
[1] https://wiki.documentfoundation.org/Installing_in_parallel/Windows#Version_3.5.x_and_newer
[2] https://dev-builds.libreoffice.org/daily/master/Win-x86_64@tb77-TDF/
Comment 13 Damian Hofmann 2021-04-13 17:06:01 UTC
Created attachment 171166 [details]
sidebar on LO 7.2.0.0alpha0+

Sorry, but it's just getting worse. It depends a bit on which panel I bring up. "Style Inspector" is the most extreme, taking up more than half of the screen and can't be made any smaller. See attached screen shot.

I also tried in "safe mode" and resetting my user profile. Didn't help.


Tested with:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: fde3b0e07eaf86ed4e16326de323f79db706e8f2
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: de-CH (de_CH); UI: en-US
Calc: threaded
Comment 14 V Stuart Foote 2021-04-13 19:15:38 UTC
(In reply to Damian Hofmann from comment #13)
> Created attachment 171166 [details]
> sidebar on LO 7.2.0.0alpha0+
> 
> Sorry, but it's just getting worse. It depends a bit on which panel I bring
> up. "Style Inspector" is the most extreme, taking up more than half of the
> screen and can't be made any smaller. See attached screen shot.
> 
> I also tried in "safe mode" and resetting my user profile. Didn't help.

No, I think there are some different issues with the Style Inspector deck, that is bug 136764, which needs additional work.

The other SB decks do seem to be better behaved at higher UI scaling on recent builds of master against 7.2

Anyone else?
Comment 15 V Stuart Foote 2021-04-17 17:29:09 UTC
In master against 7.2.0 release, with bug 136764 mostly correct now for the Style Inspector--the general issues at higher the WDM scaling needed for HiDPI support seem resolved.

Please file any new (remaining) issues as new BZ tickets.