Bug 128298 - CALC - it doesn't work Paste Special (unformatted text)
Summary: CALC - it doesn't work Paste Special (unformatted text)
Status: RESOLVED DUPLICATE of bug 57147
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2019-10-21 15:02 UTC by kabilo
Modified: 2020-10-26 10:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

screen shot of copy paste special bug libreoffice calc (271.96 KB, image/png)
2019-12-31 22:16 UTC, Rick Davis

Note You need to log in before you can comment on or make changes to this bug.
Description kabilo 2019-10-21 15:02:14 UTC
doesn't work Paste Special (unformatted text) - it's nothing inserted

Version: (x64)
Build ID: 3e8fb860d92160e41a1aef5a0a53e4447120eb2e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: cs-CZ (cs_CZ); UI-Language: en-US
Calc: CL

Steps to Reproduce:
1. copy the selected cells
2. select Paste Special - Unformatted text (or Ctrl+Alt+Shift+V)
3. nothing happens

Actual Results:
nothing happens

Expected Results:

Reproducible: Always

User Profile Reset: No

Additional Info:
Comment 1 Durgapriyanka 2019-10-21 18:02:50 UTC
Thank you for reporting the bug. I cannot reproduce the bug in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-


Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Xisco Faulí 2019-10-23 14:15:55 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 3 kabilo 2019-10-23 14:57:17 UTC
user profil is restarted ( LO is running in safe mode):

isn't paste text frome more lines (from txt file) or more lines of cells (menu for selecting the import parameters isn't displayed). No data pasted.

Paste only one line or one line of cells work, but like Ctrl+V (menu for selecting the import parameters isn't displayed). Data are pasted.
Comment 4 Timur 2019-10-26 19:30:11 UTC Comment hidden (obsolete)
Comment 5 kabilo 2019-10-29 09:15:59 UTC
(In reply to Timur from comment #4)
> Did you search existing before posting a new bug? Is this the same as
> https://bugs.documentfoundation.org/show_bug.cgi?id=116983 ?

no, this is another issue (new in 6.4).
Comment 6 raal 2019-10-29 13:06:35 UTC
I can not confirm with Version: (x64)
Build ID: ad0a97ca200328d336a3cd58942f71a824b1f23a
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win;
Comment 7 Rick Davis 2019-12-31 22:00:57 UTC Comment hidden (me-too)
Comment 8 Rick Davis 2019-12-31 22:01:47 UTC
I am experiencing the bug in Libreoffice_calc version  Running Debian stretch on Pixelbook in Crostini VM.  
When I copy several cells in calc and do paste special I expect to get the screen that allows you to choose different formats, text, formats, formulas, etc.  Instead, you get the screen that only lets you choose formatted or unformatted text.   I am very familiar with how paste_special should work from my MS excel experience.  I am also seeing reports of this bug in version 6 of LibreOffice calc.  If I do a paste it inserts the data as an "image" bitmapped file.
Comment 9 Rick Davis 2019-12-31 22:16:26 UTC
Created attachment 156864 [details]
screen shot of copy paste special bug libreoffice calc
Comment 10 Timur 2020-01-01 16:07:20 UTC
This bug is loosing sense. 
Kabilo's issue is not clear and if he said it wasn't the same as bug 116983, he didn't explain why, what makes this one specific.
Rick is adding another request for different paste formats (original issue mentioned Paste Special - Unformatted text) and speaks about  bug 128803.
I set back Needinfo for Kabilo to explain.
Comment 11 QA Administrators 2020-06-30 03:41:48 UTC Comment hidden (obsolete)
Comment 12 b. 2020-06-30 08:25:00 UTC
dear Timur, dear QA Administrators, dear all, 
bugzilla is full of reports about LO copy&paste weaknesses, a simple search for 'copy paste' has 1064 results (fixed ones omitted?), tdf#102593 ([META] 'paste')  has about 259 entries (about half resolved as duplicate, worksforme, insufficientdata, wontfix, but nearly none by fixing or patching), none 'assigned' (thus nobody is working on any of them?), advanced search shows 632 reports of which only 101 claim fixed, leaving 531 'open', 'new', 'unconfirmed', 

ok, plenty (most) of them are dups, 

ok, windows (and mutter? and other programs/utilities?) sometimes have problems with copy&paste too, and such are interwoven with things happening in LO, 

ok, most likely the problem is inherited from OO, AOO has similar problems, 

ok, the impact in most cases is not trashing data but 'only' nagging users, 

but it's clear and often reproduced that: 

- LO has it's special weaknesses, pasting in LO often fails while pasting to other targets is possible, 

- pasting in LO has plenty different flavours of weaknesses, some entries for pasting working while others don't (paste / paste special), pasting old content, difficulties with formattings ... 

- the error does not always occur but irregularly, there is no reliable reproducibility, as this didn't work in hundreds of reports there is little hope that it is even possible,  

(it is also excessive to demand a reliable reproducibility for a fault that consists in the unreliability of a function) 

i am concerned about whether it is right to waste our efforts in managing these bugs and annoy users with requests that have very little chance of generating input or insights that are not already included in existing reports, 

imho it would be better to tell users 'we are aware of this and similar bugs, pls. check the existing reports (list) and look if you can contribute new insights, we are working on the problem', and 

- to work on the problem, look for the cause... 

can one of the programmers who has already worked on it make a summary (a 'big picture', a 'how is it meant to be', 'that's the plan', 'for this and that reason we used this and that workaround', 'this and that difficulties we know', 'here and there you can find it in the code', 'we suspect the weaknesses in that area') to give an introduction to people who want to fight against this bug? or is there such a thing already? i think this would be very helpful because neither reverse engineering in C++, nor the structure and code of LO are 'easy to understand' or 'self-explanatory' ... 


this (OP)nspecial description i couldn't repro in 

Version: (x64)
Build ID: 006c65bbd472cb1d7d44e095714e28190b76be0d
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

but from the general impression i belive there is a bug, rather than @kabilo and @Rick writing nonsense or fantasy ... 

@Rick: took some time to understand your issue, yes, you are right, paste special for copies from 'inside' calc should show another option screen, you get that for 'extern' or 'unknown source'? that's another flavour than @kabilo reported, just file another bug for that ...
Comment 13 Colin 2020-10-24 18:42:19 UTC
I regularly experience this problem and may be able to offer some further insights.

For me, it mostly occurs when copying highlighted data presented in an array from a web page but it also happens when an excel file has been downloaded from the internet and opened by CALC.

When the source is a web array then it's imåpossible to immediately tell whether the data has actually been copied by [Ctrl]+C as the attempt to paste or paste special appears not to have any data to copy because the "selection" box simply doesn't appear when [Ctrl]+[Shift]+V is invoked. However, if [Ctrl]+[Shift]+[Alt]+V is utilised this will "Often" produce the desired effect.

The anomaly can sometimes also be cleared by simply selecting another small item from the internet or a single cell from the existing sheet and randomly "pasting" that into a "scrap" location before returning to the genuine cut & paste.

What is noticable with a failing Calc to Calc copy is the lack of the "animated marquee" which would normally surround the source selection within calc. It will always be missing (perhaps the ants died) and will not appear regardless of how many [Ctrl]+C attempts are made. Again, shifting focus and producing a "scrap" cut and paste will often clear the error and permit the genuine task to be completed.

Given below are two Web targets that will fail almost as often as they succeed. Be persistent ;).

The first,


Select "View draw details and prize breakdown" this will sort the results in numerical order. Select the 7 results by mouse drag [Ctrl]+C and then [Ctrl]+V into a worksheet. It's fairly random so if it works first time then simply retry the sequence with a fresh sheet and selection attempt. Also, if it fails but the full [Ctrl]+[Shift]+[Alt]+V combination is invoked it will sometimes copy the data but in the original random order.

The second,


Mouse select everything from and including the "Sweden" label to the final cell of the "Östergötlands län #21" label and paste special as "unformatted text". There will be occasions when it works perfectly, occasions when it fails to provide the dialogue box, occasions when [Ctrl]+[Shift]+[Alt]+V will accomplish the objective and occasions when a lesser man would consider spinning the revolver's cylinder and seeing if he has the same success with russian roulette ;)).

If you need a good web source for an excel download that sometimes works first time I can provide any number upon request.

I have reset the report to unconfirmed.
Comment 14 Colin 2020-10-26 07:03:28 UTC

Many of my sheets have hyperlink buttons either to the web based information I'm pasting or other sheets.

When I say "first action", Im excluding the manual activation of the hyperlink as this doesn't impact Calc's identification of the "current active cell" so I am assuming that "internally", the attempted "paste" is the first Action.

I'm not 100% certain but I feel the anomaly occurs mostly when the paste is the first action on a newly opened sheet. I'm not sure if that's even relevant but it could prove to be the "Eureka moment" for a more technically aware investigator.
Comment 15 b. 2020-10-26 09:55:16 UTC
both samples from c#13 'norepro' one some dozen attempts with paste special (7.1 win7x64), but - as @Colin wrote 'ctrl-v' - normal paste - for the euro-jackpot sample i tried that: 

instand and reproducible 'not responding' when pasting into calc, only help close - restart - recover ...
Comment 16 Timur 2020-10-26 10:33:43 UTC
(In reply to b. from comment #12)
> but from the general impression i belive there is a bug, rather than @kabilo
> and @Rick writing nonsense or fantasy ... 
Of course there's a bug, there are many reports, like:

Simply, there's no value in making a new report, without searching first. Especially if there's no reproducible steps. 
Only maybe new thing here, to most frequent other reports, is that Ctrl+Alt+Shift+V is also not functioning.

I'm volunteer in QA. To fix any bug dev volunteer is needed. If bug is clear there's some chance, but if not, chances are less than slim. 
This is obvious shortcoming of volunteer model.

> this (OP)nspecial description i couldn't repro in Version: 
I noticed that long time ago and invited people to test with LO daily master. 
In the meantime, I'll close as duplicate. 
With so many bugs, not sure which is the closest, maybe bug 99818.

This one is probably duplicate, reporter should have searched before reporting.

*** This bug has been marked as a duplicate of bug 99818 ***
Comment 17 Timur 2020-10-26 10:37:12 UTC
Sorry, that one is Linux focused. Let's try with bug 57147. 
I know it's just guessing, but as explained also from my years of experience in QA, no dev will look in to this bug.

*** This bug has been marked as a duplicate of bug 57147 ***