Download it now!
Bug 128372 - VIEWING: No visible scrollbar arrow buttons in KDE5 Breeze even when configured in KDE Settings
Summary: VIEWING: No visible scrollbar arrow buttons in KDE5 Breeze even when configur...
Status: RESOLVED DUPLICATE of bug 130857
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-10-24 13:24 UTC by Peter
Modified: 2020-02-22 00:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2019-10-24 13:24:55 UTC
environment:
LibreOffice 6.2.7.1 (used with QT5 interface)
openSUSE 15.1
KDE5 (Plasma 5.12.8, Framework 5.55.0, QT 5.9.7, Widget Style Breeze)

In environment above, by standard settings the scrollbars don't have arrow buttons for stepping.
But it's possible in KDE System Settings to configure the scrollbars with one or two arrow buttons for stepping.
This works fine for the KDE applications, but not in LibreOffice.

In LibreOffice with 'one or two buttons' configured in KDE, there are small areas above/below on vertical and left/right on horizontal scrollbar, but they are 'empty', but I can use by 'blind' clicking on them the stepping functionality.

So I assume there is something wrong with the breeze style in LibreOffice, since when I switch to another Widget Style e.g. Fusion in KDE settings, I can see the buttons in LibreOffice (limited to one arrow button, since Fusion only allows one arrow button).
Comment 1 Xisco Faulí 2019-11-08 10:11:05 UTC
Thank you for reporting the bug.
Could you please try to reproduce it with the version 6.3.3.2 of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Peter 2019-11-09 07:32:00 UTC
Hello,

thanks for your help.

I installed version 6.3.3.2 (parallel to existing version to /opt/libreoffice6.3), but same problems here.

Without KDE integration module (libobasis6.3-kde-integration-6.3.3.2-2.x86_64.rpm), I get the 'rough' standard style with scrollbars and one arrow button for stepping.

With KDE integration module, I get a nicer style (Breeze), but no arrow buttons for stepping.
Comment 3 Peter 2019-11-09 07:42:45 UTC
to be more precise:

With KDE integration module, I get a nicer style (Breeze), but no VISIBLE arrow buttons for stepping.

As I described above, the buttons are unvisible, but work.
Comment 4 elmau 2019-11-30 18:25:59 UTC
Some user report this in Ask:
https://ask.libreoffice.org/es/question/219327/en-calc-no-me-aparecen-las-flechas-en-las-barras-de-desplazamiento-horizontal-y-vertical/

I test this in different SO, all test with LibreOffice Fresh 6.3.3:

Windows - Ok, see arrows

Arch|Gnome - Not see
LinutMint 19.2|Cinnamon - Not see
openSuse Tumbleweed|KDE - Not see
Kubuntu 18.10|KDE - Not see
Comment 5 Michael Weghorn 2019-12-13 08:32:52 UTC
Confirmed with

Version: 6.5.0.0.alpha0+
Build ID: 775a06361639ffc539fda20d44b9610c98005d9b
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Description how to enable those arrows in KDE Plasma settings: [1]

Currently kf5 VCL plugin doesn't use native Qt widgets. Implementing this would probably fix the issue "automatically", but is quite a lot of work.
It may well be possible to fix this specific bug independently, though.

[1] https://forum.kde.org/viewtopic.php?f=67&t=150658
Comment 6 Peter 2019-12-13 08:54:18 UTC
(In reply to Michael Weghorn from comment #5)
> Confirmed with
> 
> Version: 6.5.0.0.alpha0+
> Build ID: 775a06361639ffc539fda20d44b9610c98005d9b
> CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: kf5; 
> Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> Description how to enable those arrows in KDE Plasma settings: [1]
> 
> Currently kf5 VCL plugin doesn't use native Qt widgets. Implementing this
> would probably fix the issue "automatically", but is quite a lot of work.
> It may well be possible to fix this specific bug independently, though.
> 
> [1] https://forum.kde.org/viewtopic.php?f=67&t=150658

Hello Michael,

the strange thing is, that in principle the KDE5 Breeze Stile 'feature' to enable the buttons works in LibreOffice, but they are unvisible in LibreOffice.
It's not of big importance, but for my opinion kde5&Breeze is from design/layout not really barrier-free (which has nothing to do with LibreOffice, but with KDE). Th scrollbars are far to small and not suitable for some people.
Comment 7 Jan-Marek Glogowski 2020-02-22 00:54:04 UTC
This won't work without using the new "weld" theming API.

*** This bug has been marked as a duplicate of bug 130857 ***