Download it now!
Bug 130758 - kde5 VCL doesn't respect QStyle::SH_ScrollBar_LeftClickAbsolutePosition
Summary: kde5 VCL doesn't respect QStyle::SH_ScrollBar_LeftClickAbsolutePosition
Status: RESOLVED DUPLICATE of bug 130857
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2020-02-18 14:06 UTC by tempel.julian
Modified: 2020-02-22 00:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tempel.julian 2020-02-18 14:06:30 UTC
Plasma 5.18 allows to be configured so that left clicking (not just middle clicking) scroll bars in Qt UIs instantly jumps to the position of the cursor (and keeps on dragging the scroll bar when keeping the button pressed).

This doesn't work with LibreOffice kde5 VCL (e.g. in Writer), as it doesn't seem to respect QStyle::SH_ScrollBar_LeftClickAbsolutePosition.

It should do that so that it behaves like other Qt UIs.

Reported coming from here:
https://bugs.kde.org/show_bug.cgi?id=379498
Comment 1 Nate Graham 2020-02-18 16:16:32 UTC
Confirmed.
Comment 2 Julien Nabet 2020-02-18 17:51:56 UTC
Michael: thought you might be interested in this one since it's KDE specific.
Comment 3 Michael Weghorn 2020-02-19 17:31:43 UTC
As far as I know, LibreOffice does not use a native QScrollBar (and most of the other native Qt widgets), but rather paints a scrollbar that is supposed to look like one, which may be the reason that it does not work "out of the box".

If somebody wants to look into this: From a quick glance, the code for painting the widgets is in 'vcl/qt5/Qt5Graphics_Controls.cxx'; the handling might be somewhere there or elsewhere, maybe not even in qt5-/kf5-specific code.

FWIW, the "gen" VCL plugin behaves the same, while gtk3 (which *might* already use native gtk widgets due to Caolán's welding work, but I don't know) behaves as it should.
Comment 4 Jan-Marek Glogowski 2020-02-22 00:51:27 UTC
This won't work without using the new "weld" theming API.

*** This bug has been marked as a duplicate of bug 130857 ***